CD-Recongition Problem

I recently purchased a Pentium-166 mhz cpu with a 2 gig hardrive for 25 bucks. I formatted and upgraded to Windows 98. It worked fine, except Windows refuses to recognize the Atapi cd-rom drive. It works- Bios recognizes and I used it to install windows in the first place. The jumper setting is correctly placed on master. Also I think its important to point out that if i use a 98 boot disk to boot into dos-the drive is recognized. What can I do to fix this? Do i have to alter config.sys?
redruntyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shivsaCommented:
i would say download the latest driver for cd-rom drive, install drivers reboot the system and see if it gets recognized.
0
shivsaCommented:
also check this link.
it state the problem with ATAPI versus Win98.
http://www.experts-exchange.com/Operating_Systems/Win98/Q_11056023.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CallandorCommented:
How about copying the driver from the Win98 boot disk?  It seems to work, as you say.
0
shaharidzalCommented:
Try this options:
1- Open Control Panel | System | Device Manager
Check the IDE Dual Channel Controller and make sure that you have both Primary and Secondary controller working without any 'exclaimation' mark.

2- Download the motherboard chipset drivers software.
   Intel:      http://www.intel.com/support/chipsets/
   VIA:       http://www.viaarena.com/?PageID=300
   SIS        http://download.sis.com/index1.htm
Read the page carefully for Windows 98 support as most of the drivers are now Win2K/XP optimised.

3- Create a Folder
    Copy the CDROM driver into this folder. The file is normally name like AOATAPI.SYS, GSCDROM.SYS or CDROM.SYS. There must be one in your Win98 startup disk.
Edit CONFIG.SYS (add the text below at bottom line).
Example: You create a folder name MYCDROM and a CDROM.SYS is the driver)

DEVICE=C:\MYCDROM\CDROM.SYS /D:MSCD01
LASTDRIVE=Z

Save the file.
Next, edit AUTOEXEC.BAT and add this at the end of the line.

C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD01

Save the file and make sure that both CONFIG.SYS and AUTOEXEC.BAT is place at C:\  (root)
Restart your PC. What happen here is that the CDROM will be loaded at DOS and Windows will the use it MS-DOS Compatibility Mode to recognise the CDROM. However your CDROM will work slower as Windows will not be able to cache data from CDROM.

Good luck.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.