how to query MSysObjects (using Java)

I have a Java app which reads .mdb files like so:

       Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
        // we are using the direct connection method rather than the DNS method
        String database = "jdbc:odbc:Driver={Microsoft Access Driver (*.mdb)};DBQ=";
        database+= filename.trim() + ";DriverID=22;READONLY=true}"; // add on to the end
        Connection con = DriverManager.getConnection( database ,"","");
        ResultSet rs;
        DatabaseMetaData metaData = con.getMetaData();
        // find out what tables and queries are in the database, and display their names
        rs = metaData.getTables(null,null,"%",null);

... which works great, however

I want to query against the system tables in the .mdb, specifically MSysObjects and MSysQueries to get som more structural info, but I get error:

java.sql.SQLException: [Microsoft][ODBC Microsoft Access Driver] Records can not be read; no read permission on 'MSysObjects'.

from the line:
Statement s = con.createStatement();
ResultSet rs_test = s.executeQuery("SELECT * FROM MSysObjects");

I am sure I solved this problem befor by tweaking a setting in Access, but I can't  remember how I did it. I have enabled viewing of the hidden and system tables, but this did not solve it. any help would be great!
kengoudswardAsked:
Who is Participating?
 
jobrienctCommented:
this thread appears to describe your problem quite well, albeit from a coldfusion perspective, the issue is securty settings i believe, read down past the original answer.

hth

John
0
 
kengoudswardAuthor Commented:
John, Thanks for the help
the thread you pointed me to said to...

Open up the database in Access, go to Tools, Options, View and select Hidden
and System objects.  

... which I had already done and wasn't the problem, but it was close. After a bit more playing around (and some sleep, and a new day)

I went to Tools, Security, User and Group Permissions
where I gave read permissions to all users and groups on the tables of interest; now it works!
0
 
jobrienctCommented:
sorry, you read me wrong - i told you to scroll down passed the accepted answer a bit to where they talked about the security settings.

ahh well, next time I'll be more specific :)

thanks for the question,

John
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.