Debian Linux - Terminal Type

Hi

I am using SSH puTTy client to login to my Debian Linux Server, however after upgrading, it no longer likes the 'xterm' terminal type.

When i issue commands such as 'clear' or 'top' i get:

'xterm': unknown terminal type.

I have tried various others: vt100, linux etc etc.



Rik.
angelousAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Karl Heinz KremerCommented:
What did you upgrade, the server or puTTy? Which terminal is reported when you log on the server using the console? The system should know linux, vt100 or xterm.
0
angelousAuthor Commented:
hi

i upgraded debian, using apt-get upgrade. then the next time i logged in this started to happen.

when i dont set a term type and run


root@xbox:~# echo $TERM
dumb

Hope this helps.
0
Karl Heinz KremerCommented:
Did you install the terminfo package?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

angelousAuthor Commented:
Well i havnt actively installed that seperately. How do i get and install that? Or detect if its present.

My server is telnet administered only.


Rik.
0
Karl Heinz KremerCommented:
To find out if you have terminfo installed, check the directory
/usr/lib/terminfo
The directory contains sub directories with letter names. If you are looking e.g. for the xterm description, go to the x directory and see if the xterm file is there.

I've never used apt-get (or Debian), but I think the command to install it is
apt-get install terminfo

You could do a
apt-get --dry-run  install terminfo
first to see if it would even install the package.
0
angelousAuthor Commented:
hi

no such directory.

i run that command but says no package found.

this is most annoying as i cant see any realy reason why an upgrade would do this?



rik.
0
Karl Heinz KremerCommented:
I just found this on http://www.debian.org/doc/manuals/reference/ch-tips.en.html:

--------------------------------------------------------------------------------------------------------------
8.6.9 Set console to the correct type
Console screens in Unix-like systems are usually accessed using (n)curses library routines. These give the user a terminal-independent method of updating character screens with reasonable optimization. See ncurses(3X) and terminfo(5).

On a Debian system, there are quite a lot of predefined entries:

     $ toe | less                  # all entries
     $ toe /etc/terminfo/ | less   # user reconfigurable entries
Export your selection as environment variable TERM.

If the terminfo entry for xterm doesn't work with a non-Debian xterm, change your terminal type from "xterm" to one of the feature-limited versions such as "xterm-r6" when you log in to a Debian system remotely. See /usr/share/doc/libncurses5/FAQ for more. "dumb" is the lowest common denominator for terminfo.

--------------------------------------------------------------------------------------------------------------

Try the toe command to see if it's there. This should list all known terminal types. If this also fails, we have to figure out why the apt-get does not work.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
angelousAuthor Commented:
Thank you so much. You Have saved me a big headache.

Your help is much appreciated.


Rik.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.