Solved

Cannot attach to password Database

Posted on 2003-12-09
4
7,166 Views
Last Modified: 2013-12-09
Hi,
We developped an application based on Interbase 7. It works
fine on developpers computers but final user cannot execute the program :
he gets this message : 'Cannot attach to password database'.
Developpers and users are using the same interbase server. If any
developpers is already in the program, the final user has no problem, it
works fine.

If I open a Windows session on his computer with my login/pass and launch
the program, it works
fine.
If I opens a Windows session on my computer with his login/pass and launch
the program, I get the famous message

If the system administrator give the user the same windows rights as I have,
it work fine for everybody (except for the sys admin who doesn't like such
situation... :-)  )

So,it seems that final user needs some specifics righth, but witch ones ?

Note : Dephi7 arch / Clients : windows XP / Server Windows 2000

Thanks for any help

Mike
0
Comment
Question by:EKIM
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 6

Expert Comment

by:BAlexandrov
ID: 9905549
What your connection string looks like? Do you use tcp to connect?
0
 
LVL 2

Expert Comment

by:vowca
ID: 9910466
Is IB runned as service or as application?
If service - does it have 'Interact with desktop" option on?
If application - maybe user has no grant for isc4.gdb file or IB steeings in registry?

Also i heard about bug in IB and clones - if You connect via NetBEUI (string like \\\MyPc\some-database) then Your user should have grants for both GDB file - password and data databases.
With local and TCP connetcion it is enough to grant access for user, used to launch ibserver.exe, but with NetBEUI both must have grants.
0
 

Author Comment

by:EKIM
ID: 9911963

connection string : \\DBServ\D:\Myappli\DB  
where DBServ is the network name of the Interbase server machine, and D: is the Local drive (from the server view)


IB runs as service, and it have 'Interact with desktop" option on

I don't know how to say you I I use TCP or NetBeui protocol.

Best Regards
Mike
0
 
LVL 6

Accepted Solution

by:
BAlexandrov earned 250 total points
ID: 9912110
You use NetBeui - this depends on connection string. Change it to:
DBServ:D:\Myappli\DB
or
ip_of_your_server:local_physical_path_to_file_on_server.gdb

Netbeui is not recomended way to communicate with Interbase. And it is removed from later versions
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Entering a date in Microsoft Access can be tricky. A typo can cause month and day to be shuffled, entering the day only causes an error, as does entering, say, day 31 in June. This article shows how an inputmask supported by code can help the user a…
Creating and Managing Databases with phpMyAdmin in cPanel.
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question