Solved

Domino HTTP Server Not Starting

Posted on 2003-12-09
8
2,599 Views
Last Modified: 2013-12-18
When loading the HTTP task (R6.5, OS 400/V5R2), the following log info appears:  

> load http
load http
12/09/2003 09:00:53   HTTP Server: Using Web Configuration View
12/09/2003 09:00:54   JVM: The lotus/notes/internal/AgentOutputStream class could not be loaded.
12/09/2003 09:00:54   JVM: Registration of JVM native methods failed.
12/09/2003 09:00:54   JVM: Java Virtual Machine failed to start
12/09/2003 09:00:54   HTTP Server: Error Loading Java Virtual Machine
12/09/2003 09:00:54   HTTP Server: JVM: Missing entrypoint in JVM runtime library.
12/09/2003 09:00:55   HTTP Server: Shutdown


Any ideas?

Thanks,

Justin
0
Comment
Question by:justintx
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 9905051
Check your notes.ini for JavaUserClasses parameter and remove any path/reference to NCSO.jar, notes.jar and jsdk.jar (which are R5 java files) and leave out the jt400.jar (For R6)

~Hemanth
0
 
LVL 3

Author Comment

by:justintx
ID: 9905122
hmmm... checked both the notes.ini file of a server that works properly and of the one that doesn't.  neither contain the JavaUserClasses parameter.

Justin
0
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 9905536
If it doesn't contain then set it up to look for jt400.jar

eg:

JavaUserClasses = c:\lotus\domino\data\java\jt400.jar

0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 3

Author Comment

by:justintx
ID: 9906359
ok, tried that, but jt400.jar does not exist on either server.  this is odd, since my server that works just fine seems to lack this file.  here are all the .jar files on my servers:

actionbar.jar
dconsole.jar
dominoapplets.jar
domtags.jar
editor.jar
jakarta-regexp-1.1.jar
LotusXSL.jar
NCSO.jar
nvapplet.jar
outline.jar
uninstall.jar
XML4j.jar

any more ideas?  thanks for the help so far.

Justin
0
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 9906517
Then try setting tools.jar and rt.jar in the parameter.. they should be under domino\jvm\lib
0
 
LVL 31

Accepted Solution

by:
qwaletee earned 200 total points
ID: 9909180
Re-insatll.  It is fairly difficult to debug code setup problems on iSeries.  And it sounds like you either lost, hosed, or mislocated some class files.
0
 
LVL 3

Author Comment

by:justintx
ID: 9966826
it turned out to be either a reinstall (thanks qwaletee) OR a PTF update that solved the problem.  thanks, all.

Justin
0
 

Expert Comment

by:whoopit
ID: 24701875
I've got this very same problem on a windows 2003 server after upgrading Domino from 7.0.3 to Domino 8.5. IBM support suggested that I reinstall Domino and this has not helped . . .

Has anyone seen this before on Windows 2003 server or has suggestions for a fix??
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For users on the Lotus Notes 8 Standard client, this article provides information on checking the Java Heap size and adjusting it to half of your system RAM in attempt to get the Lotus Notes 8.x Standard client to run faster.  I've had to exercise t…
I thought it will be a good idea to make a post as it will help in case someone else faces these issues. I trust this gives an idea how each entry in Notes.ini can mean a lot for the Domino Server to be functioning properly. This article discusses t…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question