need to delay automatic login of work stations ...

hi to everybody
i have a main server contains data and work stations that conncts via ODBC to the main server.
the main server and the work stations has automtic login script, however when power fails, i need that the main server will boot firstbecause the work stations has programs that needs ODBC connectivity to main server, otherwise they will crash.
what will be the way to delay the boot up or the login of stations after power failure? delay needed is about 30 seconds.
michael
Info_user100Asked:
Who is Participating?
 
oBdACommented:
Your best bet is the boot menu.
On the workstations in question, remove the "read only" attribute from C:\boot.ini.
Set the timeout to 30 seconds (or whatever you need).
Then simply copy the line under "[operating systems]", so that you have it twice. (You could change the menu string to something "Waiting for server to boot ...")
Set the "read only" attribute again.
If a user is sitting in front of the machine, knowing that the server is already up, he can just hit "enter" to bypass the timeout.

Your boot.ini would then look about like that (do *NOT* use this example to replace your own boot.ini, the ARC path might be different!):
====8<----[boot.ini]----
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Waiting for server to boot ..." /fastdetect
====8<----[boot.ini]----

If you want to make the second entry a useful one, you can install the recovery console instead of copying the default path.
HOW TO: Install and Use the Recovery Console in Windows 2000
http://support.microsoft.com/?kbid=318752
0
 
Fatal_ExceptionSystems EngineerCommented:
Assume you are using Group Policies to push your logon scripts.  You can also try setting the number of cached profiles to '0', or perhaps enable 'Delete cached copies of roaming profiles' using GP.  This would force the client to wait for the DC to boot up.  Find it located in Computer Config > Admin Templates > System > Logon.

Let me know if this works for you.

FE
0
 
Fatal_ExceptionSystems EngineerCommented:
Oh, forgot to direct you to the first tip :)

Number of Previous logons to cache = 0, go to: Computer Config > Windows Settings > Security Settings > Local Policies > Security Options.  

Try this first.  It usually works quite nicely.

FE
0
 
Fatal_ExceptionSystems EngineerCommented:
oBdA...  Now that is a great idea.  Never thought of the boot.ini fix.

Happy Holidays.

FE
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.