IIS 5.1 - inetinfo.exe goes to 100% cpu usage on ANY http request

Well this problem just started happening.

my inetinfo.exe just goes to 100% cpu usage for any http request.  I've tried resetting my computer, restarting IIS and reconfiguring pretty much every option i have.  I first noticed this problem after a hard reboot 2 nights ago, and I can't seem to fix it or find any relevant microsoft hotfixes.

when IIS is active all I have to do is request http://localhost/ and the thing locks up.  I can end task it, but the page is never generated and eventually IE times out.

has something been corrupted, and if so, how do i fix it?
has my configuration changed, and where was it changed?


im running IIS 5.1 (winXPpro w/ SP1)
not running SMTP server
not running FTP server
not running Web Printers
not running FrontPage Extentions
LVL 2
zerorealityAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tacobell777Commented:
Does it spike or stay at 100% after the first request?

What happens if you leave it alone for a while, does it go down, produce an error?

Have you looked at the event viewer for any related problems?
0
zerorealityAuthor Commented:
it stays there.  even if i have the page from cache and i load a missing image the inetinfo just goes nuts and stays that way.
it never throws an error, and it doesnt go back to normal

the event viewer only logs my forced quits, nothing else...
example:
The World Wide Web Publishing service terminated unexpectedly.  It has done this 13 time(s).
The IIS Admin service terminated unexpectedly.  It has done this 13 time(s).
0
Tacobell777Commented:
These are no forced stops or restarts

The World Wide Web Publishing service terminated unexpectedly.  It has done this 13 time(s).
The IIS Admin service terminated unexpectedly.  It has done this 13 time(s).

what else are you running on your machine? Anything like ColdFusion or ASP?

Do you knwo when this started happening? Right after something?
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

zerorealityAuthor Commented:
well, forced in that it wouldnt stop on its own and i had to "end-task" the thing.

i was running ASP, but i went back to just htm files and it does the same thing.
nothing but ASP and MySQL... which were working perfectly until recently

this started happening on December 8th, thats when the first hang ups started happening.  i remember i tried to run star wars jedi academy and my monitor turned off (ati drivers bug) and wouldnt come back on, so i had to hold the power button for 4 seconds to make my computer boot again.
0
Tacobell777Commented:
LOL you are running games on a webserver ;-))

Hmm reinstall sounds like a good option..

Uninstall the game first is another option.
I wasn't really after a date but more like a specific event you can remember, like installing the game for example...

Turning the computer off the hard way might have corrupted something in IIS, the metabase maybe?
A reinstall is not to difficult, easily done...
0
zerorealityAuthor Commented:
this is my home computer... i use it for development as well

i really wasnt to avoid a complete reinstall of windows if at all possible.  if the metabase was corrupt, how would i go about replacing it?
0
Tacobell777Commented:
You don't need a complete reinstallof your operating system, just IIS.


Go to control panel -> windows components -> internet information services remove it, and reinstall it it.
0
zerorealityAuthor Commented:
I tried that, but i encountered the same bug.

however, last night i was trying new things and turned off authentication for my NIC.
i then turned the Application Protection process pool from Low to Medium and suddenly eveything was back to normal.

When i turned NIC authentication back on... inetinfo did not go back to 100% cpu usage.  to this day i STILL cant duplicate the bug, but it must have had something to do with the Application Protection in IIS and some kind of authentication.

So I have a NEW question for 500 points  :)

My scripts don't use any Application, Cookie or Session objects, just an ADODB object, so how was the Application Protection affecting the performance of inetinfo.exe?
0
Tacobell777Commented:
One of my questions was "Do you know when this started happening? Right after something?"

I reckon your answer should have been, yeah right after I enabled "Authentication on my NIC and changed some other settings"
Anyway, I'm out.......
Good luck..
0
zerorealityAuthor Commented:
thing is, this STOPPED happening after turning that off
i hadn't touched it since i installed windows...

so this didnt start right after i turned it on, it was always on.
0
JackfyCommented:
I have the similar situation, while I don't have any games intalled. Thing seems happened after couple of server hang (dead). I tried reinstall the IIS but doesn't seem work. I would like to see the solution as well.
0
moduloCommented:
PAQed with points refunded (500)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.