Network LAN Setup

I have the following setup at home. Two computers running Windows XP Pro are connected to a Linksys Wireless router, (one directly using a cable, one thorugh a wireless card). The router is connected to a cable modem and both computer can access the Internet. The problem is that the computers cannot see each other. I would like to be able the two computers to share files and printers.

Could you provide stepby-step instructions on how to configure the two computers so that they are aware of each other.
LVL 5
msmolyakAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chicagoanCommented:
Are they in the same workgroup?
Can you ping one from the other?
0
Duncan MeyersCommented:
You haven't got the XP Internet Connection Firewall turned on by any chance? Or Zone Alarm installed on the machines?

Just a thought...
0
Duncan MeyersCommented:
You haven't got the XP Internet Connection Firewall turned on by any chance? Or Zone Alarm installed on the machines?

Just a thought...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

msmolyakAuthor Commented:
I have not set up any workgroups. I simply connected each machine individually to the router and thus to the Internet. I did not try to configure them into the LAN. That is what I am trying to do now. How do I create a workgroup and how do I add them to the workgroup? What IP address do I use to ping the machines? I assume the router assignes the addresses dynamically.
0
msmolyakAuthor Commented:
I have a McAffee firewall on one of the machines.
0
Duncan MeyersCommented:
Easy!

First, check the IP addresses of the two PCs by running ipconfig from a cmd prompt. The addresses should be different on the two PCs and aalmost certainly assigned by the internet access box.

Most likely the two PCs are already a member of the workgroup "WORKGROUP" by default. You can check this by right-clicking on My Computer, Properties and select the Computer Name tab. The computer names should be different, but workgroup should be WORKGROUP (or whatever you select). If you open My Network Places and select Entire Network in the left hand pane, you should see WORKGROUP (or your workgroup name) pop up in the right hand pane. Double click on the workgroup and you should see both PCs.

If you do not see both PCs, you may need to enable NetBIOS over TCP/IP.  (Start - Network Connections-LAN Connection - Properties - TCP/IP Properties - Advanced WINS tab and ensure Enable NetBIOS over TCP/IP is enabled).

Next, on one PC open My Computer and select Tools -> Map Network Drive. Type in \\<IP address of other PC>\C$ and click on Finish.  That should map a drive.

Having said all that I see that you have McAffee firewall installed on one machine - this is almost certain to be blocking attempts to connect from one machine to another. To check - disable the firewall (probably a good idea to disconnect the internet router from the 'net while you test this) and try and map a drive. If it works - bingo! I can tell you how enable a local network in Zone Alarm and Sygate Security Agent - but I don't know the McAffee product. I would think that there is an Options setting that allows you to define a local network and permit all traffic for that network.

Hope this helps.
Duncan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chicagoanCommented:
Get them into the same workgroup by right clicking on My Computer, properties, name
0
Duncan MeyersCommented:
>Get them into the same workgroup by right clicking on My Computer, properties, name

I think I said that already...
0
chicagoanCommented:
that was the Cliff Notes of your post
:)
0
msmolyakAuthor Commented:
No need to bicker, gentelmen, I can read.

meyersd, could you give me the info in disabling ZoneAlarm. It turned out the second desktop runs it. (I think I took care of McAffee).

I was able to see one computer from another, which was a big progress. However after rebooting one of them I lost all contact and had to reboot it again to access the shared directory.

I will keep this question open for a few more days while trying to understand what is going on.

Thank you for your help.
0
Duncan MeyersCommented:
>No need to bicker, gentelmen, I can read.
LOL :)

The easiest thing to do is to put your LAN in a trusted zone.

From the system tray right click on Zone Alarm ->  Restore Zone Alarm Control Centre. On the left-hand pane of the Control Centre select Firewall. Select the Zones tab. Select Add -> IP Range. In the dialogue box that pops up, select Trusted. Enter the first address of your address range (for example: 10.10.3.1) then enter the end address of your address range (for example 10.10.3.255) and enter a Description, then click OK. Click Apply. Done!

Incidentally, (and off-topic a bit) you can use ZoneAlarm to help control spam if you're on a corporate LAN. From the Program Control tab you can allow your mail reader access to the local network but block access to the internet. It helps with the spams that downloads jpegs from a remote server thus identifying you to the spammer. FWIW.


0
chicagoanCommented:

>I was able to see one computer from another,
 did you change something?
are you losing your wireless connection?
0
msmolyakAuthor Commented:
I checked ZoneAlarm settings, they do seem to allow all the local trafic.

Now I try to open the shared folder on one computer from another I get the following message:

\\computer-name is not accessible. You might not have permissions to use this network resource. Contact...
The network path not found.

The last part truly puzzles me. I di not change any options after making sure that both computers belong to the workgroup with the same name and shring the directories on the computers. I get the same message when I click on "View workgroup computers" and select the second computer entry to expand it.

Yesterday I was able to access the shared drive and no changes were made.
0
msmolyakAuthor Commented:
I am also unable to ping either computer. Both are connected to teh Internet.
0
Duncan MeyersCommented:
ZoneAlarm blocks incoming ICMP/pings and I presume the McAffee product does as well.

The thought occurs to me: do you have a bad/intermittent ethernet cable perhaps?
0
msmolyakAuthor Commented:
Sorry, for not respinding earlier.

I completely lost the connection between the two machines. They both have connection to the internet (one wired, one wireless). I tried disabling both firewalls. It did not have any effect. Neither machine can see the other.

Any suggestions?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.