Solved

Palm Desktop 4.0 won't Launch on my G4, OS 9.2 because: ERROR #-50. Help!

Posted on 2003-12-09
18
1,382 Views
Last Modified: 2010-04-25
This all started over a month ago as an occasional crash while working with multiple applications at the same time... It would say: "UNEXPECTED ERROR #-50, QUIT". I would have to click the QUIT button 3 times and then I could try to relaunch it. At first this worked, but soon I had to restart the G4 to get the palm desktop to re launch.

Then 1 day, 2 weeks ago, it would not launch no matter what I tried (ie. restart+reset the desktop...) I tried to reinstall/uninstall from the disc, nothing worked.

I called PalmOne and finally spoke with a  Level 2 technician who told me that the error message meant the USER DATA was CORRUPT (FYI, everything still works on my treo 270 handheld!)
The Level 2 guy told me to throw out everything "palm", which I did.

We REINSTALLED the Palm Software 4.0 that came with my treo. Then, we created a new user (same name as before), and HOTSYNC'd with conduits set to OVERWRITE THE DESKTOP. 10min. later, I had my desktop restored! All the info, but with none of the links, of couse. It worked for a week, then the "UNEXPECTED ERROR #-50, QUIT" started happening again.... Tonite it won't open at all again.

 I need this user data to run my business... I don't know what to do. Can this data be debugged? Like a disc warrior for Palm or something?

-Luke
0
Comment
Question by:RAYDOOR
  • 8
  • 7
  • 2
18 Comments
 
LVL 30

Expert Comment

by:weed
Comment Utility
Not really. But you MIGHT be able to reconstruct the file by exporting all your data, deleting everything palm, reinstalling it, then IMPORTING the exported files. That might rebuild enough to get around the corruption.
0
 

Author Comment

by:RAYDOOR
Comment Utility
The PalmOne guy mentioned that, but there is no gaurantee... I am worried about this because I spent at least a week linking my files on the desktop only to have that work go to waist when the Desktop crashed again...  maybe if there were a way to preserve the links between memos, addresses, todos...etc because if it crashes again  it's all lost.

thanks for the quick response!

-Luke
0
 
LVL 30

Expert Comment

by:weed
Comment Utility
If the database is hosed there's not much you can do. Make sure you're running the very latest Palm Desktop too.
0
 

Author Comment

by:RAYDOOR
Comment Utility
I am running 4.1 as of last night... here's the funny thing though...
Last night, I uninstalled all palm software from my ibook (not the g4), and reinstalled it from the 4.0 cd that came with the treo. I was then able overwrite (using the same user name) from my handheld. ?? HOW can the data be corrupted if it working fine on my g3 now?
This is the same thing I did last week, so I assume it's only a matter of time before it crashes on the g3 like it did on the g4.... but I gotta believe it has something to do with "attachement" feature on the Desktop.... cause' things work fine on the hand held, and things work fine on the desktop for now... what could be triggering the eventual crash? I am hoping, by using the ibook for PALM ONLY, that I can sustain the desktop's stability....

What do you think? Thanks for paying such close attention to my case!

-Luke
0
 
LVL 30

Expert Comment

by:weed
Comment Utility
I would take the Palm Desktop disc that you got with the treo and throw it away. It's old software. Use the 4.1 version. Maybe it is the linking parts. I dunno. Maybe your G4 has some filesystem issues. Maybe it needs a run of Norton Disk Doctor, Disk Warrior, FSCK, Repaired Permissions etc.
0
 

Author Comment

by:RAYDOOR
Comment Utility
I did have a major crash about 3 months ago... I had to use Disk warrior to get it fixed... my G4 would not respond to any comands and the blinking mac icon was all I would see...

I often run the following at the same time: Fax STF / Palm Desktop / Outlook express / Adobe Illustrator / Vellum... Honestly, I have always suspected the Fax STF as the culprit... things seem to go haywire sometimes when I use it.... heard anything about that?
-Luke
0
 
LVL 30

Expert Comment

by:weed
Comment Utility
Yeah, FaxSTF is a bad one, so is OE. You could eliminate FaxSTF by updating to OS 10.3 and eliminate OE by using the Apple Mail.app program which is much nicer anyway. You could actually even eliminate Palm Desktop by using iCal, and Address Book with iSync.
0
 

Author Comment

by:RAYDOOR
Comment Utility
I have been avoiding OS 10 because I have older versions of software... and the guys at Digital Society (my local MAC shop) say the 10 does not work well with the faxSTF....

Should I ditch faxSTF and buy a fax machine? is this software screwing me up?

FYI i have an additional hard drive on my G4 that was put in after my crash 3 months ago... it's partitioned. One half is supposed to be BACK UP, the other, they said, was for when I wanted to upgrade to 10... Is that right? because I have a feeling this HD I'm on now may be getting close to shot... I like the idea of starting a new.. Am I thinking about this correctly? Or should I just UP to 10 on the existing HD?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 30

Expert Comment

by:weed
Comment Utility
Once you go 10 youll never go back. FaxSTF doesnt work well with ANY OS version but at least with OS X Faxing is built into the OS and works better than STF.

It's impossible to say in this instance if STF is the culprit so i wont guarantee you that buying a fax machine will solve it. OS X is a way better solution.

Dont put OS X on a partitioned HD. Some people do it but theyre nuts. Just put 10 oon the HD you have. The biggest one.
0
 

Author Comment

by:RAYDOOR
Comment Utility
I will... now that I have crashed this hard... revamping everything for 10 is the only thing that makes sense... before I close this out.. I want to mention that the HD i am on now is 38 GB and the other one is 80 GB but it's partitioned equally... still start up from my old drive?

thankx -LUKE
0
 
LVL 30

Accepted Solution

by:
weed earned 500 total points
Comment Utility
Actually, i'd departition the 80 gig, put OS X on that, and use the 38 gig for backups.
0
 

Author Comment

by:RAYDOOR
Comment Utility
Thanks a lot for your help... I think I know what I am going to do to upgrade my system now.... I have able to use the ibook with my old data for a 1-1/2 days now... I will keep linking the files and using it the way I used to... meanwhile I will upgrade the G4 to 10.... is departitioning something I should have the MAC shop do...?

Thanks again!

-Luke
0
 
LVL 30

Expert Comment

by:weed
Comment Utility
You dont need to take it to a shop for something as simple as a fresh start. Repartitioning it with one partition can be done from the OS X installer CD.
0
 

Author Comment

by:RAYDOOR
Comment Utility
REpartitioning? ...don't you mean UNpartitioning?

There are 3 HD icons on my desktop now : Mac HD(currently in use), Backup HD(1/2 of the new 80), OS X HD(the other 1/2 of the new 80). I thought you said make the old Mac HD the back up, and consolidate the 2 halves of the new HD into 1 when I launch on X...

youve been very helpful, only comment further if you have the time...

thanks again  -Luke
0
 
LVL 30

Expert Comment

by:weed
Comment Utility
You dont really de-partition. Youre just repartitioning it with one. Though even a disk with one partition actually has several that you cant see.

Make your biggest HD the one you install OS X on.
0
 

Expert Comment

by:umobled
Comment Utility
Hi Luke

I am experiencing the same problem that you have described.  Can you email me at **Removed by Weed**?  I have an idea of why this is happening
0
 

Expert Comment

by:umobled
Comment Utility

See the below posts - Sorry for the size of this message but I think it will help

Umobled




Subject: Palm Desktop 4.0 error - unexpected error -50
Posted by: Damien
Posted on: 02/05/2003

Palm Desktop 4.0 error - unexpected error -50

[Link to this article]
PROBLEM: I've been using Palm Desktop 4.0 for awhile without any problems. However, yesterday when I tried to open the Palm software, I started recieving the error, "Unexpected error -50" and the program wouldn't launch. Is my Palm data gone? Help!

SOLUTION: I dont know what's causing this corruption of the user data file, but I have a solution for you. Error -50 has something to do with an error in the user perameter list, which eventually led me to discover this solution:

1) Locate your Palm User Data folder (in OS X, it's in ~/Documents/Palm/; in Mac OS 9, it's in /Documents/Palm/ or sometimes in the Palm Desktop application folder itself). Back it up.

2) Throw away the original user data folder.

3) Open the Palm Desktop Application and create a new user with the same name as your original data folder. If Palm Desktop still sees the original user, you may have to play around with creating User 2 to delete User 1, switching to User 2, deleting User 1, then making your new user with the same name as original, and finallly deleting User 2. Yeah, it's confusing, but look at the order--it'll make sense as you do this. Palm won't let you delete a user currently "loaded" or "active".

4) Finally, once you have your new user data file (it should be completely empty of info), go to the File menu and select Merge. Target your backed up data file and it will merge all the old data into your new and now uncorrupted user data file.

Alternatively, if your Palm handheld is up-to-date, you can simply hotsync it to a brand new user data file. This is the simplest solution, of course, but now many of us actually have up-to-date handhelds? :)

Replies: 49 comments

That's funny: I had to do this recently, too. This solution works like a charm. Posted by: Grant Barrett at 02/05/2003 11:35 PM EST
That's weird! I have lost my file 4 times in last 2 months due to this---as late as this morning! I didn't have your solution so i had been going to my palm handheld & resynching ( since losing my files I back up once a week).
I think I found a root cause though---it happens to me when I sleep my mac powerbook without quitting the palm desktop. Posted by: Warren Harkness at 02/10/2003 07:07 AM EST
Thanks for having a solution ready when my turn came. I have the same experience as Grant - the troubles started after my iMac went to sleep and Palm Desktop was open. Posted by: Mikael at 03/03/2003 07:38 PM EST
Thank you! I've been in a complete panic thinking that I'd lost everything. Posted by: JK at 03/12/2003 08:05 PM EST
Bizzzzar! I was going great and then the error message. I deleted the user file and I did a hotsync as my handheld was up to date. No problem - Thanks Posted by: Droid at 03/20/2003 05:29 PM EST
The first time this happened, I coundn't find a solution online, so I initialized and reinstalled my entire hard drive. That seemed to work.

This time, I followed the reporter's direction and still got the error. But the idea of a corrupted identity file made me think PREFERENCES. So I went into my System Preferences folder and trashed the Palm Desktop prefs and anthing else Palm. Worked like a charm. And I didn't have to reformat my hard drive!
Posted by: Kevin at 03/22/2003 06:18 PM EST
I had the "Unexpected error #-50" problem. Fortunately I didnt ditch my user data and I was able to open a blank file in palm, then select: FILE / MERGE... and then got the info out of the old file. So learn a lesson from this... PRINT OUT YOUR PALM INFO... and store it somewhere. So you at least have a paper backup you can rely on if something nutty happens again. Posted by: Adam Hill at 03/24/2003 12:44 PM EST
This solution was terrific. Nothing on the Palm Support site was nearly as helpful. Thank you so much! Posted by: shea at 03/27/2003 12:34 AM EST
I spent days of troubleshooting before finding this info! It worked for me too. One thing though - it might help to clarify that one needs to go into the Hot Sync drop down to edit users.

Thanks for the info! It's made my day.
Posted by: Barbara at 04/17/2003 02:36 PM EST
Damien's response worked for me as well. Thank God! All of a sudden, from out of the blue, I get an "Unexpected Error #-50" on my Palm Desktop. (I have a Palm m505 and run System 9.2 on a Power Mac G4.) I found NOTHING that could help me on Palm's website. Appletechs - you guys saved me a lot of trouble!

Da
Posted by: Jeff at 04/18/2003 08:39 PM EST
Thanks for the fix!!! I got the "Unexpected Error #-50" just when i needed my numbers most...

Palm support blows.. I keep getting the Error #1852402768 so i have to use Palm4Fix (when it doesnt crash the system)... and if i should ever try and synch with M$ Entourage, then Im bound to have all my records munged up, corrupted, duplicated, and put in the wrong categories .. AGAIN ...

The lack of decent palm synching in 9.2.2 may be the final straw to get me to X... but is there any gurantee it will work?

And where is Expenses for mac Palm Desktop 4, and where DocsToGo support for PalmDeskTop 4?? Oh that's right after wasting many hours on it i gave up trying to trick the DocsToGo installer

I've been using Macs since '88 and im not impressed with the Mac/Palm interop - especially after the painfree use of all the above on a PC at work...
Posted by: Oly at 04/24/2003 09:40 AM EST
This works great. I have had to do this several times over the last few months.

For me the corruption seems to occur when closing my monitor with Palm Desktop open. I am not a tech expert but when my PowerBook G4 is forced into sleep mode by closing my monitor this seems to create the corruption.

It is the only consistent action I have noticed.
Posted by: Lesley at 04/28/2003 12:27 PM EST
this has been caused for me when one of the palm desktop windows is minimised. Posted by: Laura Stone at 04/29/2003 05:55 AM EST
Okay, now how does one prevent this (error #-50) from occuring? It is a pain, to say the least, to have to recover data and set views once or twice a week. Posted by: Dominick Butta at 05/01/2003 12:37 PM EST
This morning, I got an unexpected error #-8796 message when trying to start Palm Desktop. My symtoms are the same as these, but the fix doesn't work. I run 9.2 on a G4. Any ideas? Posted by: Chris Taylor at 05/02/2003 03:10 PM EST
Hi-

I got the same error message and worked with Palm Support through multiple uninstalls of application files, user files, preferences, rebuilding desktop, resetting PRAM, clean re-installs. Their last comment to me:

"this error could be an apple error code. I suggest you
contact at the URL below:

www.apple.com/support "
Posted by: John Tariot at 05/08/2003 12:04 PM EST
Does any one know whether OS X has the same problem? Posted by: Lesley at 05/08/2003 12:16 PM EST
I'm having the same error, It's worked fine for many months??? Posted by: John Lee Sanders at 05/09/2003 11:24 PM EST
error 8796, I copied the user data file to my laptop running OSX from a g4 tower which runs on 9.2
and it opened fine, but it looks as if the data may be corrupt, using 9.2
I'm not sure how to get the data from OSX back to 9.22 Posted by: John Lee Sanders at 05/10/2003 01:33 AM EST
I'm currently having the same error of #-8796 - it started after I upgraded from 2.6.1 to 4.0 of the palm desktop software (running a g3 beige tower w/OS 9.2.2)...so far Handspring is baffled (I've kept them entertained with this for 2 weeks and over 5 hours of phone calls -definitely getting my $20 worth of support!) but they are determined to resolve. Question to those of you who have the same error...are you using M$ Entourage and/or KPT Effects for PhotoShop?

When I installed 4.0 palm desktop on a computer running os x I received the same error until I completely stripped the hard drive of any Palm files, reinstalled, created a new user Ð have not had any problems with palm desktop in os x since - but have not synced with M$ entourage either.

BTW, there is a special entourage x download available at mactopia to sync with handhelds for those interested in trying...
Posted by: Jerilin at 05/15/2003 04:59 PM EST
This is totally bogus. I hate that Palm tech support is clueless (and not only that made me jump through numerous hoops before saying "it's an Apple thing"). I've only tried installing 4.0 on OS 9.2 (no entourage)... after many tries still no luck.

I'll be setting up a new OSX machine but am NOT looking forward to more of these Palm errors. I find it hard to believe that no one can find out what an error is that actually is documented by a number (in this case "-8796"). No one knows?
Posted by: John Tariot at 05/20/2003 10:29 AM EST
Thank you, thank you, thank you! The same thing happened to me as others have described. Last night, out of the blue, I got the Unexpected Error#-50 dialogue box every time I attempted to open my Palm Desktop application. I found your instructions via Google, followed them exactly as you described, and the problem was solved! Mahalo! Posted by: Doug Carlson at 05/20/2003 05:36 PM EST
For those still having this problem, upgrading to Palm Desktop 4.1 should solve this issue for you. Posted by: Jeff Pollard at 07/02/2003 11:44 AM EST
Jeff, I am running Palm Desktop 4.1 and had the same problem.. (Mac OS 9.2.2)

But like everyone else I was glad to find a solution, I tried deleting the prefs and re-installing palm desktop with no results.. dumping the user data and then just doing a hotsync brought everything from my clie to the new user file and I'm back in business.

Thanks bunches!!
Posted by: Mac8myPC at 07/17/2003 07:30 PM EST
whew! i almost hit the roof...thought i'd lost everything.

the good news: THIS WORKED!

thank you endlessly

mw
Posted by: missy at 08/04/2003 05:35 PM EST
Thanks for this info. and solution-I've wasted hours on this mess over the past two weeks!

I love you all! : )

Robert
Posted by: Robert Cataldo at 08/07/2003 03:18 PM EST
Ok..
Im sorry that so many of you have had problems with Palm support. I am a technician with Palm and support Mac on a level 2 basis..unfortunately most customers and tech's look for the hardest solution before the easiest..

First with the 1825xxxxx error.. lets face it.. 4.0 was created and only made for OS 10x . and not for your 9x system..(infact if it weren't for OS 10x you wouldn't have even seen 4.0 it was the first in the 4x series and with everything with first's it is not without flaw..)... either don't use this version.... or fix your OS.. it's not that hard to figure out...4.1 works just fine.

As for the -8796 error.. this error pops up from time to time just installing, uninstalling, or editting.. there does not seem to be a reason or preference for it.

As for the -50.. the quick fix is just the way we resolve this issue here. However.. usually by the time a customer calls in.. we have a customer on the phone who has infact reinstalled 2 or 3 times and created multiple desktops and multiple problems.. so before we just do a quick fix we tend to take care of the big issue and resolve it all at once.. since we do not want to waist anyone's time if the customer has to call back in because.. they then have user none problems, corrupt data, or totally messed up desktops from leaving the multiple installs in tact.

Have a good day!
Posted by: A Palm Tech at 08/12/2003 12:29 PM EST
The fix at the top of this page worked perfectly. Thanks! Now I don't have to wait 12 hours for Palm to email me back with something that might not work. Posted by: Amy at 08/15/2003 01:12 PM EST
the error 50 problem is happening to me too. i fixed it now but how can you bring back your preferences to the new user name? Posted by: Julie LeBourgeois at 08/20/2003 11:20 AM EST
I am having the error -8796! I have reinstalled software (4.1 version) and tried dumping my user data, then syncing my handheld to get new user data and I am still having problems! i am on 9.2 OS...any suggestions?!? Please help! Posted by: Terry at 08/25/2003 03:38 PM EST
Since 4.0 does not jive with OS 9.1 that well, is there a lesser version I could download that would work better with it? Would I want to do that?

I'm getting the #-50 error, too & trying to figure out how to prevent this from happening again. Right now, I'm going to try to reload Palm & then sync with my up-to-date handheld. Hope that will work per everyone's suggestions!

Thanks,
Tammy
Posted by: Tammy at 08/29/2003 10:30 AM EST
Well, first I want to thank Damien for posting the solution. You saving me hours of time. Luckily, I'd only spent a half hour so far fooling around with this. Now reading all these comments, I'm wondering if I should downgrade to 2.6? 4.1 worked fine for me for the last 2 months, but I don't want to confront this repeatedly. Posted by: Cheryl at 09/13/2003 10:07 PM EST
You made me look like a star - not even our computer guru could figure out what the fix was! Thanks!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Package creation on OS X uses the PackageMaker utility installed as part of the XCode development suite ( on the OSX Client CD).  Packages can be installed as part of the machine build process, or later using Apple Remote Desktop. They are generally…
Are you looking to clear some space on your phone for the latest iOS 8 update? Did you switch to Spotify so you no longer need to keep music native on your phone? Run out of space for taking photos while in the middle of vacation? Sometimes the quic…
Users will learn how resize a batch of photos from a single command in Photoshop via Photoshop's Image Processor. Open up an Image you'd like to resize in Adobe Photoshop: Adjust the image size according to your preferences. Image > Adjustments > …
Users will learn how to set proper sequence settings, scale images, paste attributes, add transitions, fades, and music. Open up Final Cut Pro 7 and Create a new Project: Set the Sequence Settings. a) Click File > Easy Setup > Format > Apple ProRe…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now