ATD>SIM<n>; problem

Hi everybody,
I try to initiate a call using an ATD>SIM<5>; AT command (I also tried ATD=SIM<5>;) but always get the same answer - ERROR. Could anybody tell me why? I tried hundreds of different combination e.g. ATD=SM<5>;, ATD>SM"5"; etc. but without any result. I'm using an Ericsson A1018 mobile phone with cable connection to my PC (RS232).
forrresterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SimonTayCommented:
1 : Have you entered the numbers correctly in the SIM?
  Try AT+CPBW=20,07768??????,129,"My voice phone"    ;an example here, ?????? commented out numbers!

then try

ATD>20;

The semi-colon is important if you are making a voice call - you will get NO CARRIER or ERROR if you are trying to connect to the wrong destination type.

So for your number try

ATD>5;

Simon
0
forrresterAuthor Commented:
Hello Simon,
I have tried it as you adviced me, but unfortunately it doesn't work. I have tried AT+CPBW=20,"0905xxxxxxxxx",129,"My phone" and after ATD>20; , my phone called number "20" directly not the number stored under memory location "20". Do you have another idea?
Thanks in advance,
Paul
forester@orangemail.sk
0
SimonTayCommented:
What memory is selected?

AT+CPBS? will tell you, maybe the SIM is not selected.

Does AT+CPBR=20 return the memory location information?

Simon
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

forrresterAuthor Commented:
SIM memory is selected, yes the AT+CPBR=20 returns correct information.
I'm using AT+CPBR for parsing the number and after make a call using ATD'parsed number'; but it can save me a lot of work if I could use just ATD>memory location;
Paul.
0
SimonTayCommented:
I agree, but the ATD command works on my modem (Siemens TC45).  Maybe it's just the feature is not supported on the modem you are using - what is it?
0
forrresterAuthor Commented:
It is an Ericsson A1018 mobile phone and this feature is described in original .pdf for this phone, I also tried with R320 but without any result. If it works with your modem it should be the same for mine. Maybe its a problem of Ericssons.
Paul.
0
SimonTayCommented:
Yes wouldn't surprise me.  I tested it on my modem yesterday to check it to give you the answer above.

Some of the more obscure commands don't get written properly by module developers, and it takes a while for the bugs to appear!

Simon
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.