Access the internet from server via workstation? is it possible?

Hi folks,

I've just build a Server running Windows 2000 Advanced Server. it is setup as a domain controller with active directory.

I also have a Windows XP Professional workstation which has successfully joined my little domain i created on the server.

My XP workstation has a std diap-up connection to the net, and i have also setup internet connection sharing. a friend of mine said to put the address of my workstation as the gateway in the servers net setting and it therefore would enable to server to access the internet... but alas it doesnt, ive also tried giving the server the ip address my isp gives to my modem, this also doesnt work.

Can anyone shed any light on this situation?
LVL 1
tiranathonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JivkoCommented:
When you enable Internet connection Sharing the XP box runs "mini DHCP server" with scope of 192.168.0.0/24

Set the IP address of the server to 192.168.0.x/24
Simply put 192.168.0.1 as default gateway - this is the internal address of your XP box
Put ISP's DNS as forwarder to your Windows 2000 DNS server


Regards
0
tiranathonAuthor Commented:
ok i saw it do that part, but then i overroad the workstations ip back to the domain, 10.0.0.101 (workstation) and the server is 10.0.0.1

I also set the gateway on the server to 10.0.0.101

didnt understand your 3rd part about dns forwarding, all quite new to this, can you elaberate please? and tell me if the obive i did is ok, or do i need to let xp take over again, and will doing that destroy the dns stuff on my server?
0
JivkoCommented:
On the 2000 server:
Start-->programs-->administrative tools-->DNS-->properties-->forwarders tab-->enable forwarders
Put here IP address of ISP's DNS server.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

tiranathonAuthor Commented:
ok i found the DNS program, a little lost where to go from there ...

i have

forward lookup zones
reverse lookup zones
cashed lookups

i went to forward lookup zones, but couldnt see where to put in the isp's dns
0
JivkoCommented:
Right click on yor DNS server-->properties-->Forwarders Tab
0
tiranathonAuthor Commented:
If i right click on the DNS server, i have no option for properties ... please advise.
0
sconstableCommented:
If you have a forward lookup zone called ".", delete it, its not needed anyway.  Dont go to forward lookup zones, just do to the NAME of the DNS server in the DNS admin tool.

Also, Why are you running Advanced Server?

I have seen advanced server cause problems being a DC, but it should work...
0
tiranathonAuthor Commented:
ok think i have found the answer or thereabouts ..... apparently my server being a PDC will not allow me to create DNS forwarders, therefore im not ever going to get the internet on my server, which stinks :( well done microcrap again! .... as i see it i either have to buy a new server, just for DNS, just so i can add forwarders, or i have to find an operating system that can handle all of it.

can anyone suggest the best route to take, or think of a way round this problem?
0
sconstableCommented:
Yes, you remove the . entry from forward lookup zones, this WILL take care of your problem!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tiranathonAuthor Commented:
WOOT IT WORKS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! well done sconstable! ur a star!!!!!!!!1
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.