Weird calendarp roblem showing wrong day

Hi Guys

I keep coming up with these weird ones
Any here goes

I am using a calendar view:
If i open the view showing a 31 day view the correct day is shown as todays date. If I change to 5 day view for example and then back to 31 the days are off by one
e.g.
Wednesday December 10    31
Wednesday December 10    5
Thursday December 10        31

It seems to work OK for my Shared,desktop on first use view

Any Ideas

James
adspmoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

qwaleteeCommented:
Are you using an early version of 4.6 or 5.0?  There were some bugs like that reported at the time.
0
qwaleteeCommented:
Oh, yes,I remember you are using 5.0.11.  Perhaps the bug has resurfaced.
0
adspmoAuthor Commented:
Could be
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

qwaleteeCommented:
Use the default values for Calendar (Preferences / International settings). They are Sunday/Monday/Monday.  My version does not exhibit this problem, by the way.

Recent example:
http://notes.net/46dom.nsf/notes.net/9fca01e76546af9485256d49006cbd20

Older example, with the International issue:
http://notes.net/46dom.nsf/notes.net/31b0ee10ef6284cf85256977004b2c72
0
HemanthaKumarCommented:
Try these

Open to calendar view and Hold Shift + F9 to rebuild the index.., if that doesn't resolve
Create new copy of the database and check if this happens.., if that doesn't resolve
At server console issue commands load fixup and updall -r (parameter database path at the end of the command)

~Hemanth
0
adspmoAuthor Commented:
I tried the above and no go

James
0
adspmoAuthor Commented:
It only seem to be the 31 day view in the calendar
0
qwaleteeCommented:
adspmo,
> I tried the above and no go

> James
Which?  The interbational settings, or the rebuild?

Rebuild won't help you, since it is a display issue, not a view index issue.  The problem was once explained to me as "Notes calculates day of week in several places in the calnedar display code, and if it has some off settings for first-day-of-week, it may sometimes cache the maping incorrectly."  In other wrds, it may have become confused as it went from building the quick-pick calendar right before the large calendar or vice versa, or some other comboo of DOW calculations versus order mappings for the display.
0
adspmoAuthor Commented:
I actually verified my settings

They are Sunday, Monday Monday
0
qwaleteeCommented:
Stumped.
0
madheeswarCommented:
adspmo,
I had some problems with calendar view.

What i did is to copy view from mail template and modify it according to my needs.

Please try it and let me know.

-Thanks.
0
adspmoAuthor Commented:
I tried copying from the mail template and had the same problem. Is it possible this is a coding error. The odd thing is it is only the 31 day view

James
0
madheeswarCommented:
Can u paste the code which ur using in the first column?

I have copied from template and modified. Its working great

-Thanks
0
qwaleteeCommented:
I have seen the same problem in the mail file in the past.  Will everyone please stop assuming it is a problem in the design? if Notes is showing that today is the 11th, but that today is not Thursday, then Notes has lost its mind.  That's it.  Plain and simple.  Nothing to do with design.

So, the question becomes, Is there a way to force Notes to retain its sanity?  Changing design is UNLIKELY to do that.  Some setting is more likely.

James,
What happens if you do the same thing in your mail file's calendar?
0
adspmoAuthor Commented:
My mail seems fine
0
HemanthaKumarCommented:
The problem seems to be with the DESIGN of the calendar. THe first column has some empty dates listed.. And that is why it is corrupting the calendar.

If you create a calendar just with startdate in first col and enddate in second col then the calendar doesn't behave weirdly

Check it out.

So we might have to refine the formula to remove the nulls and build a new calendar view.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
adspmoAuthor Commented:
OK

I have noticed that it only seems to be the 31 day and the 2 day view. The 2 day view shows the same day twice, the 31 show the wrong day eg Monday 15 shows a Tuesday 15

I have changed the 1st column to Startdate and 2nd to EndDate and checked the Calendar.I am still experiencing the same problem.

Bizarre
James
0
HemanthaKumarCommented:
Completely recreate the view when you change the formula of the first two cols
0
adspmoAuthor Commented:
Do you mean build a new view, refresh the exiting one??

0
madheeswarCommented:
yes. hemantha is telling you to recreate a new view from scratch.

0
adspmoAuthor Commented:
Okee Dokee
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.