Oracle RMAN BACKUP WITH TDPO PROBLEM

Hi,

I am trying to backup an oracle database (8i) on windows NT4 with rman and I get the following error messages:

Recovery Manager: Release 8.1.7.0.0 - Production

RMAN-06005: connected to target database: PRCPTN (DBID=1597124053)
RMAN-06008: connected to recovery catalog database

RMAN> run {  
2> execute script backup_level0_TDPO;
3> }
4>
RMAN-03021: executing script: backup_level0_TDPO

RMAN-03021: executing script: alloc_TDPO

RMAN-03022: compiling command: allocate
RMAN-03023: executing command: allocate
RMAN-08030: allocated channel: t1
RMAN-08500: channel t1: sid=8 devtype=SBT_TAPE
RMAN-08526: channel t1: Tivoli Data Protection for Oracle: version 2.2.1.0

RMAN-03021: executing script: set_maxcorrupt

RMAN-03022: compiling command: set

RMAN-03022: compiling command: backup
RMAN-03023: executing command: backup
RMAN-08008: channel t1: starting incremental level 0 datafile backupset
RMAN-08502: set_count=157 set_stamp=512403853 creation_time=10-DEC-03
RMAN-08010: channel t1: specifying datafile(s) in backupset
RMAN-08522: input datafile fno=00007 name=E:\APPS\ORANT\ORADATA\PRCPTN\PERCEPTION.ORA
RMAN-08522: input datafile fno=00003 name=E:\APPS\ORANT\ORADATA\PRCPTN\USERS01.DBF
RMAN-08522: input datafile fno=00005 name=E:\APPS\ORANT\ORADATA\PRCPTN\TOOLS01.DBF
RMAN-08522: input datafile fno=00001 name=E:\APPS\ORANT\ORADATA\PRCPTN\SYSTEM01.DBF
RMAN-08011: including current controlfile in backupset
RMAN-03026: error recovery releasing channel resources
RMAN-08031: released channel: t1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03015: error occurred in stored script backup_level0_TDPO
RMAN-03007: retryable error occurred during execution of command: backup
RMAN-07004: unhandled exception during command execution on channel t1
RMAN-10035: exception raised in RPC: ORA-19506: failed to create sequential file, name="df_level0_PRCPTN_s157_p1", parms=""
ORA-27028: skgfqcre: sbtbackup returned error

RMAN-10031: ORA-19624 occurred during call to DBMS_BACKUP_RESTORE.BACKUPPIECECREATE

Recovery Manager complete.


------------------------------------------------------------------

It was working 5 days ago and suddenly, it doesn't work...

Could it be a size problem, the 4 files are 1GB total  ???

If you have any clue, please let me know.
Thanks in advance.
jvermeulAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ralf KlattEmployee in Civil ServiceCommented:
Hi,

Please ensure that your authorization code and the enabler code are error free and have not yet expired.

If there's no problem I'd suggest to have a look at Oracle8i Recovery Manager User's Guide and Reference -> if you haven't looked there already.
http://labserver01.zhwin.ch/oracle/8.1.6/server.816/a76990/troubler.htm

Please tell me when this didn't help!


Best regards, Raisor
0
jvermeulAuthor Commented:
Hi,
Thanks for your answer. Yes I already read Metalink problem, documentations, but still don't know.
I have tested also the backup of one tablespace at a time on TSM to verify that I don't have any problem of datafile corruption but it did work properly.
Also, I have 2 more databases on the same system and the backup works properly for these ones. Their size is even bigger so it doesn't seem to be a size problem.
So why this one doesn't work anymore is weird...
I saw in the messages that something seems to be missing between the lines:

ORA-27028: skgfqcre: sbtbackup returned error
....... here should be an other message more significative on the problem as I saw on similar problems on Metalink.......
RMAN-10031: ORA-19624 occurred during call to DBMS_BACKUP_RESTORE.BACKUPPIECECREATE

The full export works fine too...

So I really don't know what is happening.. and I don't see what changed on this environment since it doesn't work...

0
Ralf KlattEmployee in Civil ServiceCommented:
Hi,

As I'm not able to reproduce your error but regarding to your "file size idea" I've found out that there is a MAXPIECESIZE parameter that can be set -> even while this information is about 9i you can read and try to apply the information to your 8i settings:
http://www.engin.umich.edu/caen/wls/software/oracle/server.901/a90136/rcmsynt6.htm

In a chinese forum I've found something about "setting backup_tape_io_slaves = FALSE has been known to fix this problem" => but all explanation is in chinese which I don't know to read or speak.

If these hints lead to nothing then I'll be off of your question as I can't provide anything more productive. I'm sorry if I couldn't help!


Best regards, Raisor
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jvermeulAuthor Commented:

Hi Raisor,
Thanks again for your help.  
That's an idea.  I already tried to downsize the backup by using the fileperset parameter (=1) and it didn't work with the first one, the USERS tablespace which is very small.
But I will try this MAXPIECESIZE on tuesday we never know and will give you feedback about it.
Have a good weekend.
0
Ralf KlattEmployee in Civil ServiceCommented:
Hi,

I hope this will work => I've read that somebody has written an book about MAXPIECESIZE => I'll have a look if find what this is about => I'll get back on that book before tuesday! :)

Have a good weekend too ...


Best regards, Raisor
0
Ralf KlattEmployee in Civil ServiceCommented:
Hi,

I could't find the information I was looking for -> what I've foud instead is:
http://www.osborne.com/products/0072226625/0072226625_ch03.pdf

From chapter 3: "Here is an example of controlling the size of a backup set piece or the entire backup itself. In this example, we are limiting channel 1 to create each individual
backup piece at a maximum size of 100MB."

This is interesting too -> Lots of error explanations and examples! (8.1.6):
http://labserver01.zhwin.ch/oracle/8.1.6/server.816/a76990/troubler.htm


Best regards, Raisor
0
jvermeulAuthor Commented:
Hi,
Thanks for your help and researches.. I will have a look when I come back at work around Jan, 7th.
Sorry for the delay, I am on vacation and was on higher priority problems too weeks ago.
See you.
0
Ralf KlattEmployee in Civil ServiceCommented:
Hi,

No problem!

... and a happy new year ;-))


Best regards, Raisor
0
jvermeulAuthor Commented:

Hi Raisor,

Finally I didn't do anything and it did fix by itself.. Don't ask me why, but that's a problem in todays environments. Too many technical people work on it at the same time (network guys, system admin, etc.) and nobody tells you if they really did something.
Well I am happy it works now, but not so happy for the mystery!!
Thanks again for your help and take care.
Jacques.
0
Ralf KlattEmployee in Civil ServiceCommented:
Hi,

PAQ is perfect for this thread because there's lots of usefull information in the provided articles ... and points refunded to jvermeul is ok with me!

Best regards, Raisor
0
ee_ai_constructCommented:
PAQed, with points refunded (50)

ee_ai_construct - CS Mod
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.