Solved

Cannot Flash Bios

Posted on 2003-12-10
40
2,147 Views
Last Modified: 2012-05-04
I have a barebones computer:

A7A266 Asus Motherboard with version 1004 Bios
Athlon 1.4 ghz chip / fan
Video card
Floppy drive
CD-ROM Drive
256 Megs of DDR Ram

I am trying to flash the bios on the motherboard to give me better support for newer CPUs.  Unfortunately I am totally stuck.

I boot off a floppy disk to DR-DOS.  I got this boot disk from bootdisk.com.  It was the recommended one for flashing bios.  On this disk I also have AWFLASH.exe and AA261012.AWD.

AWDFlash starts up.  I type in the AA261012.AWD and press enter.  It says 'Please Wait' and then it seems to hang.  It scans the floppy disk for a while and then it totally stops.  I've waited about 5 minutes before giving up and rebooting.  I have tried it several times with the same result each time.  I even tried to run AWDFlash from the command line, but that didn't seem to make any difference.

One thing that concerns me is in the AWDFlash screen, there is nothing after "Flash Type" like in the picture at

http://taiwan.asus.com.tw/support/english/techref/bios/Awdflash2.jpg

Here are some other links:
http://taiwan.asus.com.tw/support/english/techref/bios/awdflash.aspx
http://oldlook.experts-exchange.com/Hardware/Q_20818823.html (an earlier question of mine which led to my current problem.)

Thanks.
0
Comment
Question by:Igiwwa
  • 15
  • 11
  • 9
  • +4
40 Comments
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
Perhaps the floppy disk isn't any good. Try using another preferably new disk to load the flash onto.
0
 

Author Comment

by:Igiwwa
Comment Utility
I did it with a different disk and it said "Divide Error!" on the right side of the screen before stopping.  Maybe I should buy some new floppy disks.   Weren't they supposed to be obselete several years ago?
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
>>>Divide Error

When did you get this error, when booting to DR-DOS or when trying to flash?
0
 

Author Comment

by:Igiwwa
Comment Utility
trying to flash.  it was right after i entered the new file name and pressed enter.  however, now its back to its old behavior (no output of any kind)
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
Hmmm can you get into your BIOS and check around if there is anything to has locked it so it can't be flashed. I have no idea what to tell you look for or if it even exists.
0
 

Author Comment

by:Igiwwa
Comment Utility
Here are all the fields I could find that appear to be relevant:

Bios Update = Enabled
Reset Config Data = No
Boot Virus Detection = Disabled
Boot Up Floppy Seek = Enabled
0
 
LVL 31

Expert Comment

by:rid
Comment Utility
I once came across a mobo that had a jumper to move to a "Flash BIOS" position, before attempting an update. How about your mobo?
/RID
0
 

Author Comment

by:Igiwwa
Comment Utility
I checked the manual and the readme docs about flashing the bios, and neither said anything about jumpers.  I'll inspect the board to see if I can notice anything, but I don't think that is the problem.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
I had seen that error once when I tried to flash with the wrong binary - are you sure that the binary is the correct version, and that the download was not corrupted?
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Asus' site says 1013-001.zip dated 2003/08/15 is the latest BIOS for the A7A266 motherboard with Athlon 1400 (266 FSB).
0
 

Author Comment

by:Igiwwa
Comment Utility
I was hesitant to go to the 1013 since I only found it under the "beta" tab.

Other questions -- some of the bios files I have seen have different extensions (.001,.bin,.AWD)  What's the difference?

Also, should I be using aflash.exe or awdflash.exe?

When I get home from work tonight, I'll re-download the 1013 along with the newest aflash off the asus site and give it another try.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Being dated 2003/08/15 and with today 2003/12/11, I would say it is past the beta stage.  The extensions for data files make no difference for rarely used programs - they are useful only for Windows associating an extension with a program (ie, .doc with Word, .xls with Excel, .bat with DOS batch).  Use the program Asus recommends.
0
 
LVL 17

Expert Comment

by:xema
Comment Utility
You should use AFLASH.EXE not AWFLASH.exe
Yoú'll find instructions here
http://taiwan.asus.com.tw/support/english/techref/bios/index.aspx

Motherboard - AFLASH BIOS Update Procedure (For A7A, A7M, A7S, A7V, P2, P3, P4B, P4S, P5, TU, TX97 Series)  
0
 

Author Comment

by:Igiwwa
Comment Utility
Ok, here is what happens:

1.  I insert boot disk with aflash.exe and 1013.001 and command.com.
2.  Turn on machine and boot to DR-Dos.
3.  Type "aflash"
4.  Press 2 to 'Update BIOS without boot block or ESCD' *NOTE THIS IS DIFFERENT FROM PICTURE
5.  Enter Filename for NEW Bios: --  I enter A:\1013.001 and press enter.
Then it starts to get weird.
6.  It says "Please enter filename to save"
This seems kind of normal, but the prompt is sort of on top of the other prompt so that I can no longer see my A:\1013.001
7.  Undeterred, I enter something like old.bin and press enter.
8.  It reads the disk for a while.
9.  Then it flashes a whole bunch of random characters -- musical notes, letters, smiley faces.
10.  "Error - File Write Failure"
11.  "Press Esc to Continue"
12.  I press escape
Repeat steps 10-12 for a while.
Finally it just runs a cursor along the bottom of the screen like someone is holding down the tab key on a blank screen.
13.  I get fed up and reboot.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
That does not sound good - that file is the correct one, and something is happening to prevent the flash.  You are sure the motherboard is an Asus A7A266, and not an Asus A7A266-E (the E version uses a download named 1013e001.zip)?  The E version has 5 PCI slots, as opposed to 4.
0
 

Author Comment

by:Igiwwa
Comment Utility
Interesting.  I have 5 PCI slots on my motherboard, but it doesn't say 'E' on it anywhere.  Should I try the A7A266-E flash?
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Since the current flash is not working and it sounds like you have the E version, yes, try it.
0
 

Author Comment

by:Igiwwa
Comment Utility
The E version didn't work.  Same thing as with the other one.

Is it possible that I might have a bad bios chip or something?  Do you think it could be a floppy disk problem?
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
>>>Is it possible that I might have a bad bios chip or something?  Do you think it could be a floppy disk problem?

It could be either. Floppy drives are cheap but from you description of what is going on you either have a flaky BIOS or a CMOS virus. If you live in an area that have computer repair shops it may be worth the money to have them check the BIOS and the mother board.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
One last resort is to swap the floppy drive, but that is a low probability source for what is going on.  I think we have come as far as we can - it sounds like a faulty piece of hardware somewhere, but we can't isolate it.  For all the time you've spent on this, if you were paid the cost of the equipment, you would be making below minimum wage ;-)
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:Igiwwa
Comment Utility
Would it be possible for me to use the bios chip from a different type of motherboard?  I have an old m7mia mobo that isn't getting any use these days.
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
I never tried it but I would suspect it wouldn't work and lot of the chips are soldered in.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
No, a BIOS is very specific to a motherboard.  Even flashing the wrong image to a BIOS can result in a non-functioning motherboard.  Your motherboard seems to refuse all images, whether right or wrong.  If you found another motherboard with the same BIOS, you probably could replace it, if it wasn't soldered in place, but it would have to be the same exact model chip.
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
I don't know Callandor I have known people to swap BIOS chips from different mother boards but they were from the same mother board vendor but different models and got them to work.
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
Why not get another mother board and be done with it. As Callandor said you invested more time than it is worth. Cut your losses and either have a computer repair shop have a look at it or get another board or machine. :)
0
 

Author Comment

by:Igiwwa
Comment Utility
I guess I'll try for a repair shop.  This motherboard is pretty out of date, so there aren't too many people selling them these days.
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
>>>This motherboard is pretty out of date

Upgrade to a newer on or some shops carry used boards you might find one that suits your needs or even check www.ebay.com
0
 
LVL 69

Assisted Solution

by:Callandor
Callandor earned 250 total points
Comment Utility
CrazyOne,

I stand corrected, the same BIOS can be used in different motherboards, and perhaps some may have gotten different ones to work in their motherboard, but it is not for the fainthearted and many experienced people would not think it is worth the trouble.
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
>>>but it is not for the fainthearted

Whole heartedly agree. :)
0
 
LVL 4

Expert Comment

by:shaharidzal
Comment Utility
Pointing out CrazyOne comments.
Goto you BIOS Setup
Goto Advanced Settings
There is a line with "Flash protection" or Flash BIOS Protect"
Disable this setting.
Then proceed with the flashing methods.
0
 

Author Comment

by:Igiwwa
Comment Utility
Shaharidzal -- The closest thing to what you describe appears to be 'Bios Update', which is already set to enabled.
0
 
LVL 17

Expert Comment

by:xema
Comment Utility
Igiwwa:
Try the following

Use built-in EZ Flash BIOS Procedure to begin BIOS Update process

Download latest ASUS BIOS from ASUS WWW/FTP for newest version BIOS, please change the BIOS name into "xxxxxx.ROM" (xxxxxx represent the motherboard model, eg : P4C800, then the BIOS file should be named p4c800.ROM) and save it in the diskette.

in your case A7A266

Reboot.


After reboot, when the system is still in POST state, hold down <Alt> + <F2> to enter the screen as shown below to begin EZ Flash process. Please place in the diskette with the latest version BIOS files into the floppy drive.




Warning If you do not have If you did not place any diskette in the floppy drive, you will see a warning message such as   "Floppy not found" message. If the BIOS utility cannot find the correct file from the diskette, it will show an error message such as   "p4c800.ROM not found!"  (If your motherboard is P4C800).


The system will auto-detect whether floppy disk is placed inside the floppy drive and all the files necessary. If there is no proble, EZ Flash utility will begin update the file automatically. Upon completion, the system will reboot automatically . The procedure can be seen in the illustration below. (Note: Please don't shutdown or reboot the system during the process of BIOS update! Such action will damage the system!)


The previous instructions are from http://taiwan.asus.com.tw/support/english/techref/bios/aflash.aspx#section2
0
 

Author Comment

by:Igiwwa
Comment Utility
I already tried this and alt-f2 didn't do anything.  I don't think my motherboard supports EZ flash.
0
 
LVL 44

Accepted Solution

by:
CrazyOne earned 250 total points
Comment Utility
What happen to "I guess I'll try for a repair shop" :)
0
 

Author Comment

by:Igiwwa
Comment Utility
Hey, as long as people keep giving me suggestions I'll try them.  I am going to take that hunk of crap to a shop soon, but I want to do some other tests before I start putting money into it (i.e. make sure that everything else works besides the bios).
0
 
LVL 44

Expert Comment

by:CrazyOne
Comment Utility
:)
0
 

Author Comment

by:Igiwwa
Comment Utility
I broke down the machine and found other uses for most of the parts.  I also found a use for the motherboard - sitting in the trash.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Ah, the sad end to a saga...
0
 
LVL 1

Expert Comment

by:fallenknight308
Comment Utility
"I broke down the machine and found other uses for most of the parts.  I also found a use for the motherboard - sitting in the trash."

No no no send it to meeeee, LOL
I know this topic is closed, but when I flashed my ms-6312 (gateway)
the instructions stated NOT to use a floppy disk that was formatted with WinXP
only with 9x, or on a brand new one (disk)
It has errors and won't work unless you applied the bios files to a floppy while using 9x
(Me/98 ect..)
I'm not shure if this applies to your A7A266 Asus, but its worth posting I guess
:)
0
 

Author Comment

by:Igiwwa
Comment Utility
Thanks for your thought FallenKnight.  The machine that created the boot disk was running 2000, so maybe that was part of the problem.  Even so, the machine is now in the following places:

sold on Craigslist
sold on Ebay
in my other computer
in my closet
in a landfill somewhere

So it has about as much chance of getting back together as the Beatles. :)
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
IT Support 4 17
CPU fan speed 7 47
Windows 7 installation issues with an HP Z800 Workstation 7 197
M2 drive not showing up 16 58
Computer running slow? Taking forever to open a folder, documents, or any programs that you didn't have an issue with before? Here are a few steps to help speed it up. The programs mentioned below ALL have free versions, you can buy them if you w…
Like many organizations, your foray into cloud computing may have started with an ancillary or security service, like email spam and virus protection. For some, the first or second step into the cloud was moving email off-premise. For others, a clou…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now