Problems starting X Server

When I boot my Debian Linux machine, I get this message:
I cannot start the X server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the X server output to diagnose the problem?

If you choose yes, then it shows a grey window with "(100%)" in the bottom right hand corner of it, an exit option right below that and in the center, and a blue back ground. Other wise, the window is blank.

When I choose to exit that screen, it gives me a message that says, "Would you like me to try to run the X configureation program? Note that you will need the root password for this."
I choose yes, and it goes back to the command prompt for a second, and then brings back up a grey screen on the blue background and says, "I will now try to restart the X server again" and it then gives me the original "cannot start the X server" message.

If I click no, it says, "I will disable this X server for now. Restart GDM when it is onfigured correctly."
Then it goes back to my command prompt login.

Then I login as root and try this:

SteveLinux:~# startx
 /usr/X11R6/lib/X11/xinit/xserverrc:/usr/bin/X11/X: No such file or directory
/usr/X11R6/lib/X11/xinit/xserverrc: exec: /usr/bin/X11/X: connot execute: No such file or directory
giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error.

And I try this too:
SteveLinux:~# gdm
gdm already running. Aborting!

Can you guys help me get my display running? My number one priority right now is getting on to the internet with this machine, then I can play around with stuff and figure it out.
crazyheadAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shivsaCommented:
run  xf86config.
select your video card(or generic if u are in doubt).

and see if it works.
0
crazyheadAuthor Commented:
I ran the program, and it did not work. I selected a generic VGA adapter and it did not work. I didn't know what kind of monitor information is was asking, so I chose the most basic and first options. It gives me the exact same errors as before when I try to run it.
0
shivsaCommented:
Do u have X rpm installed on your system. could u check these very quickly.

what does it say.
#which X

#cd /usr/bin/X11/
ls -l
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

shivsaCommented:
also do u know which graphic card u have and do u have drivers for those card.
0
dorwardCommented:
Try running:  

/etc/init.d/gdm stop
X -configure

Hopefully that will autogenerate a config file for you that you can copy to /etc/X11/XF86conf-4
0
crazyheadAuthor Commented:
shivsa:
I used the command you gave me, but got no result. I also tried the following:
which X
which x
which suck
which you better answer me you giant piece of crap

Yet, nothing.
I moved to the /usr/bin/X11 directory, but did not know what to do after that. (I used the ls -l command, but did not know what to look for)
And as long as I am looking for stuff, how do I scroll the contents of those results which are too large for my sreen?

I am using a NumberNine SR9 with 16mg of RAM.


dorward:
I tried to run gdm stop in the /etc/init.d/ directory, but it gave me the error "gdm already running. Aborting!"
I attempted to run X -configure anyway, and it said "bash: X: command not found"


*steve laughs at his shamefull newbie self*
Anything else guys?
0
shivsaCommented:
u have to look for X in /usr/bin/X11 directory.
ls -l | more and look for file X. <--- this will give input  one screen one time, space will move to another screen.

just do
ls -l X in this dir and post the result. if it a link to some thing then do ls -l fo that link too.
0
crazyheadAuthor Commented:
Do you need the information that comes with the -l flag? This is a seperate computer, and I don't know how to get all that information over here with out retyping it all.
0
shivsaCommented:
yes just send me what it print when u tyrp
ls -l X
0
crazyheadAuthor Commented:
SteveLinux:/usr/bin/X11# ls -l X
ls: X: No such file or directory

I belive I did that in the directory you spoke of...just to be sure, I tried it in the /usr/bin/ directory and the root (/) directory.
0
shivsaCommented:
it confirms that u do not X installed on your system.
u have to get X server installed on your server to get goin.
solve the problem by dselect as root, downloading the xfree86-xserver and associated files. install it.
and then  run  xf86config. u will be ok.


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crazyheadAuthor Commented:
Awsome! Its working now. (to bad it so slow, thats what I get for running it on a P-266 I supose) This has been bugging me for a long time, thank you very much!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.