Solved

HDLC serial up/up (looped)

Posted on 2003-12-11
4
788 Views
Last Modified: 2010-05-18
I'm setting up a HDLC 256k connection.

Router on both ends are Cisco 1601.

If I enable keepalives on the serial interface it shows that it is looped. Output from "debug serial int" shows:

00:28:59: Serial0: HDLC myseq 121, mineseen 120*, yourseen 121, line up (looped)
00:29:09: Serial0: HDLC myseq 122, mineseen 121*, yourseen 122, line up (looped)
00:29:19: Serial0: HDLC myseq 123, mineseen 122*, yourseen 123, line up (looped)

#sho int ser 0
Serial0 is up, line protocol is up (looped)
  Hardware is QUICC Serial
  Description: connected to C.DATALINK
  Internet address is 192.200.232.2/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input 00:00:08, output 00:00:08, output hang never
  Last clearing of "show interface" counters 00:08:57
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     131 packets input, 10049 bytes, 0 no buffer
     Received 62 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     131 packets output, 10049 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


I would think this to be a mis-configuration of the telco equipment. Someone else called them and they supposedly tested it and it was OK. What think you ?

The exact same behaviour happens on both routers when keepalives are set on the serial interface. Without keepalives, it doesn't complain about being looped (yes I know, how can it detect a loop if keepalives are not being used). I can ping the IP address of the local serial interface, but not the remote one.

The other thing that makes me think the local CSU/DSU is in loopback mode is the fact that the number of packets input & output are the same. Is this a correct assumption ? I need facts to go and acuse the telco with, but I haven't done much work with HDLC (or other point-to-point) lines.


Config of router looks like this (very plain):

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname E.DATALINK
!
enable password **
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Ethernet0
 description connected to EthernetLAN
 ip address 192.200.231.10 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 description connected to C.DATALINK
 ip address 192.200.232.2 255.255.255.0
 no ip directed-broadcast
!
router rip
 version 2
 network 192.200.231.0
 network 192.200.232.0
 no auto-summary
!
ip classless
ip route 192.100.107.0 255.255.255.0 192.200.231.5
ip route 192.200.102.0 255.255.255.0 192.200.232.1 permanent
ip route 192.200.105.0 255.255.255.0 192.200.232.1 permanent
ip route 192.200.230.0 255.255.255.0 192.200.232.1 permanent
!
line con 0
 exec-timeout 0 0
 password **
 login
 transport input none
line vty 0 4
 password **
 login
!
end


The other router is identical config (with IP addresses changed, obviously).

I don't think this is a difficult question (I could be wrong), but it is urgent, hence the 500 points.
I'm going home now and will be back in 12 hours. Hopefully there will be an answer waiting for me when I get back...
Thanks.
0
Comment
Question by:td_miles
  • 2
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 9920641
>Someone else called them and they supposedly tested it and it was OK. What think you ?
Ask to speak to their supervisor - keyword "escalate".  The curcuit is in a loop somewhere, else the DSU is in loopback.

Who controls the CSD/DSU, you or the telco?

0
 
LVL 13

Author Comment

by:td_miles
ID: 9924676
This is what I thought, just wanted confirmation.


Telco control's the CSU/DSU. We are providing router & serial cable, after that, it is all telco.
0
 
LVL 13

Author Comment

by:td_miles
ID: 9926416
Finally resolve (I say finally after spending most of the day on the phone). After managing to convince the telco service desk people that it was a problem somewhere with their network I finally got a call from a NOC guy who knew what he was doing. We started isolating various pieces of equipment and finally got an answer when the guy on site turned off the CSU/DSU that one router was plugged in to, but the telco didn't see the equipment go down. It turns out that in a brand new cabinet in a brand new location, there were actually TWO CSU/DSU's and (Murphy's Law) it was plugged into the wrong one. After that everything went well, the line was up in a bout 5 minutes :)

Unfortunately this is what happens when you can't do stuff yourself (I'm troubleshooting from about 1500km away) and have to rely on a monkey onsite to plug the cables in correctly.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9927929
Been there, done that...
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now