[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1714
  • Last Modified:

SunOS locale issues

I recently changed the locale on our 5.8 system to:
LANG=el_GR.ISO8859-7
LC_ALL=el_GR.ISO8857-7
after a previous question here. Now, after giving some commands (e.g. man) I get the "couldn't set locale correctly" message. In fact, I get it several times. Should I worry?



0
piou
Asked:
piou
  • 2
  • 2
1 Solution
 
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
This look like you have not installed all the required software packages for you locale.
Check with
  locale -a
if the one you need is present.
0
 
piouAuthor Commented:
I set the particular locale after checking with locale -a. It exists alright.

0
 
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
Getting the message indicates you don't have the message catalogs for the setting you entered. Could you try a different one and see what happens?

The complete set of locale varaibles is as follows (see also in /etc/default/init):
LC_COLLATE=C
LC_CTYPE=C
LC_MESSAGES=C
LC_MONETARY=C
LC_NUMERIC=C
LC_TIME=C
0
 
piouAuthor Commented:
There were only TZ and cMASK in the init file. I updated it as you suggested, but it didn't change a thing. I still get the same message. Just once, I even got it after a 'clear' command!

0
 
Computer101Commented:
PAQed, with points refunded (50)

Computer101
E-E Admin
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now