Taskmanager and Terminal services manager not working on Terminal server (Win2k)

Hi,
This is the situation.
We have about 16 servers running Windows 2000 server and 1 running Advanced server.

Most of the 16 servers are running remote admin terminal services
4 are running in application mode.
The Advanced server is running in application mode.

most servers are running SP4 with the latest hot fixes (as of 10/12/03)
A few are not (in an attemp to see it was a SP or hot fix that caused the problem)

When the server is first switched on it works fine.
After a while trying to bring up Task Manager fails, and trying to run Terminal services manager also fails.

Taskmanager - it looks like it minimised, in other words it's a small graph next to the clock on the taskbar.
  clicking on it make no differance, changing the screen rez make no differance (as in it's not been used under a very
  high screen rez and now being used on a lower one and is now of the screen). When you come to log off a
  message appears saying that "taskman.exe" is not responding and would i like to end the task!

Terminal Server Manager - it first seems to run ie the window appears. it looks ok on the left hand side of the
  window (showing the local machine name IE "T-Server01" . However on the right hand side the box is a kind of grey
  colour with the words "Terminal Services Manager is currently gathering information about this server".
  Then it seems to just hang.. and again when i log out i get the message about terminal serverice manager is not
  responding.. end task etc..

Rebooting the box seem's to solve this for a while then its broken again....

I have had a look around the net but i've not found anything close to this problem..

Can anyone help..??

thanx
Dan....





MadravenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

adonis1976Commented:
do a scan for viruses and trojan horses..
0
adonis1976Commented:
try this as well... uninstall the Terminal services role for the sever.. and then see if it makes a difference... reinstall it later on..
0
MadravenAuthor Commented:
All the severs are running Trend Server protect (uptodate)

Have done as you suggested and run the scan any way no nastys.

0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

adonis1976Commented:
did u already try uninstalling the TS role for the server and see taskmanager still hangs?
0
oBdACommented:
Have a deep look at this taskman.exe and what it's doing on your system. This is *NOT* W2k's Task Manager; the task manager's process/program name is taskmgr.exe. taskman.exe is found in an NT/W2k/XP installation (%Systemroot% and %Systemroot%\system32), but it's just a remnant of 16bit Windows. Don't ask me what it's doing precisely, though ...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
simpsonehhCommented:
long shots:
check zone replication times.  If things work when you first reboot, then bog down later, zone replications could bog down (AD, DNS which ever you have running)

*Have there been too many people connected and not disconnect correctly.  Is that setting to keep connection alive set?

*run perfmon and caputure data when you try to open your applications

*check event viewer.
0
bbaoIT ConsultantCommented:
here is my taskmgr.exe's information, different with yours?

X:\WINNT\system32>fileversion.pl taskmgr.exe
Filename                     Size (KB)           Version                    Date:Time                    Path
------------------------- --------------  -------------------  ----------------------------   ----------------------
taskmgr.exe               85.265625     5.00.2195.6620   06/19/2003:12:05:04PM   e:\winnt\system32

X:\WINNT\system32>cacls taskmgr.exe
X:\WINNT\system32\TASKMGR.EXE BUILTIN\Users:R
                              BUILTIN\Power Users:R
                              BUILTIN\Administrators:F
                              NT AUTHORITY\SYSTEM:F
                              Everyone:R
0
MadravenAuthor Commented:
bbao -sorry i typed the wrong name of the file. it is using taskmgr.exe and it is the same version and file size as your post above.

uninstalled terminal server .. it takes a day or so for the problem to come back so i'll give it some time and we'll see what happens.

time zones - we are not running AD or DNS on any of these servers. Some of the servers with the problem are standalone others are part of an NT4 domain. DNS is done by a linux gateway. I've check and they are all on GMT etc and all with in a second or two of each other.

The number of connections varies depending on the server.. on the 2 APPS servers the time out is set to 1 hour Idle then disconnect and 1 hour disconected before the session is terminated. on the other servers its set to 10mins for ide and 10 mins for disconected.

Event viewer on the servers don't have any entrys other than the normal stuff.


Thanx
Dan
Dan
0
adonis1976Commented:
good that u unintalled TS.. let us know what happens..i'll be waiting for the results.
0
MadravenAuthor Commented:
Ok the server that had TS uninstalled has worked fine for a few days so i've now reinstalled TS. unfortunatly this is the last i'm going to be able to work on this untill the new year as im going out to another office for few weeks. But i'll let you know what happens to the server
Thanx
Dan
0
bbaoIT ConsultantCommented:
good luck and happy new year :-))
0
bbaoIT ConsultantCommented:
Madraven, any feedback please? solved?
0
MadravenAuthor Commented:
Sorry Still not back in the office so unable to make any further tests.
When I'm back i will be carrying on with this problem.

Don't worry i've not forgotten. It's just a location thing :)

Thanx
Dan
0
MadravenAuthor Commented:
Ok update time..
We have been trialing some moitoring software called spotlight. (very usefull tool)
Our trail expired and we've been going through getting the bugdet approved for it.. (takes a long time)
So we've not been using it for a while and the problem did not go way.
However i had to get one of the other sysadmins to reboot one of the machines that's had this on going problem. Normaly after a few hours/couple of days the problem is back.. This time however the problem has not.. so i'll leave it a few more days and see what happens..

Anyone had somthing like this using this product before?

Dan
0
MadravenAuthor Commented:
Hi all,

Since the trail version of Spotlight Expired and the servers have been rebooted the problem has gone!!!

Normaly the problem would repear with in a few days. It's now been a good amount of time for me to feel confident that the problem has gone for good..

The uninstall/reinstall of TS dod not make any difference :(
Thanx, for all your suggestions and your time.

Dan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.