Solved

Cannot Run ASP

Posted on 2003-12-11
12
962 Views
Last Modified: 2012-06-21
I cannot run .asp files.
My IIS is running.
I can only run .htm files.

I type this
http://localhost/myfile.htm  <-- ok
http://localhost/myfile.asp  <-- NOT ok


When i run .asp files, I get this error
Server Application Error
The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance.


Why?
0
Comment
Question by:ansi_c
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 8

Expert Comment

by:NowaY
ID: 9920793
just use this code in your asp file to test:

<%

response.write "Hello World"

%>

Does this work?
0
 
LVL 2

Expert Comment

by:hb21l6
ID: 9921259
if you've not altered the webfile location, are you storing the files in c:\inetpub\wwwroot\

file should be called "somthing".asp (without the speech marks)

and for a test put something like this into the ASP file.

<html>
<title>test</title>

<%
date1 = date()
response.write date1

%>

</html>

then to view it goto http://localhost/yourpagename.asp

if it works you should get the date in the web browser.

failing this...
open the Internet Serivces Manager (mmc snapin)
and check your configuration




0
 
LVL 21

Expert Comment

by:ap_sajith
ID: 9921285
Are you running IIS 6? If so, you need to configure the site to run .ASP files. by default they are not set.

Cheers!!
0
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

 

Author Comment

by:ansi_c
ID: 9921754
ap_sajith, how to configure?
0
 
LVL 6

Expert Comment

by:MannSoft
ID: 9922299
If you search on Google, there is an "IIS Lockdown" utility that Microsoft made.  It asks you what features you want enabled, and it disables the rest.  On IIS 6 most are now disabled by default, but I assume the utility also has the ability to enable items you want that are currently disabled.
0
 
LVL 21

Expert Comment

by:ap_sajith
ID: 9924674
Go to Inetmgr(IIS Console),Click on Web server extensions, Click on Active server pages and click on 'Allow'. This should get you going.

If you are using file uploads then there is a limit of 2megs on them, you need to edit the config.web file to specify a higher size for the file uploads.

Cheers!!
0
 

Author Comment

by:ansi_c
ID: 9925206
i click on the server extensions but then it says
"This server has not been configured to use the Server Extensions. To configure it, choose Configure Server Extensions fronm the task menu for this server."

I cannot find the configure button.
0
 

Author Comment

by:ansi_c
ID: 9926301
FYI, I think i am using FAT32 and not NTFS on WinXP Pro.
Could this be the reason?
0
 
LVL 33

Assisted Solution

by:hongjun
hongjun earned 125 total points
ID: 9926577
Check out application and system log files in Event Viewer.
You will get clue from there.
That error is too general and not specific.

hongjun
0
 
LVL 21

Expert Comment

by:ap_sajith
ID: 9926879
Do you have the service pack installed for winxp?
http://support.microsoft.com/default.aspx?scid=kb;en-us;310407&Product=winxp

Cheers!!
0
 
LVL 21

Accepted Solution

by:
ap_sajith earned 125 total points
ID: 9927037
Try following the steps described in the article...
http://support.microsoft.com/?id=309051

Do you have Norton Antivirus installed? If so, Try running the asp page after disabling the Script blocking option in NAV.

Also, you could try disabling the simple file sharing option..

To turn Simple File Sharing on or off in Windows XP Professional:
Double-click My Computer on the desktop.
On the Tools menu, click Folder Options.
Click the View tab, and then click to select the Use Simple File Sharing (Recommended) check box to enable Simple File Sharing (click to clear this check box to disable this feature).

Cheers!!
0
 
LVL 21

Expert Comment

by:ap_sajith
ID: 9927074
0

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Hide cell in a table 2 42
Designing forms 3 70
Table header must be on top 2 57
Adding Clickable Links to JQuery Data Items 24 54
Have you ever needed to get an ASP script to wait for a while? I have, just to let something else happen. Or in my case, to allow other stuff to happen while I was murdering my MySQL database with an update. The Original Issue This was written…
I was asked about the differences between classic ASP and ASP.NET, so let me put them down here, for reference: Let's make the introductions... Classic ASP was launched by Microsoft in 1998 and dynamically generate web pages upon user interact…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question