• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 830
  • Last Modified:

CISCO 6509 lost dot1q trunking

I have a dot1qtrunk set up extending our network to another building.  Just lost it a little bit ago.  I set the port and force it to trunk.  Do a show trunk and its now truning, but, cant ping its as if its dead.  Has worked find for several months.  Anyone have an idea of what to check?

Rocky
0
rockyisin
Asked:
rockyisin
  • 2
  • 2
2 Solutions
 
rockyisinAuthor Commented:
Here is an error I am recieving:   spantree-7-recv_1q_non_trunk for the trunk that stopped working.
0
 
brabardCommented:
Well , you can see the problem is in spanning tree protocol . Usually this kind of problem is starting after adding new paths in the existing network .
0
 
bbaoIT ConsultantCommented:
This message means that an SSTP BPDU was received on the listed interface, which is not an operational trunking interface. Verify that the configuration and operational state of the listed interface and that of the interface to which it is connected are in the same mode (access or trunk). If the mode is trunk, verify that both interfaces have the same encapsulation (none, ISL, or 802.1Q). When these parameters are consistent, spanning tree automatically unblocks the interface.

VLAN and Trunk Configuration Guidelines
(Quoted from http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/sw_7_6/confg_gd/channel.pdf)

? Assign all ports in an EtherChannel to the same VLAN, or configure them as trunk ports.
? If you configure the EtherChannel as a trunk, configure the same trunk mode on all the ports in the EtherChannel. Configuring ports in an EtherChannel in different trunk modes can have unexpected results.
? An EtherChannel supports the same allowed range of VLANs on all the ports in a trunking EtherChannel. If the allowed range of VLANs is not the same for a port list, the ports do not form an EtherChannel even when set to the auto or desirable mode with the set port channel command.
? Do not configure the ports in an EtherChannel as dynamic VLAN ports. Doing so can adversely affect switch performance.
? Ports with different VLAN cost configurations cannot form a channel.

In my mind, I got a similar problem with Cat 6006 3 years ago, not sure with exact same error message but the symptoms was quite similar. Finally we found that we had different trunk mode at the two ends, one was On, the another was Off. The solution was to change both of them to Silent. See the 2nd point of above guidelines.

Hope it helps,
bbao
0
 
brabardCommented:
Btw , is that port goes down in error-disable status ? It have to be so ...
0
 
bbaoIT ConsultantCommented:
rockyisin, any feedback please?
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now