After Master/Slave attempt, one hard drive won't boot

I was not present when the following occured, so this is based on what was related to me...  Two identical computers, both with W2K Pro.  Took hard drive (we'll call it HD1) out of one computer, rejumpered for slave (I am told it was properly done, I have no first hand knowledge), and installed on primary controller of second computer.  Booted up, got NTOS kernel error.  Rebooted, got W2K splash screen, went no further.  Couldn't boot into safe mode either.  Took HD1 off primary channel, put it on secondary channel as master in place of CD Rom (again, I wasn't there to be sure of proper jumpering), same result.  Took HD1 out completely, and computer booted normally.  Put HD1 back in its original computer, with original master setting on primary channel, now it won't boot - gets to same place at splash screen.  Tried to repair, but W2K installation not detected.  Can anyone guess the most likely scenario of what happened here?  I'm guessing something with the boot sector, but I'm not positive.  I'm also guessing the jumpering was incorrect at some point in the process.  If anyone can help me figure out what happened so I can figure out if there is a way to fix it, I'd appreciate it!  
LVL 2
slandiseAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Fatal_ExceptionSystems EngineerCommented:
Have you tried the Recovery Console to fix the boot sector?  (Fixboot - Writes a new partition boot sector onto the specified partition.)  (Or Fixmbr - Repairs the master boot record of the specified disk.)

And I believe you are right, it was jumpered incorrectly.  From what I can see, this is the only explanation.  But, of course, I may be wrong...:)

FE

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GnartCommented:
When putting the second drive (jumpered as slave) into the computer, the jumper on the first drive may need to be set (drive can be jumpered as only drive, primary and slave).  The first drive may have been set as only drive.  Also, the second drive may have been jumpered as only drive instead of slave.  The problem with setting drive jumper is some folks don't know which way to hold and read the jumpers.  If you hold it upside down, which is it (right or left) of the middle pin-set.

Also, the BIOS setting should be checked.  The 2nd drive setting may not have been set as auto-detect.  This would result in the problem with the bootstrap and no OS.

cheers
notch_ur_headCommented:
HI slandise

Just remove the JUMPER from the JUMPER PINS and the restart the pc..
this will solve ur problem..

-notch_ur_head
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

slandiseAuthor Commented:
I finally got my hands on the computer and ran chkdsk /r on it.  Now it boots fine.  I'm still curious to know what caused the problem - I'm running diagnostics on the hard drive, but don't really think it's a problem with the drive itself.  To Gnart:  this is a Seagate drive, and the master jumper is supposed to be for master OR only drive.  As far as I can tell there is no separate jumpering for "only" drive, but I could be wrong.  That possibility makes sense.  And to Notch_ur_head, no jumpers is the setting on this drive for slave, which is how I'm told it was set when it was on the primary channel of the other computer.  It is currently jumpered for master.  This is probably one of those things I'll never have the exact answer to, but I'd still be interested if anyone has any further ideas.  I'm agreeing with the comments at this point that jumpering had something to do with it.  If I don't hear anything in the next couple days I'll close this question and chalk it up to one of those many unanswered questions....
Fatal_ExceptionSystems EngineerCommented:
It could have been as simple as the head bumping a sector as it was moved around, creating non-contiguous errors in the files needed to boot.  Since chkdsk fixed this (as it fixes so many unanswered WHY's), that may be the case.  Mis-jumpering it should have no affect in the disc spin up, at least as I understand it.

But the bottom line here is you got her running again.

Happy Holidays

FE  
slandiseAuthor Commented:
Maybe I do have an answer after all.  Upon investigation, it turns out that the computer was shipped from the manufacturer with the Welchia virus.  Fortunately it was not on a network.  I have never heard of Welchia causing failure to boot, and particularly failure to allow a computer to boot even when the drive is installed as a slave, but that's what I will chalk it up to for now.  Thanks for everyone's help!
Fatal_ExceptionSystems EngineerCommented:
OMG...  Guess you don't want to tell us the Brand Name, eh?  :)

Again, just glad to see her fixed.

FE
slandiseAuthor Commented:
It was a custom built system from a company that installs the OS and their own program from an image...  an image that happened to be infected!  But it's not a brand name, so not to worry!
Fatal_ExceptionSystems EngineerCommented:
Figures.  Sloppy, if you ask me.  But since nobody did...:)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.