Solved

Selective Internet Browsing

Posted on 2003-12-11
10
590 Views
Last Modified: 2010-03-17
I have a client who is having a very strange problem that I've never encountered before.  The family has DSL and the connection is up and they can browse to *some* websites.  For example, they can go to Google and do a search but when they try to follow the links none of them will go. They get the "Page could not be opened" message.  (They are using IE not Netscape). I recently upgraded their machine from Windows Me to XP.  When I left, it worked fine.  A couple of days later they started having the problem.   I tried to rule out any software related causes of this, even going so far as to remove a pop up blocker, which I didn't think was the culprit but I thought I should at least try. The firewall is also not enabled. Then, the woman suddenly tells me that they have another computer in the house and that it is behaving in exactly the same way.  What in the world could be causing this?  A faulty DSL modem would seem to cause no connection or intermittent connections but not always allow some pages to load and never allow other pages to load.  This problem just started a few days ago and the only thing I know that has changed is the upgrade to XP.  The other comptuer was untouched, and as I said, I didn't even know it was in the house.  Can someone please help?
0
Comment
Question by:TomAsimos
  • 4
  • 2
  • 2
  • +2
10 Comments
 

Assisted Solution

by:phr33kz0l
phr33kz0l earned 100 total points
Comment Utility
You say this is only the case with some webpages ?
Have you tried overriding the MTU settings ? Theres a lot of programs out there that let you do this, 'RASPPPOE' beeing one of them. You may have to lower the MTU settings, theres a manual that comes with RASPPPOE which will tell you exactly what to do in case you dont know. All I can think of for now, try doing a ping -t from the command prompt to those pages that dont load & see wether your connection to them runs smoothly.
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 200 total points
Comment Utility
Are they using MS Internet Connection Sharing from one PC?

It is a MTU issue with the overhead of the PPPoE with DSL..
http://support.microsoft.com/default.aspx?scid=kb;en-us;319661
0
 

Author Comment

by:TomAsimos
Comment Utility
What are some of those other programs that let you override the MTU settings, as I'd rather not go into the registry myself as the Microsoft article describes?  They have a Netgear router.  I don't know what MS Internet Connection Sharing from one PC is, but from the sound of it, it sounds like its a software component that does something similar to the router.  So I would guess they're not using it.  If it helps, there is only one item in the Network connections control panel and that's the Ethernet card.  I read the Microsoft article lrmoore linked above, but what I don't understand is why this problem still persists even though we have downloaded and installed Service Pack 1 for XP, which the documentation says should fix the problem.  Any more hints?
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 200 total points
Comment Utility
The service pack only helps if you are using Internet Connection Sharing.
the issue is the same, an MTU problem due to the overhead of PPPoE and DSL
The netgear router may have a setting to change the MTU from 1500 to 1492
Else, DrTCP is a small utility that can be installed/ran on a workstation:
http://www.dslreports.com/front/drtcp.html
0
 

Author Comment

by:TomAsimos
Comment Utility
I have some updated information on this.  I tried what the Microsoft article suggested about ping -r? -l (can't remember syntax off hand) and then the MTU to the default gateway, which in this case is the DSL modem.  As you'll predicted, it came back fragmented.  I kept lowering the MTU and pingin until I got to 1472 and then it came back "reply" instead of fragmented.  So, I used the DrTCP utility to change the MTU to 1472.  I then rebooted the computer and expected to be able to browse.  I went to Jigzone.com, which is one of the sites the client wanted to browse and it still didn't work.  So, I thought maybe the utility didn't work, so I followed the Microsoft instructions and found the registry key for MTU value and sure enough it was set to 1472.  So, I'm scratching my head and then I thought, well let's ping it again at 1472 and see what happens.  This time 1472 comes back fragmented.  So I kept pinging until I found another number that sent "reply" back, set the MTU to that number, and rebooted.  Same thing. Wouldn't connect.  So, I tried the ping again and this time it was down to 1430.  It was as if everytime I rebooted the computer the MTU went down.  Since it was a viscious cycle, I stopped.  I did some further research on this and read a suggestion to configure the router instead of the MTU in Windows XP.  I put in the address of the default gateway in IE and it wouldn't come up--page not found.  So, I went to look at the equipment and discovered that they had an old NetFlx modem with one output and an old 4-port double speed network HUB, not router.  Does this have something to do with the problem? Do they need a router?  They are using static IP addresses and when you change it to dynamic IP addressing and do ipconfig /renew it just freezes.  I didn't know anything about MTUs before I started this, but after having read the documentation, I thought this was fairly straightforward and told the lady that we could probably easily fix the problem--and then this happened.  So what do I do now?  If you think the router is the issue, I can unplug mine and take it to their house as a test.  Or is it the modem or something else, like software related items?  Please help.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 10

Expert Comment

by:jobrienct
Comment Utility
Hi TomAsimos,

try connecting the computer directly to the dsl modem eliminating the hub. Who is the ISP in this? If AOL I would recommend the broadband blaster modem, if SNET the Speedstream is the only one SNET will support. Set up a PPOE network connection with their login info and then check ping. the hub shouldnt be doing any harm, but eliminating it will help isolate the problem. If connect well with tehir existing modem see if you can setup internet connection sharing. get them to spring for a netgear router if thats not doable. Its a bit less troublesome then linksys. 1492 should be the ideal setting for either of the 2, but your modem is a likely culprit.


John
0
 

Author Comment

by:TomAsimos
Comment Utility
I can't connect the modem to the computer directly because they are in different rooms.  I can try taking my Netgear router up there and see if it works.  There is no Linksys involved.  But you think we should call SBC and get a new modem?
0
 
LVL 10

Accepted Solution

by:
jobrienct earned 200 total points
Comment Utility
If your provider is SBC you should have a speedstream modem if only to get support from the provider This is the modem they supply with a new service. speedstream 5360 is supported I'm sure. I would;

a. grab a long cat5 cable and hook the computer directly to the modem, test connection with sustained ping for dropped packets.

b. replace the modem and test again. If no joy (packets still drop) then the modem isnt your issue. bring in a laptop and test their service from that. look for I/W issues such as unfiltered phones on the DSL line, Exposed wires, use or overuse of extensions, etc. If you suspect I/W issue install a NID splitter and run a home run directly from the data side of the splitter to your local jack.

calling SBC will likely get a double priced modem at around $100, look around and find it for $50, I can find them for $35 as pulls.

an alternative that still maintains SBC support is the speedstream router, but thats a $400 investment I believe.

John

John





0
 

Author Comment

by:TomAsimos
Comment Utility
The problem is not resolved, but I too believe it to be a hardware problem with the modem or the line coming into the house.  What's weird is that I took my extra DSL modem to hook up and try but their DSL is not coming over the phone line.  Their modem is so old that it uses an Ethernet connection for both the network wiring and for the line port.  The customer told me that since they were one of the first to get DSL (he works for SBC) that they came in and put a spliiter outside and then ran the wire into the house.  So, there was nothing I could do except call technical support.  They verified that this particular modem had been used a LONG time ago and in very few houses.  But the DSL department said that they didn't even handle the support for it.  They said that the "line department" would have to handle it and were supposed to call the client yesterday.  I haven't heard back from her yet.  I suspect that they are just going to reprovision the line so that it is compatible with today's modems becuase it is doubtlful that they even have any of those modems to replace their current one.
0
 

Expert Comment

by:napatec
Comment Utility
Hello TomAsimos,

I just wanted to add that in my experience this problem has always been solved by Matching the MTU of the "clients" with the MTU of the "host" ( computer directly connected to the DSL modem). So far the magic number seems to be 1454 for a PPPoe setup.
 I used to do all the registry changes by hand, now you can just download the TCP optimizer from speedguide. It's so much easier to backup current settings and then tweak as needed. It also allows you to choose the exact network adapter to apply the changes to without affecting any others you may have installed.

I know you have tried changing the mtu to resolve this but it's very possible that you didn't match any of the machines mtu and that you may have changed the mtu for the wrong adapter in one or more of the machines, especially if you have a mixed OS network.

Just my two cents, you can use the link below to download the tcpoptimizer.

http://www.speedguide.net/files/TCPOptimizer.exe

-Gordon
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

This solves the problem of diagnosing why an internet connection is no longer working. It also helps identify the likely cause of the lost connection if the procedure fails to re-establish your internet connection. It helps to pinpoint the likely co…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now