[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 460
  • Last Modified:

Missing zeros in Word mail merge. Data imported via Office Partner (Delphi)

I'm using Office Partner (www.turbopower.com) to import data to Word for mailmerge. My problem is that leading zeros are not shown. How can I set that the leading zeros are shown. I had the same problem in Excel and formatted the cell to show leading zeros, but how can that be done in Word?

real data: 02200
shown in word: 2200


Regards
  Janne
0
olmy
Asked:
olmy
  • 3
  • 3
  • 3
  • +1
2 Solutions
 
Joanne M. OrzechManager, Document Services CenterCommented:
0
 
DreamboatCommented:
Hit Alt+F9 in your main document.

Change the zip code field to read like this:

{ MERGEFIELD Zipcode [\# "00000"] }
0
 
olmyAuthor Commented:
Thank you. I got same answer from both of you and now I know how to do it manually. Next, I need to know how I can do it in my software, when the mailmerge field is added into word. I send more information about it on monday. Thank you and have a good weekend.
0
How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

 
Joanne M. OrzechManager, Document Services CenterCommented:
If you're using VB, I can help with that.
0
 
DreamboatCommented:
Basically, olmy, I think that if you change your data connection method (act like you are going to change to a different data source and choose "select method" checkbox) to DDE, that may resolve the issue.
0
 
olmyAuthor Commented:
Thank you for you comments.

Dreamboat: I don't know how to access the "data source" setting. Could you give a little more information about that.

Jorzech: I'm using Delphi with OLE-interface and I'm pretty sure that most important part of that code is almost identical. What I need is the calls that enables me to drive Word in a right way.

Is it possible to turn off the way Word handels numbers? Actually those post-number fields are text fields, but Word twistes them into numercial form and then the leading zeros drop out.

Best regards
  Janne
0
 
Joanne M. OrzechManager, Document Services CenterCommented:
You need to declare your variables and then Word won't "twistes them into numercial form and then the leading zeros drop out."

Dim YourField as Integer

frmForm.TextBox1.Text.Value = Format(YourField, "####0")

0
 
DreamboatCommented:
Janne:

I've already stated how to set the connection method:
(act like you are going to change to a different data source and choose "select method" checkbox)

If you want explicit, I need your version of Word.
0
 
olmyAuthor Commented:
Dreamboat: I'm sorry, but I really cant find the thing, what you are telling me. I have Word 2002. Is it a word dialog or a call via OLE-interface?
0
 
daleoranCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

Split: Dreamboat & JOrzech

Please leave any comments here within the next four days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Daleoran
EE Cleanup Volunteer
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now