Solved

CanoScan D646U Scanner Problem

Posted on 2003-12-12
7
574 Views
Last Modified: 2011-10-03
I have a problem with my scanner , for some reason  i wanted to scan a picture today, i click "acquire" on my favorite picture viewer (infranview) like always to scan a picture..and I received a error:

" TWAIN error!
Can't connect to device or the TWAIN Driver is not installed! "

well i tried with "Select twain source" on my favorites image programs like infranview and photoshop, the source list is empty..

..Looks like the twain driver is not installed or corrupted.. so i uninstalled the driver and i installed it again but it's the same..

I'm very frustated right now :(, i tried everything ..the usb port is connected and i have the latest driver..also when i did a test in the driver propierties it says that it's working fine but i cannot scan anything , i can't also see the scangear manager..

My system is Xp Home.
Please help me to solve this problem. thanks in advance.
0
Comment
Question by:sergio23
  • 3
  • 2
7 Comments
 
LVL 32

Expert Comment

by:LucF
ID: 9928098
Have you checked all cables? Also, have you checked for updates for your USB controller? Chipsetdrivers? etc.
Also, try updating XP => http://windowsupdate.microsoft.com
If also that fails, try Start => Run => type "SFC /scannow" (without the quotes) and press enter.

Greetings,

LucF

p.s. you did try the updated drivers from here? => http://tinyurl.com/yx6f
0
 

Author Comment

by:sergio23
ID: 9932408
still the same :(

I want to say that i used my scanner las week, it was ok..i didn't know what happen.

:(

I think it's a problem with the TWAIN Driver in my system., i don't konw much about it.
0
 
LVL 32

Expert Comment

by:LucF
ID: 9932431
Have you tried your scanner on another computer, if it doesn't work there, your scanner might have died :-(
0
 

Author Comment

by:sergio23
ID: 9933675
it works m8, it pass the test...there are not problems with the scanner, i think it's a problem with the TWAIN DLL that comes with windows XP, i think its damn corrupted...practically its a problem with the TWAIN. Is there a way to get this dll fresh and register it via run command?
0
 
LVL 32

Accepted Solution

by:
LucF earned 125 total points
ID: 9933731
You can probably find it at http://www.dllfiles.com after you've found it, you can register it by: "regsvr32 <dllname>.dll"
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
This is about my first experience with programming Arduino.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question