ALTER TABLESPACE READ WRITE and ORA-01256

Hello,

 Somteimes after this command : ALTER TABLESPACE READ WRITE
 I receive : ORA-01256 error in locking database file xxxxx

 The messages manual says :
   Cause: The file is in use by another database instance.
   Action: Determine which database instance legitimately owns the file.

 But there's only ONE instance on my server.
 How can I see who is locking the .dbf ?

 Thanks


Xav2Asked:
Who is Participating?
 
Computer101Connect With a Mentor Commented:
PAQed, with points refunded (125)

Computer101
E-E Admin
0
 
SDuttaCommented:
Do you have any other transportable tablespaces ? Does the tablespace have any partitioned table that is partitioned over to another transportable tablespace ? If you do, then you may face this error after exporting the other transportable tablespace.
0
 
Xav2Author Commented:

 The tablespace is not a transportable TS .
 I put it RO to prevent backup of static data and now Iwant to drop it.
 
 The tablespace contains one partition of a partitioned table.

 
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
SDuttaCommented:
Say you have tablespaces T1, T2 which contain the partitioned table Table1.
Tablespace T1 is read-only and T2 is read-write.

Create another table with the same columns as the partitioned table in tablespace T2.
SQL> create table mytable tablespace T2
as select * from table1 where 1 = 2;

Exchange the partition with the newly created table.
SQL> alter table table1 exchange partition p1 with table mytable;

Mytable now has partions in T1 and T2.
Drop the newly created table mytable.

Now your tablespace T1 does not have any overlapping partitioned tables.
You should now be able to make it read-write or even drop it.

0
 
seazodiacCommented:
Try to shutdown the database in normal mode.

then log in as sys, start the database in the restricted mode:

SQL> start restricted
0
 
Xav2Author Commented:

 Here's the solution :

 Increase the Sun-Solaris parameter rlim_fd_max (max number of open files per process) then reboot.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.