Avatar of jrcsnet
jrcsnet
 asked on

Win XP to Linux Printing Slow

Heres the situation. We have a Windows XP client network, with a Redhat 9 file server (samba) and a Redhat 7.3 (also samba) print server. There is a Laserjet 1100 attached to the 7.3 box, and it prints fine from the system itself. When printing across the network, it works on 4 of the 5 computers without incident, however on that last computer it constantly times out, or locks up the computer when you try to open the print queue. On the odd ocasion that it does print, it often takes 5 minutes to print a single page of text.

It is not an issue with user permissions, as the same user can login to any other computer in the network and print fine. The systems are all on the same subnet, and I have also tried changing hte IP of the problematic system to no avail. The printer uses LPRng. Any suggestions?
NetworkingTCP/IPInternet Protocols

Avatar of undefined
Last Comment
chicagoan

8/22/2022 - Mon
Les Moore

Do you have Netbios over TCP/IP enabled on this XP box?
Enabling NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.

REFERENCES:

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/winxppro/reskit/prjj_ipa_zeft.asp

http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm
chicagoan

Try the LaserJet 4 on this machine and see if that helps.
chicagoan

Also, have you checked this machine's ethernet connection for speed/duplex mismatch?

above I meant to say

Try the LaserJet 4 DRIVER on this machine and see if that helps.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
jrcsnet

ASKER
I will give the printer driver a shot... it doesn't seem to be an issue with the NIC as it works fine on the internet, as well as accessing shared folders on both the print server, and the file server.
chicagoan

wouldn't hurt to take a look at the negotiated rate... just take a sec! ;)
otherwise I won't be able to sleep
jrcsnet

ASKER
NETBIOS over TCP/IP is enabled, computer browser is started. No change at all. Checked the link speed, the switch is at 100mbps FD, and so is the NIC. Print server is only at 10mbps however since the other workstations are also 100mbps I can't see why this would be the problem.

Also tried using a Laserjet 4 driver, doesn't seem to be any change either. The more I look at the system I am thinking it is network related as the explorer window totally locks up for about a minute after trying to double click on the print queue. Then once it does open, the title reads 'Laserjet 1100 on printserv Initializing' for about a minute. and if I close the window, I have to go through the entire process again to be able to get in.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
chicagoan

As long as the switch ports and the machines have the same speed/duplex settings, that's fine.
What's in the nmbd and smbd logs?
Is this workstation's address set up correctly in wins/dns/lmhosts  (forward and backward)?
jrcsnet

ASKER
There is no wins/lmhosts setup on the network, but DNS is correct. Like I said I can access shared folders on both servers, including browsing to the printer.

log.nmbd shows just the standard starting up and terminating messages from when I told it to restart, log.smbd shows nothing out of the ordinary also, just the startup/shutdown messages. I am going to upgrade the print server to the latest samba 3 tonight, hopefully it might be a weird bug or something in 2.x
ASKER CERTIFIED SOLUTION
chicagoan

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
chicagoan


and what's the name resolve order in smb.conf?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
jrcsnet

ASKER
Found the problem, thanks chicagoan for mentioning the PTR record, it seems there wasn't one for the print server. Added one and now it all appears to work. :)
chicagoan

Had to be something!
glad to help