kernel panic: VFS: Unable to mount root fs

Hi all,

I'll start off by stating that I'm pretty new to linux so this could likely be a stupid newbie mistake. Here's the problem:

The kernel I have working is version 2.4.22 and I can still boot up to that. I compiled a 2.6 version and installed it in exactly the same way that the old version is, just appending 2-6 to the end of the file. I did this also with /etc/lilo.conf and ran lilo afterwards so when I reboot I get a menu that shows linux and linux-2.6

linux still boots up fine but when I try and boot up linux-2.6 I get some ouput and then a kernel panic with this message:

<snip>
VFS: Cannot open root device "888" or unknown-block(8,8)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(8,8)

I am running debian testing on a dell poweredge 1750. It has 2 Xeon processors and 1 scsi HD. The whole reason behind my compiling a kernel is trying to get support for high memory (this machine has 2 gigs of ram) and multi-processor support.

I doubt this has anything to do with lilo and suspect that I've somehow configured the kernel wrong. I am using reiserFS and I'm pretty sure I selected all scsi and driver support. Everything is compiled in and not as modules.

Any help would be greatly appreciated! Thanks in advance,

-Pat
LVL 3
pat5starAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arjanhCommented:
Looks like more people have this problem with 2.6... Try adding this line to your lilo.conf to the new 2.6 section :
append = "root=/dev/sda8"

To get the correct value of the root device, boot into your 2.4 linux and do a 'df -k'. The device that shows up as "mounted on /" should be specified in your lilo.conf
pat5starAuthor Commented:
Hi arjanh,

I added that to lilo and it still didn't work. I even tried at the startup prompt doing linux-2.6 root="/dev/sda8" which I think is effectively the same thing, and it too did not work.

-Pat
pat5starAuthor Commented:
Looking at the error message I noticed it was slightly changed after adding the append line to lilo.conf. It now reads:

VFS: Cannot open root device "sda8" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)

The root directory is sda8.
Maximize Customer Retention with Superior Service

The IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more to help build customer satisfaction and retention.

arjanhCommented:
The problem may also be caused by devfs being enabled, try adding 'devfs=nomount' to the append line. If this is the case, you might get some more info at http://www.torque.net/sg/devfs_scsi.html
shivsaCommented:
could u check on IDE support, whether is turned on or not.
Check your .config and look for CONFIG_BLK_DEV_IDE and CONFIG_BLK_DEV_IDEDISK entries.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shivsaCommented:
also if u have root=LABEL=/ line in your lilo.conf, remove it/uncomment out.
pat5starAuthor Commented:
Hi all,

Thanks for the help. It turns out it that I didn't have the right option selected for the scsi and I was sure I did. oops!

Anyways, I'll split the points amongst you for the effort. Thanks again,

-Pat
1stomniCommented:
Pat,

Please tell us what option you selected for scsi to fix this
ketuphatsCommented:
try this..

$ df -h
<root directory>

edit your lilo.conf..

append = "root=<root directory>"

run lilo..

$ /sbin/lilo

$ reboot


sagar24Commented:
Hi,

I tried all the above things but still I am getting the same error.  Below I am giving my .config file .  I am doing this on Xeon mechine.  and Operating system is redhat 9.


RaseelCommented:
Hey,
Even I'm encountering the same problem. I checked my SCSI and IDE settings too, everything .. dunno whats gone wrong.

Basically can some1 tell me what root=LABEL=/ exactly means?
AS in, where is LABEL defined, why are there two = in this entry only, et al.?

Raseel.
l0stCommented:
Hi, I had the same problem after recompiling my kernel.
Is reiserfs compiled in your kernel?
if its just a module then try making one initrd image with the reiserfs module
mvandererveCommented:
Hi you all.
it is the 2Gig boundary of the memory. there is a bug in kernel 2.6. So when you reduce your meemory to 1 G you'll see that you won't have any problem.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.