the list of servers for this workgroup is not currently available

I have a small workgroup network consisting entirely of wXP and w2k machines, 4 in total.  All have personal firewalls and there is also a Linksys firewall providing overall service and DHCP service.  I use Windows file and printer sharing and in the past all 4 machines have seen each other, shared files and used the printers.  Now one of the machines gets the message "the list of servers for this workgroup is not currently available" when I try to show the Network Neightborhood list of other machines.  However I can ping the other machines  

On the other machines you can see the errant machine in the browser list.

I do have the MS firewall turned off and I do have NetBIOS over TCP/IP turned on.  

What do I need to do to get this machine to be part of the workgroup again?  I've done all of the obvious stuff.

Thanks, Rich
parent55Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shivsaCommented:
For Win2k machine:
---------------------
http://www.experts-exchange.com/Operating_Systems/Win2000/Q_20737456.html
http://www.experts-exchange.com/Operating_Systems/Win2000/Q_10405458.html
 Have a look at this Microsoft KB article:
http://support.microsoft.com?kbid=285035 
=============

  System error 6118 has occurred. The list of servers for this workgroup is not currently available
SYMPTOMS: 1) After enabling ICS/ICF, you can't see any computes on My Network places. If you try, you may get "workgroup is not accessible". 2) If you use the net view command, you may receive "System error 6118 has occurred. The list of servers for this workgroup is not currently available." message.
Resolutions:
1) This behavior can occur if you enable the ICF that will closes the ports for file sharing by default. To open these ports, right-click the network connection that is firewall protected> Properties>Advanced>Settings>Service Tab>Add, Enter 127.0.0.1) for the required Internet Protocol (IP) number. Enter UDP ports from 135 through 139, and TCP ports from 135 through 139 one by one (the external and internal port numbers should be identical).
2) This may occur if the workgroup name and the domain name are the different.
3) No master browser. Starting Computer Browser Service on one of w2k/xp computers should fix the problem

==============
3865 » Windows 2000 can't access 'Computers Near Me' in their workgroup - server list is unavailable
http://www.jsiinc.com/SUBH/tip3800/rh3865.htm



stevenlewisCommented:
could also be a master browser issue
http://www.winguides.com/registry/display.php/54/

1 - On the master computer, set KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\MaintainServerList

to "YES". Set this key to "NO" on the other computers. Note that any computer using

the default setting "AUTO", which is later connected to the network will not be able

to browse until the key has been set to "NO" on that machine.




parent55Author Commented:
shivsa's comments:  Issues I've already looked at.  1) The ICF is not enabled and the firewall I'm using is not blocking UDP ports 135 through 139.  2) There is no PDC and the workgroup name is the same on all machines.  3) The computer browser service is already running on all of the machines.

Stevenlewis comments:  I set the parameter mentioned to Yes on one of the main workstations and set the parameter to No on the problematic machine.  Previously both machines had the parameter set to Auto.  This did not solve the problem.

The problem seems to be somewhere else.

Thanks, keep trying, Rich

Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

shivsaCommented:
did u checked the previous EE solutions i posted.
stevenlewisCommented:
as a test, install NetBEUI on all boxes
here's how on XP
http://support.microsoft.com/support/kb/articles/q301/0/41.asp
parent55Author Commented:
Re' shivsa's comments:  Yes I looked at all of the links you provided as well as the one provided by stevenlewis.  I checked them all out and they did not solve my problem.

Re' stevenlewis comments:  As you know NetBEUI is an old broadcast-based level 2 (non-routable) protocol that is no longer supported by Microsoft.  Before I consider installing it, it would help me to know what you are asking me to test for.  Knowing that, we could consider whether there are other ways to test for that issue.  I would not continue to run NetBEUI other than as a test, so if it did work then we'd need to know why.

Thanks for the new suggestions, keep them coming.

Rich
parent55Author Commented:
Is there more information that I can provide about my enviornment that would help you?

Rich
stevenlewisCommented:
>>As you know NetBEUI is an old broadcast-based level 2 (non-routable) protocol that is no longer supported by Microsoft.  Before I consider installing it, it would help me to know what you are asking me to test for.
Yes, I know that, but is included for backwards compatibility, and for testing purposes
I want to see if when using NetBEUI it gets the list of servers (if it does, then we can look towards NetBIOS over tcp, If not, then we can look more at the browse master issue)
stevenlewisCommented:
I would also triple check the settings on the firewall
ShineOnCommented:
Per CrazyOne's recommendation, I am going to recommend that you try IPX with NetBIOS over IPX enabled.  See this PAQ for more information:  http://www.experts-exchange.com/Operating_Systems/WinXP/Q_20834306.html

If it works with NetBIOS over IPX, then you have a name resolution issue.  Since IPX is a routable transport that broadcasts service advertisements, if it works where IP does not, then the solution is very possibly populating and using LMHOSTS in your IP configuration, because IP does NOT broadcast service advertisements.  Therefore you need to provide IP a way to resolve names to IP addresses.

The NetBIOS over IPX test will work in environments where the NetBEUI test does not.
parent55Author Commented:
Problem Solved !!

The problem:  My laptop and another computer I have both worked fine in my office network.  One running XP the other W2k.  At different times (8 months apart) both machines were used for a short visit to UCLA and connected to their network.  Upon return, both computers refused to join my local workgroup and gave the error "the list of servers for this workgroup is not currently available"

The Analysis:  The first time I never solved the problem.  This time I was able to use the very new 2004 version of NetScanTools Pro from Northwest Performance Software (see http://www.netscantools.com/nstpromain.html )  I highly recommend this tool which has many features including analysis of the NetBIOS relationships on a network.  Using this tool you would have seen that most of my computers are "Broadcast" node types, but that the two problem machines are "Point-to-Point" node types.  The Help description in the product advises that one of the parameters that may *optionally* be set by *some* DHCP servers in your registry is "DhcpNodeType" and that this parameter once set will persist in the computer's registry.  Since not all DHCP servers set this parameter, when the machine is moved to another network, like the typical small office or home office (SOHO) network, that network's DHCP server probably does not change the parameter and the machine fails to join the workgroup and gives the error message.  This is because the typical SOHO network is set up using the default "broadcast" node types and the persisting DhcpNodeType parameter continues to tell the malfunctioning machine to be a "point-to-point" node type.  The two types do not talk to each other.

The Solution:  Upon return from travel, if your laptop fails to see your workgroup and gives you the error message "the list of servers for this workgroup is not currently available".  Check your registry for the DhcpNodeType parameter at the registry location shown below.  If the value is 2 then change it to 1 and reboot your machine.  Optionally you may choose the value 4 or 8 to have your machine work in both environments (see below).

Registry Location:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netbt\Parameters
Key: DhcpNodeType
Value Type: REG_DWORD - Number
Valid Range: 1,2,4,8 (B -node, P-node, M-node, H-node)
Default: 1 or 8 based on the WINS server configuration
Description: This optional parameter specifies the NBT node type. It is written by the DHCP client service, if enabled. This parameter determines what methods NetBT uses to register and resolve names. A B-node system uses broadcasts. A P -node system uses only point- to-point name queries to a name server (WINS). An M -node system broadcasts first, and then queries the name server. An H -node system queries the name server first, and then broadcasts. Resolution through LMHOSTS and/or DNS, if enabled, follows these methods. If this key is not present, the system defaults to B -node if there are no WINS servers configured for the network. The system defaults to H -node if there is at least one WINS server configured.

By the way, there is another optional parameter at the same registry location that you (or a helpful Net Administrator) may add which will override any DHCP server value placed in the DhcpNodeType.  If present, check that the value of this parameter is correct as well.

NodeType
Key: Netbt\Parameters
Value Type: REG_DWORD - Number
Valid Range: 1 - 8
Default: 1
Description: This parameter specifies the NBT node type. It is an optional parameter that, if present, will override the DhcpNodeType parameter. See the entry for DhcpNodeType above for a complete description.
parent55Author Commented:
Hi, I solved the problem myself, do I get the points :-)
Rich
shivsaCommented:
yes u get the points.
just post a message to CS and ask for PAQ/refund.
stevenlewisCommented:
PAQ, the questioner explained how they solved, and it is good info
my 2 ¢
parent55Author Commented:
Hi,  I have answered all questions from experts and also solved the problem myself.

I posted the solution in a response to my question.

I also pointed out a small error at the beginnng of the last paragraph of my solution post that might confuse someone and requested that it be corrected.  Here is that correction again:

Wrong:
NodeType
Key: Netbt\Parameters
Value Type: REG_DWORD - Number
etc......

Right:
Key: NodeType
Value Type: REG_DWORD - Number
etc.......

I was told that since I solved the problem myself I would be eligible for the points.  Since I'm a paying subscriber, I have unlimited points to award.  My request to win my own points was an attempt at humor.  If this is causing a problem, please ignore my points award request and just mark this question solved so others can benefit from it.

Thank you, Rich
LunchyCommented:
PAQed, with points refunded (500)

Lunchy
Friendly Neighbourhood Community Support Admin

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
plseelosCommented:
I'm new to the expert exchange but it has been very useful and worth the price already.

I have read this thread with interest, because I have been experiencing the same problem.  A Workgroup network with 7 computers, mostly XP (with SP2 as of a few days ago).  Now I can Browse the network from any machine.  I changed the registry entries for DHCPNodeType on all the machines and tested as I went along with no success.

When I got to the last machine I found Zone Alarm running (the free version).  I closed Zone Alarm (which caused the new ICF in XP SP2 to activate).  All of a sudden I could see all the network from all the machines.  I had this experience eaerlier with Zone Alarm over a year ago but thought it was resolved.  I think Zone Alarm Pro has a special setting to work on a Windows network but the same setting is not available in the free version to my knowledge.  

I am back in business with all machines on the net and no Zone Alarm but Windows ICF working fine.

Thanks for all the information and ideas which led me to correct my problem (and also understand it more).
mmeiner2Commented:
Thanks to all for this thread, especially "plseelos"...

I had VERY similar problem symptoms on my SOHO network.   Somewhat similar to the "Zone Alarm" situation, my problem resolution was to correctly configure Norton Internet Security (duh).

Within "Personal Firewall," used the wizard for "Internet Zone Control" to allow access from machines on my SOHO's subnet (which I recently changed).
WarHoweCommented:
I had the same problem.  Before making the registry changes, I went back to my free Zone Alarm to check the settings.  I simply changed the "Internet Zone Security" to Medium (was at high) and I then had access to the network.  It appears to have solved the problem.
parent55Author Commented:
Several people have noted the importance of checking the firewall settings before making the more challenging registry changes.

To Summarize:  There are really two different solutions documented in this thread for the problem "the list of servers for this workgroup is not currently available"

1) The simple solution of making sure that your firewall software is permitting the local Netbios over TCP/IP traffic to pass.  The server list is propogated using NetBIOS over TCP/IP, and by default using a broadcast mechanism.

2) The very difficult to find problem of having the registry DhcpNodeType silently set to work "point-to-point" when later you will need it set to "broadcast".  As mentioned earlier this is only likely to occur on a laptop or other computer that is moved around and connected to multiple networks.  If one of those networks has a DHCP server configured to feed your laptop the "point-to-point" registry configuration for your DhcpNodeType, this unfortunately  "sticks" with you in your registry.  Then when you move onto another network that uses the more typical default "broadcast" configuration to propogate the server list using NetBIOS over TCP/IP you are left out in the cold.  This is a devilishly hard problem to figure out.  It happened to two differnet computers that I briefly had connected to the UCLA campus network and then brought back to my office.

Rich

x13Commented:
Thanks for this helpful solution Rich. I actually needed both solutions: excluding ports 135-139 through my firewall AND correcting the Node Type (mine was "unknown"). Thanks again. I was scratching my head on this one for a while!
geekboystevesCommented:
I had tried everything and was going crazy.  All my Windows XP Home PCs saw the workgroup and one of my XP Pro PCs did but the other two did not.  For four hours my tech (computer science major) and I worked the problem and got nowhere until we found this EE topic and changed Key: DhcpNodeType from 2 to 1.

Instantly, the workgroup lit up!  Yipee!

Phew.
swachtelCommented:
Inspired by this thread, I solved a similar problem in my network. I'd had to remove and reinstall the TCP/IP protocol because of a problem with MAPI to my exchange server. Outlook was fine, but I couldn't see the domain list.

A simple
NBTSTAT -R
(refresh cached netbios names)  solved the problem.
swachtelCommented:
I need to retract that suggestion about NBTSTAT.

I'm working remotely and I got confused about which machine I was on when I issued the command and then did NET VIEW.

I'm going to check the registry suggestions more carefully.
dlubbsCommented:
Rename your PC using only A/N characters. Don't use

-_!@?,*& (Looks like cartoon profanity)

I did this and the system began to show up again in the Workgroup.

dan_venableCommented:
Parent55, your solution worked for me. Thanks.
suhsalmanCommented:
Hello all,

I just want to share this:

this problem may happen also when using Microsoft windows 2003 server, after enabling Routing and Remote Access service.

Solution:
enable NetBIOS over TCP/IP from the WINS tab on Advanced TCP/IP configuration.\

Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.