Solved

Serial Port....what's using it?

Posted on 2004-01-28
6
3,368 Views
Last Modified: 2007-12-19
I have a DEll 4600 running XP.  I'm using an external modem for DSL.

When I want to get photos from my digital camera onto the computer, it get's hooked up to the serial port.  The serial port is also used to program my X10 module.  Niether is done at the same time.

On my last computer, both worked on COM2.  On this machine when I try to use them, I get no connection and they indicate COM2 is in use by another program or piece of hardware.  I know the internal modem for voice and fax is using COM3.

How can I find what is using COM2.  I get no connection when trying to get the camera or X10 module on COM1.

Last....both of these devices worked when I first installed them and their software on the computer.
0
Comment
Question by:weazer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
6 Comments
 
LVL 69

Expert Comment

by:Callandor
ID: 10221574
Get a readout on all your devices with Aida32: http://www.aida32.hu/aida32.php

You should be able to see if COM1 is working if you go into Control Panel->System->Hardware->Device Manager and look under Ports.
0
 
LVL 16

Accepted Solution

by:
Kyle Schroeder earned 500 total points
ID: 10221721
It may say its in use but what it really means is that there is a process locking the port (probably some background process) waiting for you to plug in an X10 device or the digital camera.  it constantly probes (or just listens passively) for the device to connect.  I've seen this many times with Palm handhelds/PDAs, and the easy fix is to just disable the application in question.

check device manager and remove any/all COM ports, I've seen some machines on XP with COM port problems and generally removing all the ports and letting XP re-detect them will fix it.  It could be a BIOS related problem also, Dell has had some BIOS-related serial port issues from time to time.  Or the COM1 might be set for IRDA mode in BIOS for some reason, press F2 at power-on to check that, it might be under "Legacy Peripherals" or "Integrated Peripherals" section.   I'll find you the latest update for that 4600.

Also, COM1 and COM3 typically (in the "old times" before ACPI) shared an IRQ, so you could try changing your modem properties to make it COM5 or 6, etc.

-dog*
0
 

Author Comment

by:weazer
ID: 10222804
Followed your advice......solved the problem.
Thanks
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 10224214
weazer:
What specifically fixed it?  Removing and re-adding the ports?  Just curious to have a well-defined answer in case someone else finds this question in the future who is having the same/similar problem.

Thanks!
dogztar
0
 

Author Comment

by:weazer
ID: 10227295
After doing all the various checks...I determined it was an application tieing up the port.  I finally did a system restore (which I was afraid to do being new to XP) from the day I knew everything including the camera and X10 module were able to communicate with COM 1.

Now everything works.
0

Featured Post

Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…
Suggested Courses

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question