We help IT Professionals succeed at work.

Timeouts

Paulmul
Paulmul asked
on
386 Views
Last Modified: 2010-03-04
Hi,

I'm running apache on Redhat 9.0 I need to run an experiment for several hours, I have been trying to run it over night but the server (my machine) keeps timing out. Is there anyway to change the server timeout? I am running a perl script which runs for a while then I get a timeout error.

Any help greatly appreciated,

Paul
Comment
Watch Question

Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Commented:
What is the perl script doing?  How about looking in the apache log usually in /etc/httpd/logs/error_log

To change the timeout rate in the httpd.conf you go to the line that says

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

~~~~~~~~~~~~~~~~~~~~~~~~~

Here is some more info. on the timeout rate:

TimeOut Directive
Description: Amount of time the server will wait for certain events before failing a request
Syntax: TimeOut seconds
Default: TimeOut 300
Context: server config
Status: Core
Module: core

The TimeOut directive currently defines the amount of time Apache will wait for three things:

The total amount of time it takes to receive a GET request.
The amount of time between receipt of TCP packets on a POST or PUT request.
The amount of time between ACKs on transmissions of TCP packets in responses.
We plan on making these separately configurable at some point down the road. The timer used to default to 1200 before 1.2, but has been lowered to 300 which is still far more than necessary in most situations. It is not set any lower by default because there may still be odd places in the code where the timer is not reset when a packet is sent.

Author

Commented:
If I change the server timeout settings do I have to recompile apache or somthing? I changed it to a much alger number than 300 and I still get a timeout after 300 seconds.

Thanks

Commented:
After any changes are made to the httpd.conf you have to restart apache so that the changes take effect.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.