We help IT Professionals succeed at work.

Delete a file that refuses to budge

dc197
dc197 asked
on
170 Views
Last Modified: 2010-04-14
Hi
I downloaded a ISO, burned it, now it will not budge.
I can rename the file, that is the strange thing.
Cannot delete it via DOS or Explorer (Access Is Denied).
Nor through code (Bad File Name or Number).

Any ideas?
I tried safe mode, stopping all services.

High points cos I am so pissed off.

Ta
Daniel
Comment
Watch Question

Commented:
Hello,
right click the file >> properties >> security tab >>advanced tab >> verify that you are the owner
if you are not then you can change that here.

have you tried moving it to a different folder then from dos navigate to the folder and issue the
command del *

Author

Commented:
Eeryone was listed, full control.
Added myself explicitly, full control, no avail.

Can move file, can't del from new position!

Author

Commented:
Made me the owner, no good.
Sorry about the link.  The following article goes through just about every possible reason why you would not be able to delete a file or folder on an NTFS volume.  Just something to step through and see what applies, in case you haven't seen the article before.

http://support.microsoft.com/?kbid=320081

Fatal_ExceptionSystems Engineer
Top Expert 2005

Commented:
What about the file attributes..??

Author

Commented:
Attribes - normal.

MS link - tried them.
I don't think another proc has the file open or I could not move or rename it.
Look like some kinda feck-up within the file or the file system

Commented:
Hello,
Can you create a new file with the same name (convert textfile.txt to whatever.iso) then
move it to the same folder and accept yes when it asks to replace the existing file. then try to delete it?

I know....I'm grasping :)

Have you set explorer to show all files including system files?
Maybe there is another tag along file. (Even less likely than my first suggestion)

where did you get this iso? I want to try it!

Commented:
Do you have a firewall...has anything new tried to get out since you downloaded this file?
Any chance the website was malicious?

If so you can check for spyware by downloading AdAware here:
http://www.lavasoftusa.com/

or you can download a tool called hijackthis that will show you more info than programs like adaware will
http://www.spychecker.com/program/hijackthis.html

since you said you booted into safe mode and could not delete this file the chances of this being the cause decreases
but its still worth a try
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
how about RMDIR from a command windows

RMDIR c:\marvin\badfile.fil
Fatal_ExceptionSystems Engineer
Top Expert 2005
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Fatal_ExceptionSystems Engineer
Top Expert 2005

Commented:
This is a tough one..

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.