We help IT Professionals succeed at work.

iml32.dll macromedia projector error

muso120999
muso120999 asked
on
57,113 Views
Last Modified: 2013-12-24
Hi

I am having trouble on a laptop running XP with a “Macromedia Projector” error which is having troubles with a iml32.dll.

The problem occurs when going from one movie to another e.g.

Go to frame “MyFrame” of movie “MyMovie”

The problem does not occur on a full install but on minimum install when the exe is installed on the hard drive and Program is running from disc.

 the OnLine Crash Analysis report returns:


Online Crash Analysis

Analysis Information

Thank you for submitting an error report. The error was likely caused by:

Flash Player

Flash Player was created by Macromedia, Inc.. Please contact Macromedia, Inc. in order to find out if a solution or an updated version of Flash Player is available. For more information, see the Macromedia, Inc. Web site.

http://www.macromedia.com/support/ 


However, as usual this was of no help. I have uninstalled and installed both the shockwave and flash players and still no joy. Also the program is already playing flash before it crashes. Any ideas?
Comment
Watch Question

Is this a Director or flash program?  Is this on a CDR?  Try burning at slower sppeds as a fast burn my not be reading correctly or fast enough.  

Author

Commented:
Director program on CD with flash intergrated. Have tried burning at 1x speed but still have problems.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks for your help

The problem appears to have been solved by putting the dll into the Xtras folder.

I'll award the points to you anyway, as they are sensible suggestions anyway.
Soundsl liek you made a Shockwave projector.  If you put the items in the Xtras folder then its a "fast start" stub.  There are 4 DLL files that will need to go int eh Xtras folder.  If you make a "Standard" exe then these are packaged into the projector.

Author

Commented:
Further to your comment:

It is a standard projector - the four DLL's you mentioned appear to be created on the fly when the app is run into a temp directory, and deleted upon exit (unless it crashes).

Sometimes copying the DLL's into the application folder appears to solve the problem.

I may re-open the question anew, as the problem still occurs on some machines and not on others, and a recognisable pattern has not yet been established.

Thanks again for your assistance though :-)
Correct.  They are packaged into the program but will "unpack" at runtime to a temp folder.

Most likely this is a CD Rom read issue.  I hae seen this many times when the drive has problems reading the CD.

Author

Commented:
Hi,

I have created a new question (easy points!?)

https://www.experts-exchange.com/Web/WebDevSoftware/Director/Q_20882597.html


If you could reply there with more details, that would be great.

Also, the problem seems to be specific to Windows XP.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.