We help IT Professionals succeed at work.

Disabling shutdown in Terminal Services

jasonsas
jasonsas asked
on
568 Views
Last Modified: 2010-04-18
HI,
We are currently running a Windows 2003 server with Terminal services installed. This is a stand alone machine and as such is not a domain controller and does not have active directory installed. Is there a way to disable the shutdown option when a user logs in to terminal services?
Thanks
Comment
Watch Question

first one question:
do you need to avoid user shutting down your member terminal server
or
do you need to avoid that users shutdown their terminal server client workstation
is your terminal server member server part of an active directory domain
Adam LeinssSystems Administrator
CERTIFIED EXPERT

Commented:
Go into the admin tools>local security policy and remove the shutdown right for users.

Author

Commented:
It's not part of an active directory domain, it just acts as a server in a workgroup, as we run a netware network.

I have gone into local security policy>User Rights Assignment>Shutdown the system and only "Administrators" are listed there. the problem is that when I log into terminal services as a user who is NOT in Administrators, they still have the shutdown system.

Thanks

Author

Commented:
The reason we run terminal services on our server is that certain users need to login to this server to run a program that they can only run on the server. I need to be able to stop them from shutting down the server when they log into the server via Terminal Services.
Add Logoff to the Start Menu
User Configuration\AdministrativeTemplates\Start Menu & Taskbar

This could be further strengthened by removing Shutdown from the start menu and CTRL-ALT-DEL box

Disable and remove the Shut Down command
User Configuration\AdministrativeTemplates\Start Menu & Taskbar

Description
Prevents users from shutting down or restarting Windows.

This policy removes the Shut Down option from the Start menu and disables the Shut Down button on the Windows Security dialog box that appears when you press CTRL+ALT+DEL.

This policy prevents users from using the Windows user interface to shut down the system, although it does not prevent them from running programs that shut down Windows.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Commented:
Use GPEDIT.MSC
 
expand user configuration
expand administrative templates
choose start menu/taskbar

in the right hand pane choose "disable and remove shutdown" and enable it

Commented:
Well thats just plainly the wrong answer

tks a lot and good luck

Commented:
karel_jespers just an FYI, what you suggested stops REMOTE (users on a seperate system) from Remotely shutting down the terminal server, the question was about locally logged on users on a terminal server shutting it down. My solution fix's that problem, yours doesn't.
when a user logs in to terminal services?

do you think that means local logon?

Commented:
Yes they are logging on to a local session on the terminal server.

Commented:
try yours, try mine, i support 30+ terminal servers, i have had this same problem
perhaps jaconsas can explain you why your fix (that of course helped you a lot) isn't the fix he was waiting for

over and out
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.