.DCR File Not Displaying, Code Is Okay, Problem On Server

I have a problem with a .DCR file that was once playing, and is now not playing.  I changed nothing in the code.  What happens is that the Macromedia Shockwave loading logo displays, no progress on the progress bar, then a couple seconds later it goes away.  

This has to be a problem on the server.  I've made sure that .dcr is bound to application/x-director in the MIME type settings.  I don't know what else to do.  Please help me.  I'm a web programmer, not a sysadmin.  Thanks in advance.

Jeremy
w33zelAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MediaMacrosCommented:
Check the version of the player you have installed against the version of the player the page is asking for.  (Is it made in MX 2004 and you have the 8.5.1 player?)  Also if there are external resources like cast libraries it may be having problems and note case sensitivity.  For many web servers this...

file.dcr
is different than this...
File.DCR
0
w33zelAuthor Commented:
The code is fine.  The code hasn't changed between when it was working and now, when it isn't.  We received these .dcr files from a third party, I don't even have access to their source.  We are just presenting them to users.  
0
w33zelAuthor Commented:
How would I check which version of the Shockwave player I'm running?
0
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

MediaMacrosCommented:
It will be installed in your Windows\system32\macromed folder.  Most likely you are running 8.5.1 unless you have gone to MM's site and downloaded the SW 10 beta.
0
w33zelAuthor Commented:
Yeah, it's 8.5.1.  A number of other people report the same thing happening when they attempt to view the file.  This file worked a week ago, I changed nothing in the movie or the code, and now it does what is described above.  Would this be caused if the LAN Shop was blocking the .dcr extension for some reason?
0
MediaMacrosCommented:
If the port or mime type is blockd it coudl cause a problem.  Also look and see if the case sensitive issue describes your problem.  One caps where it sohudl nto be will cause problems.
0
w33zelAuthor Commented:
The code hasn't changed.  I've poured over it in the course of trying to figure out was wrong.  It is EXACTLY how it should be.  Case sensitive and all.  The code isn't the problem.  
0
MediaMacrosCommented:
But if the filename changed at all then it will cause this.   :)

Also, try it locally.  Does it work better if refreshed in the browser?  How large is the file?  Have you tried it without a preloader movie?
0
w33zelAuthor Commented:
It doesn't work at all when displayed in the browser.  It shows the standard Macromedia Loading logo, then goes blank.  I can't try it without a preloader movie because I don't have access to the source files.  These are third party movie files that we are merely PRESENTING to our users.  

What is bugging me is that without touching the files, or the code that presents them, .DCR files are not working anymore on the web server.  That is why I suspect it is an issue of a setting on the web server and not an issue in the code or actual movie file.  Do you understand?  It's not just THIS dcr file, it's all dcr files.  

I appreciate your helping on this, but I really really really don't think that it's an issue with the code or the content of the movie as neither of those things has been touched since it was working.
0
w33zelAuthor Commented:
I have this same question up in the "Web Servers" area for 500pts as well.  If you can solve this, I'll give you both sets of points totalling 1000pts.
0
MediaMacrosCommented:
Can you send me a link to the file?

As for a preloader you can load them directly.  Just set the embed tag in the page to point to the DCR and not the preloader movie.
0
w33zelAuthor Commented:
Sorry, I can't send you a link, it's on a .mil domain.
0
MediaMacrosCommented:
Can you post the embed tag from then HTML file then? And also copy and paste the filename?  Just so I can see if there are any common pitfalls in the HTML portion of the page.
0
w33zelAuthor Commented:
Yeah, no problem, give me a sec.
0
w33zelAuthor Commented:
<EMBED SRC="esc_apps_intro_001.dcr" bgColor=#303D5D  WIDTH=790 HEIGHT=543 swRemote="swSaveEnabled='false' swVolume='false' swRestart='false' swPausePlay='false' swFastForward='false' swContextMenu='false' " swStretchStyle=none
 TYPE="application/x-director" PLUGINSPAGE="http://www.macromedia.com/shockwave/download/"></EMBED>


Name of file:

esc_apps_intro_001.dcr

0
MediaMacrosCommented:
If that is all you have you are also mising hte object params.  Note that netscape uses one set of tags and IE uses the other.  You need both your object param tags and the embed tags.  Does it load correctly if you go to the file itself?

IE...

www.domain.com/esc_apps_intro_001.dcr

Also, if possible set the Director file to not play while downloading.  You can also write a custom preloader to preload the entire file before playing it.  This way you can be sure the entire movie is cached before it starts.  Does the movie use any external casts or media?
0
w33zelAuthor Commented:
Here's the whole page of the HTML file, and no, the file does not play if I just type in it's address alone:

<HTML>
<HEAD>
<TITLE>esc_apps_intro_001</TITLE>
</HEAD>
<BODY bgColor="#303D5D">
<center>
<TABLE border=0 width=100% height=100%>
<TR><TD valign=middle align=center>
<OBJECT classid="clsid:166B1BCA-3F9C-11CF-8075-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/director/sw.cab#version=8,5,1,0"
 ID=esc_apps_intro_001 WIDTH=790 HEIGHT=543 VIEWASTEXT>
<param name=src value="esc_apps_intro_001.dcr">
<PARAM NAME=swStretchStyle VALUE=none>
<param name=swRemote value="swSaveEnabled='false' swVolume='false' swRestart='false' swPausePlay='false' swFastForward='false' swContextMenu='false' ">
<PARAM NAME=bgColor VALUE=#303D5D>
<EMBED SRC="esc_apps_intro_001.dcr" bgColor=#303D5D  WIDTH=790 HEIGHT=543 swRemote="swSaveEnabled='false' swVolume='false' swRestart='false' swPausePlay='false' swFastForward='false' swContextMenu='false' " swStretchStyle=none
 TYPE="application/x-director" PLUGINSPAGE="http://www.macromedia.com/shockwave/download/"></EMBED>
</OBJECT>

</TD>
</TR>
</TABLE>
</CENTER>
</BODY>
</HTML>
0
MediaMacrosCommented:
Does the file play locally from teh hard drvie if dropped in a browser?  It sounds like you may have a corrupt file.  Maybe uploaded as ASCII instad of binary.  
0
w33zelAuthor Commented:
Let me reiterate that I'm 95% sure that it doesn't have anything to do with the movie file, or the code.  I touched nothing in relation to this file or any other DCR file since they worked a week ago.  Since then, they don't work.  I am almost positive that it concerns a setting on the web box or on the network.  If it was an issue with some simple HTML code, or with something as simple as a corrupt DCR file, I would not be offering 1000 pts for its solution.
0
MediaMacrosCommented:
I am aware of that but I am offering you the most common causes of this.  Things that will cause it to fail are...

Incorrect file path
Corrupt file
File playing while downloading and all needed resources are not loaded
Incomplete file
Uploaded in the wrong format (ascii instead of binary)

You never did tell me if downloading the file locally and dragging it to the browser worked. Thats a great way to test if the problem is in the DCR or if its how it streams in.  Are there any other security measures on that server that woudl block ports, limit file size downloads, etc?

I am trying to help, and sometimes things we are sure are not causing the problems turn out to be the culprit.  Since I can't see the file directly all I can do is try to help you narrow the problem.
0
w33zelAuthor Commented:
Thanks, I don't mean to be short, I'm just frustrated.  
0
w33zelAuthor Commented:
What ports need to be open on the server to allow the playing of DCR files?  That could be it.
0
MediaMacrosCommented:
If the file is stand alone port 80 sohudl be all you need.  If you are ising MUS then you need to open the port your MUS server is set to use.  Did you try the download and drag into browser test?
0
w33zelAuthor Commented:
When I try to download it, I get an error that says:

Internet Explorer cannot download esc_apps_intro_001.dcr from www.domain.mil

Internet Explorer was not able to open this Intenet site.  The requested site is either unavailable or cannot be found.  Please try again later.

Which is weird because I can get to the rest of the site just fine.
0
w33zelAuthor Commented:
Getting closer.  I came upon this:

http://support.microsoft.com/default.aspx?scid=kb;en-us;316431

after researching the error.  None of those headers were configured on the website, but when I unchecked the box marked "Enable Content Expiration", the file started working like it was.  Now, I don't think I should need to uncheck that box, so I've contacted the firewall admin to see if they're inserting the headers.  I'll let you know, and if this turns out to be the solution, you'll get the points because I really appreciate your help with this.
0
MediaMacrosCommented:
It coudl have to do with how its downloading as well.  If it has to restart then it will start from the beginning.  Disabling content expiration allows the file to fully cache, so you are not restarting the download each time.  Also see if they are limiting file size, bandwidth, or number of connections per user at a time too.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.