ntoskrnl.exe

I have a friend of mine calling who keeps calling me asking him what to do about this error message:

Windows NT won't start because <winnt root>\System32\Ntoskrnl.exe is missing or corrupt

He tells me that it occurred after installing the latest update for adobe acrobat. It's Windows 2000 on an NTFS partition, but he only has the Win2K upgrade CD in his possession. I've given him directions for making a bootdisks with another Win2000 laptop he has.

I'm wondering what I should do next?

Should I copy over a known good file from a different machine (will that work) or what?

could it be a bad boot.ini file?


-thanks

Any guidance would be appreciated...
sladehawkeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bruintjeCommented:
0
4auHukCommented:
>could it be a bad boot.ini file?

If message reads exactly as you described("<winnt root>" part), then yes, it could be corrupted/changed boot.ini file. Anyway you should take a look into it.

hth,
4auHuk
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zoomdogCommented:
Presumably it is an ntfs volume
as distinct from a fat32

either way you can apply the same principle
user this site for your pointers
http://www.muratyildirimoglu.com/articles/EmergencyRepairProcessandNTOSKRNL.htm
if you need to access an ntfs drive from dos user ntfsdos http://www.sysinternals.com/ntw2k/freeware/ntfsdos.shtml

hope that is of help
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

sladehawkeAuthor Commented:
OK,

I need simple instructions... I've never used the Win2000 bootdisks myself, so I don't know what to tell him to do next.

thanks
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Ok I would Boot from windowss boot disks and try recovery console.
Type chdsk /f to issue a disk repair 1st.
Then you can try fixing the boot.ini
http://support.microsoft.com/default.aspx?kbid=124550
0
Kamel407Commented:
try this

copy another Windows 2000 Ntoskrnl.exe onto a floppy disk

go to http://www.ultimatebootcd.com and copy down the .exe file

burn that onto a CD and it will become a NTFS boot CD

Copy the Ntoskrnl.exe from the floppy onto the <winnt root>\System32\ directory

Reboot
0
sladehawkeAuthor Commented:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;119467

This is how I fixed it... far simple than using the recovery console, which merely gave him error messages regarding that an incompatible OS was installed. It wouldn't even let him view the contents of the drive. fixboot, fixmbr, and chkdsk did nothing.

Anyway, the above link puts
ntldr, ntdectect.com, and boot.ini on a floppy, with the boot.ini pointing at the OS on the hard drive.

When booting from this floppy, the Windows 2000 started seamlessly, so I copied the boot.ini file from the boot floppy to the hard drive, and now everything works perfectly.


Problem: Missing boot.ini
Resolution: followed the steps at http://support.microsoft.com/default.aspx?scid=kb;EN-US;119467


points to 4auHuk because he made me focus on the boot.ini file instead of the ntoskrnl one... (I was on the right track already)
0
4auHukCommented:
sladehawke,
Thanks, though i would say that you fixed your problem almost by yourself :)

I believe you should split points or give points to 1stITMAN since link he provided (http://support.microsoft.com/default.aspx?kbid=124550) suggests same article for boot from floppy as you mentioned.

4auHuk
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Thanks 4auHuk dont worry about it!!
0
HighTechGeekCommented:
I had the same error message, but a different fix. I just wanted to add my fix in case it can help someone else...

Symptoms:
1. Win 2K SP4 getting ntoskrnl.exe file missing or corrupt at boot up.
2. When going into the Recovery Console, it does NOT ask for me to log into an instance of windows (ie. C:\WINNT), but it DOES give me a C: prompt.
3. When doing a DIR command at the C: prompt, there is no WINNT directory.
4. Attempting to repair with or without an Emergency Repair Disk (ERD) tells me that it cannot find a copy of Windows on the PC (in this case a Dell Precision M40 laptop)

Fix:
1. From the C: prompt of the RC, I did a CHKDSK.
2. It "found" 3 "missing" directories and stuck them inside a FOUND.000 directory. They were DIR0000.chk, DIR0001.chk and DIR0002.chk.
3. Upon inspecting their contents, it turned out they were the WINNT, SYSTEM32 and CONFIG directories.
4. I put the laptop harddrive into a working PC as a secondary drive (you need to use a $5 pinout converter), renamed and moved the directories to their proper locations (CONFIG goes inside SYSTEM32 which goes inside WINNT which is at the root - in my case, at least), performed a SCANDISK (it found 48k of bad sectors), shutdown the PC, put the laptop drive back in the laptop and everything came up fine.
5. I then backed up all my necessary files and promptly bought a new laptop!
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
EXCELLENT TIP...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.