Error 0x800ccc15

Alain_Labelle_Ing
Alain_Labelle_Ing used Ask the Experts™
on
I have a Win2k with all Windows Update done, Office with all update done, Symantec Anti-virus active and all update done.  For unknown reasons, I am getting once in a while a TCP/IP error: "TCP/IP error occured while trying to connect to the server. Account, ... Server,... Protocol: POP3, Port: 110, Secure (SSL): No, Error Number: 0x800ccc15".  I looked over Google and found some stuff as to check if a certain virus was there (which is not the case) and to run Ad-Aware 6 (with last update) for "I don't remember the reason".    The most possible one I got was to reload my TCP/IP stack by ripping and reinstalling TCP/IP.  I uninstall TCP/IP protocol from network control panel, reboot and reinstall TCP/IP protocol.  The problem stays.
When I get the error, if I closed Outlook I can see my OUTLOOK.EXE still active in the Task Manager.  By "End Process" the OUTLOOK.EXE, I can restart Outlook and it start working properly.  I also tried to unstalled Outlook and reinstalling it, reinstall Outlook Update (Office update) and my problem's still there.  Any ideas???
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2006

Commented:
if you have a dialup networking entry remove that too and recreate
you could also try to remove the settings in outlook for the pop and smtp server, close outlook. open outlook and then recreate the entries

it could also be due to the AV program interfering with the outlook connection once in a while

Commented:
You -may- want to try diabling email scanning for a short period and see if the problem reoccurs.    

Depending on how bothersome this is for you, you could completely uninstall the Symantec product that you have, download the evaluation version of PC-Cillin http://www.trendmicro.com/en/products/desktop/pc-cillin/evaluate/overview.htm and see if the problem reoccurs.



Commented:
>>> you could completely uninstall the Symantec product that you have

Becuase I believe that it is the AV software that you have now that is causeing the problem.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Well, this PC is part of a Domain and the Anti-Virus is server based.  There is also other PC on that Domain using Outlook and using the AV software and those PC does not have my 0x800ccc15 error.  Another point is Outlook Express is also installed on that faulty PC and Express does not get the error 0x800ccc15...
try running fixmapi from the Run prompt.
Commented:
This behavior occurs when you connect to your Internet mail server using a SOCKS proxy server, even though you can successfully connect to the Internet using a SOCKS proxy server

 The error you get (0x800ccc15) means SOCKET_CONNECT_ERROR -    Unable to open Windows Socket, and might appear when you connect to your Internet mail server using a SOCKS proxy server, even though you can successfully connect to the Internet using a SOCKS proxy server.

This is a known problem to Microsoft and is fixed in Outlook 2003 (which I suppose you don't have it installed)

One thing you can do is to uninstall Outlook (I know you've done it before), change all the files which contan "mapixxx.xxx" to "mapixxx_old.xxx" and reinstall Outlook and see what happens.

Hope it helps,
Adrian

Author

Commented:
I tried the FixMAPI.exe (from WinNT\system32) and the problem is still there.  Will try tomorrow to unstall Outlook 2000 with changing MAPIxxx.xxx to MAPIxxxold.xxx and then reinstalling Outlook 2000.  I will make a backup copy of the PST so I will not lose my historic.  Will let you know how it goes...

Commented:
Thanx for awarding me the points.

regards,
Adrian
I have the same problem with my Outlook Express v6. I tried reinstalling tcp/ip but nothing happens. Just started this morning. I can ping the server but when I try to receive my messages, the error 0x800CCC15 appears.
Hi Alain_Labelle_Ing! Did you solve this problem? I just did a few mins ago! I remove the TCP/IP from the network settings. However, before I restart my PC, I deleted these entries on the registry:

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock]

and

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2]

Pls. backup your registry before doing this.

Then I restart my PC and add TCP/IP protocol. After restarting again, all came back to normal!

Hope this helps.

Author

Commented:
Yes it did solve my problem.  A real thanks to adicos...

Commented:
I am getting this error too, and neither of the above suggestions fixed it.  Tomorrow I'm giving up and using the good ole' Format fix.  Trying to resolve this issue has become a huge time sink for me.  The problem started with some MS Office or MS OS patch perhaps, but I've been unable to narrow it down to which for now.  Either way, I had this problem on one machine, and I kept thinking it was a networking issue.  The computer would ping the email server just fine though, and all of the settings were correct.  A reboot would always fix it.  I then got the problem on a second computer.  PestPatrol was installed on the second to see if it was malware or a trojan.  It did find some junk, including a couple .exe illicit programs, but the problem remained with Outlook remained once everything bad was removed.  Then it got worse after trying the two fixes above.  The renaming of files to old versions and reinstalling Outlook caused a problem.  When reinstalling Outlook I got a MAPI install error, and it would not continue.  Then the TCP/IP trick royally messed up my networking files.  I had to reinstall the NIC and do a Windows repair reinstall of the OS to get the TCP/IP functioning again.  Now the computer will boot but it opens up pre-login screen to a large blank pop-up window with only a single "I" in it and a box icon for the name of the window.  You can click "Ok" and just go past it though.  Outlook will not even run without stalling and crashing now too.  I'm going to install from scratch now sadly, but I just wish I knew the source of the problem.  Hopefully none of my other supported machines will get the error.  All I can tell is that I had IHateSpam on the second machine.  The second machine also had PestPatrol installed after the problems started.  The first has neither.  Now I have a third computer doing this too.  It too has PestPatrol and _had_ IHateSpam.  IHateSpam was causing serious problems for me, and the uninstall caused havoc.  It required some registry tweaking just to get Outlook to work again.  Since the first machine with the above problem never had IHateSpam though, I doubt it is the original cause of my problem.  Some MS patches for the OS and Office were done on all three machines outside of UpdateExpert however, so that is why I'm leaning towards a patch.

Oh well...

I'll report back if the unthinkable happens and the problem remains after a fresh install.  LOL  If it does, then I will blame a corrupt Outlook .pst file.

8-(

Agathon

Commented:
I replaced all of the machine's hardware entirely and reinstalled from scratch.  The only thing I took with me from the old computer was the .pst file.  The computer worked fine for 5 days, and then the error magically reappeared.  I don't see how it is a .pst problem if it worked for 5 days without a problem.  I'm using Symantec's corporate anti-virus, and I'm wondering if that is somehow breaking it after a set amount of time.  The problem is still there though.  The computer fixes the issue when it is rebooted however.  Then the computer will work for the entire day.  The next morning it is broken again.  The maintenance running at night includes a Diskeeper defrag and the corporate server virus scan.  I suspect Symantec is messing with the Outlook's ability to connect somehow, but how exactly is unknown for now.  If I resolve the issue once and for all, I'll report back here.  Based on what I have discovered so far, does anyone have any suggestions?

Thanks,

Agathon

Author

Commented:
I am using also Corporate Symantec Anti-virus on our Domain Network.  Personnaly, I am using Outlook Express and do not experiment any problem with that ... error.  Most of our people are using Outlook and all of them are also using Corporate Symantec Anti-Virus.  Personnaly, just try to disable your Diskeeper defrag for a while and see if that make any difference.

Good luck.
Alain.
So I have a friend who is seeing this too and is at wits end so he turned to me to help.  This discussion has been centered around OE and O :) but have you had problems with other ports?  I am asking because my friend's problem seems to be ONLY with posts 25 and 110 and not specific to OE or O.  I have used tlenet to attempt to connect with no success, however port 80, for example, works fine, so he can browse but not send nor receive email, and it applies to anything attempting to access ports 25 and 110.

Before you ask, YES, I checked for firewall blocking first.  As is so often the case, everything was working fine, and then it occured even though he didn't do anything...  Well, we all know he or his kids did do something, but nonetheless it does not seem to be a general TCP/IP stack problem, but a centralized port problem that is not related to firewall or AV programs.

So, the question is if this was the same behavior you all saw, just the mail ports and not the other generally used ports.

Thank you
BRD
Oh yeah...  He's using XP personal
I am experiencing this issue. The problem is that I can telnet to the port 25 on the Exchange server from within the same subnet but I can't telnet to this port from outside on a different subnet. I am using Windows XP on all our machines. We noticed this problem when an application that we have that uses SMTP to email from within stopped working and issued the 0x800ccc15 error. Can anyone advise what this issue is and if it really is an OS patch that has disabled the tcp/ip stack.
Was this problem ever solved ?

Author

Commented:
It does fix my problem, if that can help...

Commented:
hey guys, i  been having the same proble and from all comment it is a stack problem and tcp ip problem..... so i try  winsockfix   and it is FIX

winsockfix  did fix it

thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial