We help IT Professionals succeed at work.

Access windows 2003 share from Solaris with samba

pepitoH
pepitoH asked
on
3,087 Views
Last Modified: 2013-12-21
Hi solaris gurus.
I'm having trouble trying to access a windows 2003 share from my Solaris Box. I can access another windows XP, but I don't know why I can't access the win 2003 machine.
Here's an example of what I'm doing:
danno is the XP box and trucu is the win 2003.

I am getting NT_STATUS_ACCESS_DENIED with the windows 2003.

Lower you will find me smb.conf I've tried with security user, share and (domain with encrypted passwords)


# smbclient //danno/d -U administrator
added interface ip=10.0.0.71 bcast=10.0.0.255 nmask=255.255.255.0
Password:
Domain=[TRULALA] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
smb: \> exit
# smbclient //trucu/htdocs -U administrator
added interface ip=10.0.0.71 bcast=10.0.0.255 nmask=255.255.255.0
Password:
Domain=[TRULALA] OS=[Windows Server 2003 3790] Server=[Windows Server 2003 5.2]
tree connect failed: NT_STATUS_ACCESS_DENIED
#

# cat smb.conf
# Samba config file created using SWAT
# from danno.trulala.w3.com.ar (10.0.0.25)
# Date: 2004/03/19 10:19:21
# Global parameters
[global]
        workgroup = TRULALA
        netbios name = W3SUN
        security = SHARE
[homes]
        valid users = %S
        read only = No
[share]
        path = /tmp
        read only = No
        guest ok = Yes

If some helps me out with this I'll give him/her extra points.
I have searched google, read a lot of samba how2s but I can't manage to do this.
Comment
Watch Question

Author

Commented:
I enable the guest account and I can access the win 2003 share.
But how can I access it without enabling the guest account.

Author

Commented:
I've also tried modifying the registry with:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters\enableplaintextpassword value= 0x00000001

And still nothing.

I'm getting very irritated with this.
For now I'm using the guest account to access the shares but I have confidential information that I need to access with a windows account.

Thanks.
it's a pain that M$ changes the challenge/response with every version.
Best you have a look at the docs supplied by Samba itself, they explain much better how a [BP]DC works than M4 itself ;-)

Probably your Solaris needs to be a member of the domain
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Gns

Commented:
The latest Samba (3.xxxx:-) should support this. Have seen at least smbclient access success.

-- Glenn

Author

Commented:
Alf666 you are the man!

Thanks a lot.
This stuff gave me a lot of headaches.

You can collect some extra points here:
https://www.experts-exchange.com/Operating_Systems/Solaris/Q_20937850.html

Author

Commented:
Hey.. Alf666
after I edited in regedit that key, I can't manage to logon my PDC with remote desktop.

Do you know what could do this?
Do I have to edit any other registry key?
Does enablesecuritysignature have to be the same as requiresecuritysignature.?

Thanks.

Commented:
Which one is your PDC ?

Is the one you changed the registry key on the remote desktop client or the server ?

Author

Commented:
I fixed restarting the machine.

I think that the commands:
  net stop srv
  net start srv
.. didn't work quite well.

I also read here: https://www.experts-exchange.com/Networking/Linux_Networking/Q_20753133.html
that windows 2003 after 4-8 hours changes the registry value again to 1. And you can solve that issue with this link. May be helpful for somene else.

Author

Commented:
Sorry Alf666...
but I think this registry change affected my IIS directory security.

I'll explain: I have some virtual directories in IIS that have Authentication Methods / Integrated Windows authenticaction. And I can't access these directories with the registry hack.

Do you know if there's a solution for this problem.
Thanks again.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.