Solved

Problem forwarding  email received from pop3 account to exchange recipients

Posted on 2004-03-20
35
976 Views
Last Modified: 2010-03-05
I just set up Exchange 2003 in a Windows 2000 domain. All the recipients have a smtp address of "username@mycompany.com" in Active Directory. "mycompany.com" is a not a publicly registered domain name and it is only used internally. Most Exchange recipients also have POP3 accounts from a internet email host provider. In the Outlook clients I have added both an Exchange account and a POP3 account. It works fine as far as sending emails is concerned, Outlook knows when to use the appropriate account/service depending on whether the email is for an exchange  recipient in the global list or to an internet email address. However when I try to forward email that was received from a POP 3 account to an Exchange recipient in the global list Outlook uses the POP3  smtp host address to send it out on the internet and of course it comes back undeliverable. How can I correct this problem. Thanks
0
Comment
Question by:pauljshaw
  • 18
  • 17
35 Comments
 
LVL 8

Expert Comment

by:Emptyone
ID: 10644792
Does the users have the same domain on their external mail, or does one have 123.com and one 456.com? If they all have the same, I would recommend setting up the exchangeserver to handle that domain. Then the users use POP3 to get the mail down, and exchange would handle mail internal and out of your organization
0
 

Author Comment

by:pauljshaw
ID: 10648549
No, as i said the exchange recipient address  123.com is for internal use only, their  internet mail address would use the 456.com and is hosted outside the company
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10648814
That I now. What I meant was that all users had the same domain external. And I got the answer I wanted. What you do then is that you set up the recipient policy with their external mail too. Just add it. Set that as default SMTP address. Use the Outlook to pop down the mail. When the users try to send mail, they will default now send it with their external mail address. This way you use exchange for internal and outgoing mail, and pop3 for downloading external.
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10648899
Have a look on this one, he had the same problem and I helped him with it:

http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_20919395.html
0
 

Author Comment

by:pauljshaw
ID: 10649632
I have the following in the email addresses property page for the users

Primary SMTP: username@publicdomain.com
smtp:username@domain.local

However when I try to forward an email received by username@publicdomain.com to a local recipient it still goes out on the internet via the POP3 account and the smtp host of publicdomain.com sends back an NDR saying

<<< 550 <username@domain.local>: Relay access denied 550 5.1.1 <username@domain.local>... User unknown <<< 503 Error: need RCPT command
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10649855
You have to make a change in Outlook. When in the properties page you can change which transport to use. Set the POP3 on the bottom. If you don't find it, tell me what version of Outlook you use and I'll guide you
0
 

Author Comment

by:pauljshaw
ID: 10649951
I changed the outlook accounts to have exchange as default and POP3 at the bottom. Outlook version is 2003. It is still using the POP3 account to forward to local domain recipients
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10649976
Just to check, have you set exchange as default?
0
 

Author Comment

by:pauljshaw
ID: 10650080
yes I have
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10650147
What happens when you try to send a new mail from Outlook? Which mail address does it use then? Just to check if everything is synchronized
0
 

Author Comment

by:pauljshaw
ID: 10651055
New emails to outside addresses seems to use Exchange and the reply to smtp address is username@publicdomain.com

New emails to local recipient uses exchange and the smtp address: username@domain.local

Forwarding outside emails to local recipients use pop3 account and smtp address username@domain.local and comes back undeliverable
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10651175
Could you try to make a new profile on one computer. This to check if there is something in the profile
0
 

Author Comment

by:pauljshaw
ID: 10652412
I set up a new profile. I just can't stop Outlook from choosing the pop3 account to forward email that was received on the publicdomain.com address
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10652852
What happens if you only set up Exchange in the profile and send an e-mail to internet?
0
 

Author Comment

by:pauljshaw
ID: 10653184
then it works fine because there's no pop3 account to be used instead of exchange, but then i can't receive any outside email. It must be an outlook 2003 issue, because users with outlook xp and 2000 and identical configuration don't have this problem
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10655441
Had another guy I just helped. He had the same problem, but he had not installed the latest patches. So if you miss som servicepack or patches, install them and see what happens then.
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10657463
Are you running Outlook 2003 in cached mode? If you are, try to disable that and see what happens then
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:pauljshaw
ID: 10657589
This morning without any changes from yesterdays configuration it is forwarding to local recipients, but  the reply to smtp address is not the username@domain.local but username@publicdomain.com. I deselected the cached mode setting but it didn't make any difference.
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10657607
The reply address should be the publicdomain.com. Since your server also answers for these addresses, it will be sent internally on the exchangeserver.
0
 

Author Comment

by:pauljshaw
ID: 10657684
you mean the reply address should be username@localdomain.com. if i'm forwarding to local recipients and they have to reply to me using my internet mail address then it is not sent internally
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10657745
If you in the default recipient policy have a SMTP address set to publicdomain.com as primary, then the exchangeserver will handle the mail for that domain too
0
 

Author Comment

by:pauljshaw
ID: 10658136
I know, but shouldn't exchange choose the appropriate reply smtp address according to whether the message is sent internally or as internet email? why use my internet mail smtp address at all for a message that is meant for a local recipient?
0
 

Author Comment

by:pauljshaw
ID: 10658150
That's what is doing with other non-Outlook 2003 configurations. I'm definetely going to look for a patch for outlook 2003
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10658589
It uses the mail address set at primary for the user. And if the exchange server is responsible for that domain, then it will use that for sending internal mail too.
0
 

Author Comment

by:pauljshaw
ID: 10658923
But the exchange server is not responsible for the "publicdomain.com" domain, that's hosted outside and email sent to it is downloaded not by exchange but by the pop3 accounts in the various outlook clients . i thought exchange was acting as a transport only for outbound email and deciding what smtp reply address to use in the message according to whether the message was meant for an internet mail address or for a local recipient, that's how it is behaving in the other outlook 2000/xp client configurations, but not on my outlook 2003 client, in mine it is using my internet mail smtp address to forward internally, I just don't understand the logic of the local recipients having to use my internet email address and the internet connection to reply to an internal email.
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10659023
You can set up an exchange server to be "responisble" for publicdomain.com, even though it is hosted outside. You just set the server up this way, so that you will not have the problem with the outlook sending out mail through exchange with the localdomain.com mail address
That is the reason why I suggest you set up your exchange like this.

You will still download mail with the outlook client and pop3 as you used to.

Internal users can with this soloution just relate to one mail address and use that. The exchange will then deliver it local. And they can also use their local address if they want to. It will go as before.

Hope this explain more. It is not so easy to just write this down, would have been easier if I could show you at the same time as I explained. :)

Just ask if there is something that is still unclear, and I'll try to explain as best I can
0
 

Author Comment

by:pauljshaw
ID: 10659290
Ok. How do I go about setting up the server to be "responsible" for the publicdomain.com domain? Is it a configuration of the default virtual smtp server under protocols? BTW I wish I could give you more than the 500 pts, I must say you're really earning them!  :^) I do appreciate your patience
0
 
LVL 8

Accepted Solution

by:
Emptyone earned 500 total points
ID: 10661316
You set it up under recipients in System Manager for Exchange. There you will find a folder named Recipient policies, containing a Default policy
Look at the properties of that one. You have a tab named E-mail Addresses (Policy)
Add an SMTP address where you specify your publicdomain.com address like this:

@publicdomain.com

Set that address as primary

Then you just have to wait for a little time. Check on the users and they should have that mail address too.
0
 

Author Comment

by:pauljshaw
ID: 10661606
I had that in place already applying to my account too. I am certain it is an Outlook 2003 issue. I set up my profile identically on Outlook XP and it works correctly. I couldn't find any patches for 2003 yet. In any event the 500 points are yours. You really earned them. Thanks very much for your assitance
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10661744
Glad I could help. Would be glad if you posted some info if you find a soloution for Outlook 2003. Thanks for the points
0
 

Author Comment

by:pauljshaw
ID: 10670171
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10671942
Which method did you use? Just asking since method 2 is what we talked about in the beginning and you commented this:

Comment from pauljshaw
Date: 03/22/2004 05:03PM CET
 Author Comment  


I changed the outlook accounts to have exchange as default and POP3 at the bottom. Outlook version is 2003. It is still using the POP3 account to forward to local domain recipients
0
 

Author Comment

by:pauljshaw
ID: 10672362
method 1. I never even thought of that Accounts button to choose what account to use. Method 2 never worked for me.
0
 

Author Comment

by:pauljshaw
ID: 10672377
I think it is smarter how it is in Outlook 2000/xp to let Exchange figure out what account to use
0
 
LVL 8

Expert Comment

by:Emptyone
ID: 10674769
I agree with you there. But it would be even easier if you got the exchange to do all the job, and don't use POP3. :)
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
how to add IIS SMTP to handle application/Scanner relays into office 365.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now