Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 597
  • Last Modified:

Crossover Cable with NETBEUI and with TCP/IP

Is it possible for a crossover cable connecting 2 Windows98 SE computers to work correctly with NETBEUI and be faulty for connecting with TCP/IP? With NETBEUI as the protocol everything works OK and with no problem setting it up. With TCP/IP each machine sees itself as on the workgroup but does not see the other machine in Network Neighbourhood. Each machind can ping itself, but not the other machine. Neither machine has any Internet connection, ICS is not activated on ether machine.
0
specsol
Asked:
specsol
  • 10
  • 6
  • 3
  • +1
1 Solution
 
LucFCommented:
Hi specsol,

Could be that the TCP/IP stack or winsock is corrupt on one of the computers, use this tool to reset it.
http://www.bu.edu/pcsc/internetaccess/winsock2fix.html

Also, check if you have any firewalls running, you might have to reconfigure it so you build a trusted zone.

Greetings,

LucF
0
 
specsolAuthor Commented:
Thanks LucF. There are no firewalls running, (no internet connections), both machines had a clean install of Windows 98 SE and I have removed and re-installed the TCP/IP on both machines. They behave as if the cable is not there -- if I remove it, both computers still give same results. Suspected the cable faulty, but it works fine with NETBEUI and no TCP/IP. So wanted to know if TCP/IP uses a different set of the cable wires from NETBEUI?

Specsol
0
 
LucFCommented:
specsol,
Nope they both use exactly the same cable, that's why I suspect a mistake in the tcp/ip stack.
What adresses have you used?
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
specsolAuthor Commented:
I have tried just about every combination. Currently, one machine is on "Get IP Adress automatically -- setting 169.254.179.92, wwith the other a fixed address set at 192.168.0.2. Previously tried thev addresses set at 192.168.0.1 and 192.168.0.2 This last gave (for one occasion) the 192.168.0.2 machine listing both machines in Network Neighbourhood but unable to reach the other while the 192.168.0.1 machine only saw itself. Thanks for the info about the cable use in NETBEUI & TCP/IP -- I was gradually coming to that conclusion myself. Will try your tool & see what happens

Specsol
0
 
LucFCommented:
Ok, good luck.

btw, the settings you posted above: 192.168.0.1 and 192.168.0.2 is the right one. Both with a subnet mask of 255.255.255.0
0
 
specsolAuthor Commented:
The Win2Fix tool does not do the trick. In using the 192.168.0.1 & 192.168.0.2 I presume this implies setting both machines to have a fixed IP address. What should be the settings for DNS configuration? I had set DNS enabled with the Host as the machines own name but put 192.168.0.1 as the DNS search order. Also put 192.168.0.1 in the Gateway. Each machine had its own IP addess in the IP Address tab.

Specsol
0
 
LucFCommented:
As there are no internet connections, you don't have to fill in the DNS servers, so set it up not to use DNS.

I'm wondering why you can't ping the other computer... :(
0
 
specsolAuthor Commented:
So am I! That is what originally made me think the cable was to blame. Will set it to not use DNS on both machines

Specsol
0
 
LucFCommented:
Please doublecheck if you don't have any firewalls running. Zonealarm/Norton internet security/ whatever.
0
 
specsolAuthor Commented:
Definitely no firewalls, nothing installed. Also system is not stable. If I alter some parameters then go back to previous settings, the machines behave differently. Currently, with addresses 192.168.0.1 and 192.168.0.2 the 192.168/0/1 mamhine sees both machines in Netwoek Neighbourhood, cannot access 192.168.0.2 (gives message \\Mcl2 is not accessible, the computer or sharename could not be found) while the 192.168.0.2 machine cannot see anything (even itself) in Network Neighbourhood (message Unable to browse the network, when clicking on Entire Network). Previously with same settings as now, each could see itself but not the other. As regards the "Unable to browse the network" message, I am familiar with the Microsoft Knowledge  Base Article 193938 on this message. Been through with no result

Specsol

0
 
specsolAuthor Commented:
Further information. I got past the "Unable to browse the network" by removing and then replacing the TCP/IP. 192.168.0.2 now sees itself but not 192.168.0.1

Specsol
0
 
chadCommented:
Network neighborhood requires the use of netbios namesin win9x machines.  are you attempting to ping by IP or NetBios names?  you can try adding the computers and IP addresses to the other computers lmhost file to resolve name to IP.
0
 
specsolAuthor Commented:
Thank you kabaam

I have tried both the IP addresses and the names, with & without LMHOST files to resolve the names. No joy in any case

specsol
0
 
chadCommented:
from both machines
ping 192.168.0.1
ping 192.168.0.2
ipconfig /all

Do you have any type of antivirus running?  I have seen some that have a basic firewall service that blocks these type of comms.
check the workgroup names on both computers.  They need to be the same
0
 
specsolAuthor Commented:
No antivirus. Neither machine connects to anything except the other machine -- except even that does not happen!

specsol
0
 
specsolAuthor Commented:
I should add that I have now had the crossover cable tested and that is OK

specsol
0
 
specsolAuthor Commented:
I have now solved the problem. I had to remove the network adaptor (RealtekRTL8139/810X) from the Device Manager of both machines, remove the driver from Windows/system and the Information file from Windows/Inf/Other. Rebooting then autodetected the cards and installed drivers. System then worked.

My thanks to  LucF and Kabaam for their help

specsol
0
 
LucFCommented:
Hmm, a forrest through the trees thingy ;-)

Glad you solved your problem.

LucF
0
 
chadCommented:
ditto, glad to hear that you now have you network working like it should.
If you would like a refund of your points, post a zero point question to the Community support Topic area.
Asking for a PAQ/refund as you solved the problem yourself.  Include a link to this question.
good luck,
CHAD
0
 
Computer101Commented:
PAQed, with points refunded (125)

Computer101
E-E Admin
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

  • 10
  • 6
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now