enabling quota problem.


Hello,

I've a problem while trying to enable quotas using "quotaon -a".

The error message is every time:

quotaon: using //quota.user on /dev/hda3 [/]: Invalid argument

quotacheck is running without errors and is generating "aquota.user".

Is there any option/config possibility to say the server to generate quota.user and not aquota.user?

Or any idea what to do?

Thanks
j79
LVL 2
j79Asked:
Who is Participating?
 
owensleftfootConnect With a Mentor Commented:
Edit the file /etc/fstab:

Add userquota after defaults, using lower case.


1.)  /dev/hda7   /home  ext2  defaults, userquota     1 2

Then create two files for the partions

2.) touch   /home/quota.user
3.) touch  /home/quota.group
4.) chmod 600 /home/quota.user
5.) chmod 600 /home/quota.group

You must reboot the system.

6.) edquota  –u  sam ( username )

Soft limit = Maximum amount of disk disk usage a quota user can have on
the system.

Hard limit =  A user cannot go beyond. If this limit is reached, the
user will not be able to use any additional space.
0
 
j79Author Commented:
Done as you said, also done a checkquota after reboot.

# quotaon -a
quotaon: using /home/quota.group on /dev/hda3 [/home]: Invalid argument
quotaon: using /home/quota.user on /dev/hda3 [/home]: Invalid argument

It's creating aquota.user and aquota.group in the home directory and not quota.user and quota.group

j79



0
 
owensleftfootCommented:
quota.user etc are from version 1 of quota. Version 2 uses aquota.user etc.
What does quotaon -v -a tell you?
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
j79Author Commented:

Hello owensleftfoot,

quotaon -v -a
quotaon: using /home/quota.group on /dev/hda3 [/home]: Invalid argument
quotaon: using /home/quota.user on /dev/hda3 [/home]: Invalid argument

"quota -V" tells:
Quota utilities version 3.03.
Compiled with RPC and EXT2_DIRECT
Bugs to mvw@planets.elm.net, jack@suse.cz

I noticed that hda3 seems to use ext3 ? Does this matter anything?

0
 
owensleftfootCommented:
Could you post your /etc/fstab?
0
 
j79Author Commented:

The original fstab is/was:

/dev/hda3       /               ext3    defaults,usrquota       1 1
/dev/hda1       /boot           ext3    defaults        1 2
/dev/hda2       swap            swap    pri=42          0 0
devpts          /dev/pts        devpts  mode=0620,gid=5 0 0
proc            /proc           proc    defaults        0 0

0
 
owensleftfootCommented:
The example I gave you was for enabling quotas on a mounted /home partition. You need to create aquota.user in the / directory of your filesystem.
http://www.tldp.org/HOWTO/Quota.html will take you through things step by step.
0
 
j79Author Commented:

thank you owensleftfoot, but it's not helping me.
aquota.user is being crated automatically after running a quotacheck, as I said above.
But if I try to start/enable quota it's not working because of expecting quota.user.
I also tried a link for quota.user to aquota.user, still without success.

j79
0
 
owensleftfootCommented:
You can force quotaon to use either version 1 quota (quota.user) or version 2 (aquota.user) with the -F switch. To use quota.user files use quotaon -a -F vsfold
To use aquota.user use quotaon -a -F vsfv0
0
 
j79Author Commented:


I did this 2-3 steps and it works now, don't ask me why.

rm aquota.user
touch quota.user
chmod 600 quota.user
quotacheck -uvma
quotaon -a

Anyway, thank you for the assistance owensleftfoot.

j79

 
0
All Courses

From novice to tech pro — start learning today.