Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

enabling quota problem.

Posted on 2004-03-21
10
Medium Priority
?
701 Views
Last Modified: 2013-12-15

Hello,

I've a problem while trying to enable quotas using "quotaon -a".

The error message is every time:

quotaon: using //quota.user on /dev/hda3 [/]: Invalid argument

quotacheck is running without errors and is generating "aquota.user".

Is there any option/config possibility to say the server to generate quota.user and not aquota.user?

Or any idea what to do?

Thanks
j79
0
Comment
Question by:j79
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
10 Comments
 
LVL 17

Accepted Solution

by:
owensleftfoot earned 500 total points
ID: 10645703
Edit the file /etc/fstab:

Add userquota after defaults, using lower case.


1.)  /dev/hda7   /home  ext2  defaults, userquota     1 2

Then create two files for the partions

2.) touch   /home/quota.user
3.) touch  /home/quota.group
4.) chmod 600 /home/quota.user
5.) chmod 600 /home/quota.group

You must reboot the system.

6.) edquota  –u  sam ( username )

Soft limit = Maximum amount of disk disk usage a quota user can have on
the system.

Hard limit =  A user cannot go beyond. If this limit is reached, the
user will not be able to use any additional space.
0
 
LVL 2

Author Comment

by:j79
ID: 10647881
Done as you said, also done a checkquota after reboot.

# quotaon -a
quotaon: using /home/quota.group on /dev/hda3 [/home]: Invalid argument
quotaon: using /home/quota.user on /dev/hda3 [/home]: Invalid argument

It's creating aquota.user and aquota.group in the home directory and not quota.user and quota.group

j79



0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10648133
quota.user etc are from version 1 of quota. Version 2 uses aquota.user etc.
What does quotaon -v -a tell you?
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 2

Author Comment

by:j79
ID: 10649105

Hello owensleftfoot,

quotaon -v -a
quotaon: using /home/quota.group on /dev/hda3 [/home]: Invalid argument
quotaon: using /home/quota.user on /dev/hda3 [/home]: Invalid argument

"quota -V" tells:
Quota utilities version 3.03.
Compiled with RPC and EXT2_DIRECT
Bugs to mvw@planets.elm.net, jack@suse.cz

I noticed that hda3 seems to use ext3 ? Does this matter anything?

0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10649154
Could you post your /etc/fstab?
0
 
LVL 2

Author Comment

by:j79
ID: 10649190

The original fstab is/was:

/dev/hda3       /               ext3    defaults,usrquota       1 1
/dev/hda1       /boot           ext3    defaults        1 2
/dev/hda2       swap            swap    pri=42          0 0
devpts          /dev/pts        devpts  mode=0620,gid=5 0 0
proc            /proc           proc    defaults        0 0

0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10649354
The example I gave you was for enabling quotas on a mounted /home partition. You need to create aquota.user in the / directory of your filesystem.
http://www.tldp.org/HOWTO/Quota.html will take you through things step by step.
0
 
LVL 2

Author Comment

by:j79
ID: 10649604

thank you owensleftfoot, but it's not helping me.
aquota.user is being crated automatically after running a quotacheck, as I said above.
But if I try to start/enable quota it's not working because of expecting quota.user.
I also tried a link for quota.user to aquota.user, still without success.

j79
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10649676
You can force quotaon to use either version 1 quota (quota.user) or version 2 (aquota.user) with the -F switch. To use quota.user files use quotaon -a -F vsfold
To use aquota.user use quotaon -a -F vsfv0
0
 
LVL 2

Author Comment

by:j79
ID: 10655660


I did this 2-3 steps and it works now, don't ask me why.

rm aquota.user
touch quota.user
chmod 600 quota.user
quotacheck -uvma
quotaon -a

Anyway, thank you for the assistance owensleftfoot.

j79

 
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question