• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3946
  • Last Modified:

Installed Tomcat, cannot start: StandardServer.await: create[8005]: java.net.BindException: Address in use: JVM_Bind

Upon installation I not the following in my logs after Tomcat tries to start and fails.

[INFO] Http11Protocol - -Initializing Coyote HTTP/1.1 on port 8080
[INFO] Catalina - -Initialization processed in 1390 ms
[INFO] StandardService - -Starting service Catalina
[INFO] StandardEngine - -Starting Servlet Engine: Apache Tomcat/5.0.19
[INFO] StandardHost - -XML validation disabled
[INFO] StandardHost - -Create Host deployer for direct deployment ( non-jmx )
[INFO] StandardHostDeployer - -Processing Context configuration file URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\conf\Catalina\localhost\admin.xml
[INFO] PropertyMessageResources - -Initializing, config='org.apache.struts.util.LocalStrings', returnNull=true
[INFO] PropertyMessageResources - -Initializing, config='org.apache.struts.action.ActionResources', returnNull=true
[INFO] PropertyMessageResources - -Initializing, config='org.apache.webapp.admin.ApplicationResources', returnNull=true
[INFO] StandardHostDeployer - -Processing Context configuration file URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\conf\Catalina\localhost\manager.xml
[INFO] StandardHostDeployer - -Processing Context configuration file URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\conf\Catalina\localhost\balancer.xml
[INFO] StandardHostDeployer - -Installing web application at context path  from URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\ROOT
[INFO] StandardHostDeployer - -Installing web application at context path /tomcat-docs from URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\tomcat-docs
[INFO] StandardHostDeployer - -Installing web application at context path /jsp-examples from URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\jsp-examples
[INFO] StandardHostDeployer - -Installing web application at context path /servlets-examples from URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\servlets-examples
[INFO] StandardHostDeployer - -Installing web application at context path /webdav from URL file:E:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\webdav
[INFO] Http11Protocol - -Starting Coyote HTTP/1.1 on port 8080
[INFO] ChannelSocket - -JK2: ajp13 listening on 0.0.0.0/0.0.0.0:8009
[INFO] JkMain - -Jk running ID=0 time=0/31  config=E:\Program Files\Apache Software Foundation\Tomcat 5.0\conf\jk2.properties
[INFO] Catalina - -Server startup in 2985 ms
StandardServer.await: create[8005]: java.net.BindException: Address in use: JVM_Bind
java.net.BindException: Address in use: JVM_Bind
      at java.net.PlainSocketImpl.socketBind(Native Method)
      at java.net.PlainSocketImpl.bind(Unknown Source)
      at java.net.ServerSocket.<init>(Unknown Source)
      at org.apache.catalina.core.StandardServer.await(StandardServer.java:534)
      at org.apache.catalina.startup.Catalina.await(Catalina.java:657)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:617)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:297)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:398)
[INFO] Http11Protocol - -http11protocol.pause
[ERROR] Catalina - -Catalina.stop <LifecycleException:  Cannot find message associated with key coyoteConnector.protocolHandlerPauseFailed>LifecycleException:  Cannot find message associated with key coyoteConnector.protocolHandlerPauseFailed
      at org.apache.coyote.tomcat5.CoyoteConnector.pause(CoyoteConnector.java:1462)
      at org.apache.catalina.core.StandardService.stop(StandardService.java:560)
      at org.apache.catalina.core.StandardServer.stop(StandardServer.java:2379)
      at org.apache.catalina.startup.Catalina.stop(Catalina.java:643)
      at org.apache.catalina.startup.Catalina$CatalinaShutdownHook.run(Catalina.java:686)

I recently installed JDK1.3.1.11, Hibernate, Eclipse and MySQL if that helps.

Many thanks :)
0
micknorman11
Asked:
micknorman11
2 Solutions
 
Nick_72Commented:
Possibly there's another service running on port 8080 on the computer. Try to change the port to something else (for example 8090) in the server.xml file.

/Nick
0
 
Mayank SAssociate Director - Product EngineeringCommented:
I guess Nick is correct. If you don't know about how to modify the server.xml file, then have a look here:

http://jakarta.apache.org/tomcat/tomcat-3.3-doc/serverxml.html

http://www.cs.tcd.ie/courses/baict/bass/4ict12/tomcat.html
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
micknorman11Author Commented:
Thanks for the input. I'll try the ideas when I get home.

I did try and telnet to 8080 and there was no response.
0
 
Mayank SAssociate Director - Product EngineeringCommented:
Please proceed with that recommendation.
0
 
Nick_72Commented:
As mayankeagle
0
 
fsm289Commented:
Just to add another solution to problem for future users
I had a similar issue on a server with two different versions of tomcat running.
Solution was to change server port from 8005 to 8006, not the tomcat service port 8080 as my second tomcat service port was already on 8200.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now