Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

**URGENT** IIS HTTP 500 Internal Server Error

Posted on 2004-03-22
15
Medium Priority
?
1,059 Views
Last Modified: 2010-04-13
Hi,

This question is very urgent as I have a problem with a website that my company hosts (or needs to host!). The setup is a bit complicated to explain, so I'll try my best.

The setup:

Windows 2000 Server SP3 (Can't go to SP4 yet - not the standard. But if there is a fix in there which fixes this I may have a case to do it)
IIS 5.0
.NET Framework 1.1
This server is in a DMZ (firewall either side of it - 1 between my companies network and 1 between the internet and it)
The internet firewall also using NAT, so it's something like this (for example):

Internet (212.212.1.1) -> Server IIS Website (192.168.1.1)

This server has multiple websites setup on it, each with a different IP, the default not running and 3 others. 2 of them work fine. The 3rd doesn't just always gives me a HTTP 500 Internal Server Error. Turning on show friendly error messages just gives me "Internal Server Error". Bear in mind that this server also has IPs 192.168.1.0 and 192.168.1.2. Then each of these IPs are NATed to internet IPs which have hostnames on the internet (for the different websites). These hostnames are in the host header fields of each in IIS too.

All I am trying to get to work (firstly) is the showing of a simple HTML page, but it won't even show that! It works when I create a virtual directory to this website that doesn't work, from a website which does, but not as the actual website.

So any ideas? I have seriously tried everything... anonymous access is enabled, NTFS rights are everyone, most settings are default, running on port 80.... Could the fact that we have 3 websites running on the same box make a difference? I've been through MSKB article regarding this error, but none of the "fixes" fix it. I guess it could be some werid routing error... but what I have no idea. I really just have no ideas left!

Please help.
Thanks
0
Comment
Question by:simonprr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 3
  • 3
15 Comments
 
LVL 19

Accepted Solution

by:
Zaheer Iqbal earned 2000 total points
ID: 10647497
Ok have you tried stopping the other two webistes for a while and then see what happens..
Also try restarting the IIS server once ...
What happens if u try to access the website internally/locally??
0
 
LVL 3

Author Comment

by:simonprr
ID: 10647516
Yes, with the other 2 stopped still the same problem. I have rebooted the box a few times aswell. And from internally/locally I get the same error unfortunately.

It doesn't say any details either, like error in asp or anything.
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 10647556
So if you getting the same error locally, then there is a probelm with the setup..
What about going through computer management then try to show the site does it work that way..
Also try it on the box ie.. http:\\localhost\...
Does that have the same problem..
You have set up the correct rights for that web folder as well...
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LVL 3

Author Comment

by:simonprr
ID: 10647609
Well, because the default website (which listens on localhost) is stopped, I can't do http://localhost. This website listens on another IP address on the same box. Because the box has no DNS (cause in the DMZ it can't see our DNS server) I have put in the hostname of the website (on the internet) and the local IP address this server is listening on in the hosts file. Then I can go into computer management \ internet service manager and go into the website and right click browse on the html file in there. This of course gives me the HTTP 500 error again. However, this method works for the other websites.
0
 
LVL 3

Author Comment

by:simonprr
ID: 10647616
This error is just so annoying, it doesn't tell me anything. There is so many resolutions or fixes for this problem it is unbelievable. Any way to get some more detail of whats going on, like maybe a IIS error log?
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 10647624
0
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 10647649
Ok I think its a rights issue on that Web folder.. Double check rights on folder..
0
 
LVL 3

Author Comment

by:simonprr
ID: 10647652
Pete, trouble is I don't have any ASP pages or anything. Only a simple HTML page... it's more of a general problem I believe than a problem with a certain type of pages. Everything gives the HTTP 500 error.
0
 
LVL 3

Author Comment

by:simonprr
ID: 10647766
Just checked the rights on the web folder. I guess you mean the "web sharing" tab? On the folder it has "/" listed and when I edit properties I have read ticked and under application permissions I have scripts with a dot in it. These are the same settings that the other websites have.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 10650373
dont you need to be looking at rights from the IIS console??????
0
 
LVL 3

Author Comment

by:simonprr
ID: 10650766
Yes, but setting them through explorer is just another way of doing it.
0
 
LVL 3

Author Comment

by:simonprr
ID: 10650771
I'm beginning to think this is some kind of werid routing problem, due to the port filtering and protection of our DMZ.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 10652168
>>Yes, but setting them through explorer is just another way of doing it.

Not as far as Im aware? the only time you need to get involved with permissions in explorer is granting rights to the IUSR_machinename account all other Web permissions are handled by IIS admin
0
 
LVL 3

Author Comment

by:simonprr
ID: 10653238
No, in Explorer there is another tab called "Web Sharing".

See here: http://www.simonprr.pwp.blueyonder.co.uk/images/WebSharing.jpg
0
 
LVL 3

Author Comment

by:simonprr
ID: 10675238
I've fixed it! In the end it was a problem with the IP address assigned to the site, we have setup a new range and it all works fine. Wonder why IIS called this a HTTP 500 error though. Very strange. It could have given me a bit more info, that would have helped! oh well!

Thanks for all your help guys. I'm gonna give the points to 1stITMAN, cause he was kind of on the right lines, with the internal/externally bit.

Cheers :)
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
An overview of cyber security, cyber crime, and personal protection against hackers. Includes a brief summary of the Equifax breach and why everyone should be aware of it. Other subjects include: how cyber security has failed to advance with technol…
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question