Solved

rsynth installation/setup

Posted on 2004-03-22
5
226 Views
Last Modified: 2013-11-13
I use Mandrake 10
im trying to install rsynth... the talking program, it says words you type and stuff

i got the .tgz but it didnt have any install scripts (must be wrong thing)
so i got the rpm
boomed out ]$ rpm -Uvh rsynth-2.0-2.i386.rpm
and i get
warning: rsynth-2.0-2.i386.rpm: V3 RSA/MD5 signature: NOKEY, key ID 0fa3ca4d
error: Failed dependencies:
        libm.so.5 is needed by rsynth-2.0-2
        libc.so.5 is needed by rsynth-2.0-2

so what do i need to do to get/install them
and get it working
0
Comment
Question by:tsukasa
  • 3
  • 2
5 Comments
 
LVL 20

Expert Comment

by:Gns
ID: 10648078
The rpm is for another distro, with an old libc5... not glibc2/3 ... Go back to the tarball... Is it perhaps a collection of sourcefiles? Do you have a configure script, or perhaps a Makefile? Wait... having a look....
You should read the Readme textfile for instructions, as well as the README.linux file... But basically what you should do is unpack it, cd into the directory and
./configure
make
make check
./say --help
./say Something of your choice
make -n install  # see what it is going to do
make install     # copy program(s) to /usr/local/bin
.... But do read the readme.

-- Glenn
0
 

Author Comment

by:tsukasa
ID: 10655503
yeh it didnt have any configure or make
ill look for another one
0
 
LVL 20

Expert Comment

by:Gns
ID: 10656100
A quick google turned up several (for me at least:-) so... get one that suits you, version-wise...:)
And be prepared for some "tinkering":-)

-- Glenn
0
 

Author Comment

by:tsukasa
ID: 10656112
mmk i found a real one
after ./configure it gives me
checking host system type... configure: error: can not guess host type; you must specify one
any ideas what host i put in, i checked the config.sub but i dont see anything related to mandrake
0
 
LVL 20

Accepted Solution

by:
Gns earned 50 total points
ID: 10656350
Try run
./configure --help
to see possible flags (where to install to, system type specification etc).
Why not try
./configure --host=linux
...;-)

-- Glenn
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question