Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 454
  • Last Modified:

Having trouble with Internet connection and file sharing.

Hello all,
I have a fairly simple issue or at least this was what I had thought at first...
I have 2 PC's running dual boot Win98se+WinXP pro.
PC A (server) has the DSL modem and the internet connection.
PC B (client) is the computer that wishes to access the web via PC A.
Now, assuming I am running WinXP on *both*, I have read through an article on ICS and followed it line by line, but it simply won't fly...!! I have generic ethernet nics on both PC's (kingston 10/100Mb with Intel chipset. I have not installed their propritary drivers since they were identified by the OS).
Both computers are connected through a crossed network cable.
I need some guidance here from someone who can put it simple enough so that an ignorrant :-) like me can understand it.
On PC A(server), under network properties I have 2 connections. One for the web, and one for the LAN which is godd & enough... I hope...
In PC B(client) I have 1 connection under network properties, which is the LAN.
What I wish to achieve is ICS and file sharing if possible.
Things that I have tried already:
-------------------------------------
Configured PC A as 192.168.0.1 subnet 255.255.255.0 in the LAN connection and PC B as 192.168.0.2 with same subnet, default gateway= 192.168.0.1 DNS server= 192.168.0.1.
When I try to ping PC A from B I get a timeout and vice versa...(but not on Win98se, so it not a HW problem).
I have noticed that in PC A(server) in the DSL connection, I do not have a 'Authentication' tab under the properties of that connection. Is that good or doesn't matter?
Note: when running Win98se on both PC's I have file sharing without problems but not ICS.
Also, my DSL modem uses PPoA and not PPoE.
--------------------------------------
I have been thinking of doing this from scratch, clean install of all connections, but how do I do it "best practice" way?


Thanks to all who reply.
0
liorde
Asked:
liorde
  • 6
  • 4
  • 3
  • +3
4 Solutions
 
MaBCommented:
Hi liorde,
You probably have the XP firewall enabled on your LAN connections. Disable it and you should be home free.

BR MaB.
0
 
MaBCommented:
Right click your LAN connection choose properties and (i believe) the advanced tab. There choose to disable the "Protect this computer..." checkbox.

I don't have XP at work so this is out of memory. I hope I'm correct about the tab names.

MaB
0
 
liordeAuthor Commented:
Hi again.
The XP firewall, is enabled on PC A(server) and only on the connection that goes outside to the internet. On the LAN connection on PC A and B the firewall is not selected.

Any other ideas?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
rafael_accCommented:
Trust me on this ... :)!
You said (...) (kingston 10/100Mb with Intel chipset. I have not installed their propritary drivers since they were identified by the OS (...)

Well ... install them!!

Rafael.
0
 
WillHudsonCommented:
Have you tried running the network connection wizard on both PC's? I've got almost the same setup as you and after running it they both work fine.
0
 
liordeAuthor Commented:
I think I should go with the "disaster" option which means to reinstall the whole package from scratch, i.e. nic drivers, define the connections from scratch using the wizards.
Did all this before, dont know how it will be different this time, but I do not have much to loose here anyway... :-|
I will try it and post results here...
0
 
GenestetCommented:
Are you manually configuring all of the NICs or are you letting the wizards do it? You might set everything back to auto assign (IP and DNS) and run the ICS once more on the 2 NIC computer.

Good luck,
Bob
0
 
rafael_accCommented:
You are right, liorde. Especialy about the drivers. Some times the drivers wich xp automaticaly installs don'w work as they should. It's a best practice to install drivers wich have been packaged with your hardware.

0
 
MaBCommented:
Have you done ipconfig /all just to check if the IP addresses really are what you have set them to. I had some problem at home with XP removing the ICS internal IP (192.168.0.1) and replacing it with something else that did not work at all. When I ran the guide "Create a home or small office network" from scratch it worked fine.

MaB
0
 
liordeAuthor Commented:
to MaB.
Yes, I ran IPCONFIG to verify that PC A and B have the correct IP settings. Funny though, I remember now that when i pinged PC B from A i got a "Hardware Error" return code. And when i did the other way around I simply got timeout. But this cannot be a HW error, because the nic's are fine, I mean when Win98se is on in both PC's I can file share, so it means that the nics are good right??

0
 
chadCommented:
the xp firewall should be disabled.  Although it appears to only effect the web connection... it will have an effect on other connections.
Are you sure that the cable you are using is in fact a crossover cable that isn't faulted?  Do you have a way of testing it?
0
 
liordeAuthor Commented:
kabaam,
Thank-you for the reply.
This is what I cam up with...
I got it to work like this:
PC A (server):
Disabled Firewall on Dial Up and on LAN
specified static IP as 192.168.0.1 with the default subnet

PC B(client):
Now I see 2 icons in the network properties
1. Internet Gateway
2. LAN connection
Now, If I assign a static IP to PC B such as 192.168.0.2 with the defualt subnet, the gateway icon disappears and I cannot connect to the internet.
If I choose "obtain automatic IP..." then the internet gateway icon returns and now I can connect to the web.

I have not updated drivers for the nics or anything...

My questions:
1. What gives? How does it work all of a sudden??
2. What do I need a static IP in PC A, if PC B does not use it anywhere?
3. What is the IP on PC B? How do I ping it?
4. If I am hosting an online game on PC B, how can people connect to me? Which IP do I givew them?
(Question 4 is the most important here :-))

Thanks again...!
0
 
chadCommented:
1 the firewall doesn't protect a connection... it protects the computer... not nic specific
2 pc b uses pc a as a default gateway. it needs to be static so that pc b can easily find it
3 click start/run    type CMD        type IPCONFIG /ALL  
   this will give you the ip of the local machine
   ICS uses a mini DHCP to hand out addresses
4  I don't do much gaming... let me get back to you

hth
CHAD
0
 
liordeAuthor Commented:
Thank-you for the quick repl kabaam...!
So on PC B (client) there MUST be 2 icons in the network properties? One for the internet gateway and the second for the LAN? I noticed that enabling the firewall on PC A on the dial up connection does not bother PC B to connect to the internet.
This is my config on PC B:
-----------------------------
      Dhcp Enabled. . . . . . . . . . . : Yes
      Autoconfiguration Enabled . . . . : Yes
      IP Address. . . . . . . . . . . . : 192.168.0.2
      Subnet Mask . . . . . . . . . . . : 255.255.255.0
      Default Gateway . . . . . . . . . : 192.168.0.1
      DHCP Server . . . . . . . . . . . : 192.168.0.1
      DNS Servers . . . . . . . . . . . : 192.168.0.1

How do i do file sharing now, for both PC's?
and last question, if PC A (server) is running Win98se, can I still have ICS?

Thanks again.
0
 
chadCommented:
98se can function as ICS server.
I don't know about the two icons thing... may depend on the ISP format you are using.  I have PPPoE and the 'client' computers only have one icon to connect to 'server'

the purpose of the firewall is to allow access to the internet and block other stuff not normal to internet usage.
A ping and file access , such as file sharing are considered unsandard internet usage.  Therefore the ICF was blocking those things.
file sharing:
http://www.homenethelp.com/web/howto/net-share-98.asp
0
 
liordeAuthor Commented:
Thank-you Kabaam.
How do I define and where do I define it, so that both computers will be on the same workgroup so that they can file share. When they both runWin98se file sharing works like a charm, but not in XP. For some reason I cannot communicate with the other mahine.

Please advise...
0
 
MaBCommented:
To specify workgroup in XP:
Right click "My computer" choose properties and "computer name". There you should have a button where you can change computer name and workgroup. (Out of memory since I don't have XP at work but it's there somewhere..)

To enable file and printer sharing right click your connection that you want to allow that for, choose properties and check that the file and printer sharing checkbox is checked.

BR MaB
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 6
  • 4
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now