Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

conneting to VNC from behind proxy

Posted on 2004-03-22
2
Medium Priority
?
1,131 Views
Last Modified: 2011-09-20
I installed ultravnc at home, and it's been working fine everywhere except for where I am now.  This puzzled me until I remembered that here we're behind a proxy, so I'm guessing that's preventing me from connecting to my home computer from here.  when I type http://myipaddress:5800, the applet loads, prompts for password, and then displays a "network error: could not connect to server: myipaddress:5900".  I was wondering if there was a way to make this work.  If you can help, thanks, it's greatly appreciated.

Jonathan
0
Comment
Question by:FredPiano
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 

Expert Comment

by:PJRivr
ID: 10654593
Possibly is a firewall issue blocking the port.
Found this link:
 http://www.calwell.ca/articles/a0028.php
Details how to change the port configuration so that it can use port 80.  According to UltraVNC site, they referred any configuration changes to the RealVNC site which is the instructions in the URL above.  The registry item may have a different name in conjunction with UltraVNC, but should be found in the same location.
Good luck,
Pj.
0
 
LVL 1

Accepted Solution

by:
htjiawi earned 420 total points
ID: 10910160
To connect to your VNC from behind a restricted proxy, you need to setup additional layer of tunneling software. As long as you are still allowed to access SSL/https than this can be done. You will need to do the following

ON SERVER:
- install ORENOSP:
  http://hp.vector.co.jp/authors/VA027031/orenosp/index_en.html
- generate certificate using the same software package
- configure sproxy.conf to point to your VNC service
- open port 443 (https)

ON CLIENT
- configure otunnel.conf (found from same website location)
- make sure your otunnel.conf is consistence with sproxy.conf
- run otunnel.exe -c
- run your remote client

with this setting it is even more secure than your previous setting since you are using SSL/https and your privacy is protected as well.

Good Luck
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question