Solved

Disabling NT4 Auto-Login

Posted on 2004-03-22
4
759 Views
Last Modified: 2013-12-04
heres my problem:
I need to install a new software suite on a win nt box, and the machine is currently setup to auto-login. The account that is automaticly logged into is not the admin account. the software is giving me errors during install, after contacting the software vendor, they determined i have to have administrative rights to install it (wasnt realy shocked at that).this is a new client, so i wasnt the one that setup the auto login in the first place, and have never setup or worked with the auto login feature. Can someone tell me how i can disable this feature? Ive found a few articles on how to enable it and i could probly do some reverse engineering but would like to get expert advice before trying that. Thanks
0
Comment
Question by:daveg232
  • 4
4 Comments
 
LVL 12

Accepted Solution

by:
trywaredk earned 50 total points
ID: 10650485
You don't need to disable autologon.

Step-by-Step Guide to Using Secondary Logon in Windows 2000 (runas.exe)
http://www.microsoft.com/windows2000/techinfo/planning/management/seclogon.asp

HOW TO Enable and Use the RunAs Command When Running Programs in Windows
http://support.microsoft.com/default.aspx?scid=kb;en-us;294676

You have to start the runas-service if you want to use runas.exe
http://www.microsoft.com/windows2000/en/professional/help/default.asp?url=/windows2000/en/professional/help/sys_srv_secondary_logon.htm

Runas has several parameters:
1. Start / Run
2. Input CMD
3. Press Enter
4. Input RUNAS /?
5. Press Enter
6. --- find the parameters you want to use ---
7. Input EXIT
8. Press Enter.

Remember NOT to use runas with administrators logon in a batch-job, because then you have to input administrators password, thus compromizing your security.
Instead use RunAs Professional
http://www.mast-computer.de/

Many Regards
Jorgen Malmgren
IT-Supervisor
Denmark

:o) Your brain is like a parachute. It works best when it's open
0
 
LVL 12

Expert Comment

by:trywaredk
ID: 10650502
Automatic Logon to Windows NT, 2000 and XP
http://www.winguides.com/registry/display.php/13/
0
 
LVL 12

Expert Comment

by:trywaredk
ID: 10650514
4. Find the string value named 'AutoAdminLogon' and set it to '0' to disable it.
0
 
LVL 12

Expert Comment

by:trywaredk
ID: 10650588
:o) Glad I could help you - thank you for the points
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No security measures warrant 100% as a "silver bullet". The truth is we also cannot assume anything but a defensive and vigilance posture. Adopt no trust by default and reveal in assumption. Only assume anonymity or invisibility in the reverse. Safe…
Users of Windows 10 Professional can disable automatic reboots using the policy editor. This tool is not included in the Windows home edition. But don't worry! Follow the instructions below to install (a Win7) policy editor on your Windows 10 Home e…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question