Solved

Applications require admin permissions....

Posted on 2004-03-22
3
323 Views
Last Modified: 2010-03-18
I am setting up a Windows Small Business Server 2000 server with about 15 client workstations.  These client workstations locally run a couple of applications, one of them being Maximizer 3.0, and the other being an in-house software application.  I get errors when trying to run either of these applications on a workstation if I am logged in as a "domain user".  When I login as an administrator, the applications run fine.

Both of these applications use network paths to get data from.  However, the Maximizer application would not run locally (not using any network drives) on a workstation using a "domain user" account either.

I know this question is sort of broad, but does anyone know what I can do to allow "domain users" to run these applications.  Anything I can try?

Thanks,

Brian
0
Comment
Question by:Brian1
  • 2
3 Comments
 
LVL 7

Accepted Solution

by:
Isigow earned 500 total points
ID: 10652009
Have you tried adding the specific user who will be using the machine to the local administrator group?

Isi
0
 
LVL 9

Expert Comment

by:jamesreddy
ID: 10652072
Well...I had a similar problem on my student's PCs where they needed local administrator privelages to run some applications on their computers.  The only workaround that was an option for me was to add Domain Users to the local Administrators group on the PCs.  I then locked down the PCs with group policies to prevent the local administrative access from becoming a problem like disabling the Windows Installer and such.

One other thing you can try...add the Domain Admins to the local Power Users group.  I have seen SOME of our applications begin working after that, and of course it is preferable to giving out local administrative rights.  If it would have worked for ALL of our programs, I would have done it.

Last idea...One of the things that causes problems with the Domain Users is that they do not gain full control of Program Files on he C drive.  That is likely your problem.  Try installing your application in a root directory like c:\program_name.  Usually that will override most of the admin security since Program Files is not being granted access to.

James
0
 
LVL 9

Expert Comment

by:jamesreddy
ID: 10652075
Second option should be add Domain Users to Power Users, not Domain Admins.,
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
FIPS stands for the Federal Information Processing Standardisation and FIPS 140-2 is a collection of standards that are generically associated with hardware and software cryptography. In most cases, people can refer to this as the method of encrypti…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now