?
Solved

why can i not access http://ABC1 but can access http://ABC1/SUSadmin ?

Posted on 2004-03-23
6
Medium Priority
?
594 Views
Last Modified: 2010-04-20
can somebody explain to me why if i type http://ABC1/SUSadmin i get the SUS administration page but if i type in http://ABC1 i get the message that "you are not authorized to view this page". the page http://ABC1/SUSadmin is on our intranet so i thought that by typing http://ABC1 i could browse this directory.
0
Comment
Question by:exdos
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 27

Expert Comment

by:BigRat
ID: 10656821
Webserver? Apache?

It looks as if the defaiult directory (htdocs) has no index.html page, or whatever is set is not accessible (what Operating system are you using?), and thete is no .htaccess file.

0
 

Author Comment

by:exdos
ID: 10656961
sebserver (iis)
i am using windows 2000 server
thanks
0
 
LVL 12

Expert Comment

by:rcmb
ID: 10660408
If SUSadmin is a subweb of ABC1 then the permissions are most likely different. In IIS ensure you have the security settings correct and that you have the correct default document set. Under documents check the files listed and make sure you have the same file available in your website.

Go to the inetpub directory and check the NTFS permissions on the wwwroot folder and make sure you have permission to access the folder. The SUSadmin should be a subdirectory under wwwroot and more than likely has unique permissions set on it.

RCMB
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 17

Expert Comment

by:Tacobell777
ID: 10662545
If you do not have directory browsing enabled then you need a default document in the directory your accessing.
0
 
LVL 38

Expert Comment

by:yuzh
ID: 10664251
"if i type http://ABC1/SUSadmin i get the SUS administration page but if i type in http://ABC1 i get the message that "you are not authorized to view this page". the page http://ABC1/SUSadmin is on our intranet so i thought that by typing http://ABC1 i could browse this directory. "

Have a look at your access control file (typical name access.conf or .htaccess file under the dir).

they might has soemthing like:

 <Location /SUSadmin/>
    order deny,allow
    deny from all
    allow from xxx.xxx.
  </Location>

  The above setting will only allow machine in the IP range of xxx.xxx to access to "SUSadmin"
0
 
LVL 3

Accepted Solution

by:
zapthedingbat earned 1200 total points
ID: 10731536
ignore yuzh what he sugests in no way applys to windows at all.

.o0(why do people not read the thread)

Right well you have obvously installed SUS (good move)
and thats setup a virtual directory on your webserver called "SUSadmin"
this virtual directory is serving a directory somwhere on your webservers file system.

the nice thing about IIS is that it uses windows file security.
by default when you browse a page on your webserver, IIS goes and opens that page with a user called IUSR_MACHINENAME (where MACHINENAME is the name of the webserver)

now just like all users, you can control IUSR_MACHINENAME's permissions on any drive, directory or file.

what happens if you browse for a file that the IUSR_MACHINENAME user dosnt have READ permission on is IIS will display the error message that you are getting...

there are sevral posabilaties here. one being that the IUSR_MACHINENAME user dosnt have READ permissions on whatever IIS is trying to serve.

If your browsing to the server from withing your network iis might be using NTLM authentication to pick up which user is browsing it... this way IIS dosnt try to access the files its serving as the IUSR_MACHINENAME user. but uses the browsing clients credentals instead.. so the problem might be that the user your logged on as dosnt have read permissions on the files. you can stop IIS from using this NTLM authentication by unchecking the "user intigrated windows authentication" box on the "Directory Security" tab in the properties for a website or virtual directory in the IIS  Managment tool.

0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most ColdFusion developers get confused between the CFSet, Duplicate, and Structcopy methods of copying a Structure, especially which one to use when. This Article will explain the differences in the approaches with examples; therefore, after readin…
One of the typical problems I have experienced is when you have to move a web server from one hosting site to another. You normally prepare all on the new host, transfer the site, change DNS and cross your fingers hoping all will be ok on new server…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses
Course of the Month11 days, 20 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question