We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Exchange 2003 & POP3 Connector Issues

netsweeper
netsweeper asked
on
Medium Priority
4,366 Views
Last Modified: 2008-02-01
I have recently installed Windows 2003 Server SBS with Excahneg 2003.  The company that is currently using hosted POP3 accounts at their ISP.  I have tried without success to setup the POP3 connector for them but everytime I send a test email through it gets to me, and then I reply, but they never recieve a response.  At first I didn't have the POP3 connector service setup to start automanticly, but I have since corrected that.  I'm sure the server, username, and password are correct as they can get the email from a web based interface.  Anyone have any suggestions?
Comment
Watch Question

Is the POP3 still being hosted by the ISP?

If so, then that would not work.  Assuming that the company's domain name is the same on both the ISP's server and yours, when you send an email to your let's say, hotmail account, it doesn't really need the DNS records of your company.com domain to get through.  Your Exchange server will just do a DNS lookup for hotmail.com's mx record and send the email there.  IMPORTANT THING:  it's reply address will be username@company.com.

When you try to reply, the reverse happens...  It will look try to send an email to username@company.com.  When it looks up the DNS record it will see that the email server is pointing to the ISP's email server, and send it there.  Your Exchange server will not get the email unless the DNS' mx record is changed and has a lower priority number than your ISP's.

- Info

Author

Commented:
My LAN domain is somecompany.local and my internet domain is somecompany.com.  When I send the email to the 3rd party test account (a hotmail account) it recieves it and says it is going to send it back to employee@somecompany.com.  But they never recieve it on their Outlook email client.  I can then change the settings of the Outlook email client back to it's previous non exchange settings and can then recieve the email.

I hope this helps in explaing this better.
If both your ISP and you are hosting email for somecompany.com, then that means only one of the two email servers will get the email back, right?

The fact that you receive the the email on your "non exchange setting" means that the email is sent to the ISP, not your exchange server.  So...  change the DNS record so that your Exchange server is the 1st MX record it is pointing to, not your ISP's email server.

- Info

Author

Commented:
ok, I understand what your trying to tell me.  But my LAN domain is "somecompany.local" and my email addresses are all "someone@somecompany.com".  They are not the same domain name.  So I'm hosting email for somecompany.local and my ISP is hosting for somecompany.com.
yes... you just answer your own question.

>>it recieves it and says it is going to send it back to employee@somecompany.com

So if it's going back to employee@somecompany.com, then why would your Exchange server get the reply email?

- Info

Author

Commented:
Because I have configured the exchange pop3 connector to connect to that mail server and download that email into a specified users local exchange account.  Is this not what the exchange pop3 connector is for?
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Author

Commented:
These both look like what I was trying to find.  I will try them ASAP and let you know the outcome.

Thanks for the help.

Author

Commented:
Ok I'm at least getting some error messages in the Event Viewer now.  I am now getting invalid userid/password for the hosted email accounts.  I am verifying with the ISP the proper settings and if all goes well I'll award you the points.  Thanks for your help thus far.

Chris

Author

Commented:
Ok, I can now retrieve the email from our ISP but now the mail is not delivering to the exchange mailbox I have specified.  It's as if the messages download to the server and then disappear.  Any suggestions?

Commented:
I'm having the Same Issues with the Pop Connector and "Disappearing Email"

Was this ever resolved?

I have the same issues.  Email goes to never never land.
We removed the pop3 connector, recreated it .  Success, although we have lost all email that went to never never land with each forced download from the pop3 provider.
Clue:  prior to issues, email and OWA were working perfectly.  Within 10 hours major DNS errors began to occure and all email stopped being routed.  Could not login to OWA with any user accounts, even those with domain admin rights, and one with administrative rights, but...THE administrator could log in fine.

Seems there is a problem resolving the DNS.

The article above doesn't address the real problem...any more suggestions or comments would be greatly appreciated.
I have the same problem, no mail is ending up i the Exchange mailboxes but I know that they are collected from the ISP.

Commented:
I resolved my Issue by Re-Doing the Internet Connection Setup Wizard in SBS Server 2003.
I also did a re-install of Exchange Service Pack 1 for 2003 and that seemed to help also.

We actually resolved our issue by restricting the packet size in 2003.  Apparently 2003 can allow packets greater than 512kb to be transported across the network, including routers that may not be able to handle such large packet sizes.  We determined this to be the cause of the DNS errors, which in turn had completely trashed our POP3 connector install, beyond repair or re-installation.  After running the utility provided on the 2003 CD under Tools, we were able to successfully configure the POP3 Connector and retrieve mail in the respective mailboxes.  And, low and behold, NO MORE DNS ERRORS.
Your W2K3 DNS server and the remote DNS server have agreed to exchange
UDP packets > 512 bytes, but your router may not be capable of
handling this.

You can disable EDNS-0 in your W2K3 DNS server by running this command:

                dnscmd /Config /EnableEDnsProbes 0

Once you run this your W2K3 DNS server will never advertise its EDNS
capabilities and so will never receive a UDP packet > 512 bytes.

dnscmd.exe can be found in the Support Tools.

You can find more information on our support of EDNS here:

http://support.microsoft.com/default.aspx?scid=kb;en-us;828263
I got an answer from a friend that might work.

This issue is seen mostly when the user is configuring a POP3
account with a domain that is not local, for example, trying to get e-mail
down through the POP3 Connector from Comcast.net or any other ISP.

Since we are downloading e-mails on the POP3 Connector from a domain that
this server is not responsible for, we should not change the primary
address on the Default domain policy. Due to the way the POP3 Connector in
SBS 2003 works, we need add a secondary SMTP address (Not responsible) to
match the ISP's domain that we are trying to download through the POP3
Connector. After that, we can configure the User not to get updates from
the Recipient Policy and configure the primary SMTP address for that user
with the ISP's e-mail address (So the Reply-To when the users sends e-mail
is correct).

This is the description on the steps for the resolution:

Open Exchange System Manager
Expand Recipients, Recipient Policies.
Open the properties for the Default Policy.
Go to the E-Mail Addresses (Policy) tab
Right now you should have an entry for your local active directory domain
and for an X400 address.
Make sure you do not have an entry with your ISP's domain or a domain that
you are
not responsible for.
Click New, select SMTP.
In the address type the domain you are receiving e-mail for using the Pop3
Connector. (@contoso.com), Un-Check "This Exchange Organization is
responsible for
all mail delivery to this address".
Put a check on the newly added address, DO NOT CHANGE THE PRIMARY.

OK the changes and acknowledge the warnings.

Open the SBS Server Management console, click on USERS.
Find the User that is receiving the POP3 Connector e-mails and open it
(double click).
Go to the E-mail addresses tab.
Uncheck (on the bottom) "Automatically Update e-mail addresses based on the
Recipient Policy.
Make the "user@contoso.com" the Primary email, do not remove any other
address from
here.
Ok the changes.

Proceed to re-start IIS, for that, open a command prompt and type IISRESET
followed by Enter/Return.

I'm going to try this today at my customer.

Commented:
This last post from Genocide worked perfectly for me but I had to follow every direction to fix it.  I tried to cheat and not change my primary email address but that did not resolve it.  It was not until after I changed the primary email address and followed every step perfectly before I would receive mail.   Just wanted to post that update to this ticket.

Commented:
This information from Genocide78 was just what the doctor ordered. It saved me from hanging from a noose over the balcony of our office.
Thankyou.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.