Solved

I don't see the "permissions" tab when right clicking on a public folder even though I'm logged on as an administrator

Posted on 2004-03-23
11
252 Views
Last Modified: 2008-03-03
I need to change permissions on certain public folders but when I use the Outlook 2003 client and right click on the folder all I get is the summary tab. When I try to use the ESM and right click on the folder and go to properties, it states, "The object is no longer available. Press F5 to refresh the display and then try again. ID No. 80040e19." Any body have any ideas? Thanks.
0
Comment
Question by:mleziva
  • 5
  • 3
11 Comments
 
LVL 13

Assisted Solution

by:Mob-bom
Mob-bom earned 250 total points
ID: 10660686
http://support.microsoft.com/default.aspx?scid=kb;en-us;325920

The Object is no longer available. Press F5 to refresh the Display, and then try again.
ID no: 80040E19
Exchange System Manager

CAUSE
This issue may occur when the virtual server that hosts the Exadmin virtual folder runs on a port other than port 80. When the Exchange System Manager requests information about public folders, it uses port 80 for an HTTP request to the Exadmin virtual folder. When port 80 is not available, you receive the symptoms that are listed in the "Symptoms" section of this article.
RESOLUTION
To resolve this issue, use one of the following methods:
Change the Port Number
Click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
Right-click the virtual server on which the Exadmin virtual folder is located, and then click Properties.
Click the Web Site tab, and then modify the port number in the TCP Port box.
Click OK.
Move Exadmin to the Server on Port 80
If you have more than one virtual servers, one of which is set to use port 80, you can copy Exadmin to that server:
Click Start, click Run, type cmd in the Open box, and then press ENTER.
At the command prompt, type the following commands, pressing ENTER after each command:

c:
cd \inetpub\adminscripts
cscript adsutil.vbs copy w3svc/1/root/exadmin w3svc/100/root/exadmin
NOTE: The preceding command assumes that "w3svc/1" is the Web site that currently hosts Exadmin, and "w3svc/100" is the Web site to which you copy Exadmin. You must set "w3svc/100" to use port 80.

To determine which Web site is which:


At the command prompt, type the following commands, pressing ENTER after each command:

c:
cd \inetpub\adminscripts
cscript adsutil.vbs enum_all>AdsutilOutput.txt
notepad AdsutilOutput.txt
In Notepad, click Find on the Edit menu. In the Find what box, type the name of the HTTP virtual server that is running on port 80 and to which you want to copy Exadmin, and then click OK. You may see output that is similar to the following, with the name of the virtual server selected:

[/W3SVC/100]
KeyType                         : (STRING) "IIsWebServer"
ServerState                     : (INTEGER) 2
ServerComment                   : (STRING) "MyNewHTTPServer"
ServerAutoStart                 : (BOOLEAN) True
ServerBindings                  : (LIST) (1 Items)
  "192.168.0.11:80:"

SecureBindings                  : (LIST) (1 Items)
  "192.168.0.11:443:"

MaxConnections                  : (INTEGER) 2000000000
ConnectionTimeout               : (INTEGER) 900
DefaultLogonDomain              : (STRING) "KAZOOCONSULTING"

Note that the name of the server is listed on the ServerComment line as MyNewHTTPServer, and the corresponding server number is listed at the top as /W3SVC/100. In this example, /W3SVC/100 is the server to which you will copy the Exadmin virtual folder.
Determine the server that currently holds the Exadmin virtual folder. To do so, establish the name of the virtual server under which Exadmin is listed in Internet Services Manager. Repeat step B to find out the server number. This is the server from which you will copy Exadmin.
Restart Internet Information Services and Exchange services.
0
 

Author Comment

by:mleziva
ID: 10661546
Click the Web Site tab, and then modify the port number in the TCP Port box.
Click OK.

I tried this MS article and there is no web site tab under properties. There are 5 tabs listed as

Virtual Directory
Documents
Directory Security
HTTP Headers
Custom Errors

The Public, Exchange, and Exadmin web sites all have ERROR signs next to them.
0
 
LVL 13

Expert Comment

by:Mob-bom
ID: 10661856
Internet Information Services > locate the Exadmin virtual folder, move up and out the tree to Default Web site > Right-click for properties.

The web site tab is in the properties of the virtual server that holds the exadmin folder
0
 

Author Comment

by:mleziva
ID: 10662129
OK. TCP Port was set to 80. Description is "default web site", IP Addresses are "(all unassigned)", connections are "unlimited" and logging is enabled.
 There is only one virtual server.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 13

Expert Comment

by:Mob-bom
ID: 10662259
Which Exchange do you have?
Have you ever been able to change permissions or did this start after a specific event?

Is the URLScan tool installed?
Does your domain name have ".com" in it?
http://support.microsoft.com/?id=328659
0
 

Author Comment

by:mleziva
ID: 10664123
Exchange 2000. I have only been here a short time and have never had to change the permissions. I did find out that the person who originally setup the folder has since left and their account has been deleted. Assuming they were the original owner of the folder would this lock out everyone else? I made a backup of the folder, created a new one and imported the sub folders. I cannot however delete the old folder. Even if I go to the M: drive and try to access the permissions for the public folder I am denied access. Is this normal?
0
 
LVL 13

Expert Comment

by:Mob-bom
ID: 10671048
Do -not- change permissions on the M drive.

Using ESM, try to propogate permissions for yourself down the tree
0
 
LVL 3

Accepted Solution

by:
spikeworld earned 250 total points
ID: 10671590
sounds like you do not have permissions in the exchange tree.. go to exchange system administrator, right click on the top of the exchange tree (create a group to assign permissions first, like "exchange admins"  add yourself to the group)  click on delegate control, assign the group you just made.. assign permission "exchange full admins"  wait for at least an hour for exchange to propogate rights..
0
 
LVL 13

Expert Comment

by:Mob-bom
ID: 10939078
Permissions is the issue here, which I pointed out and instructed to correct and then spikeworld gave more detailed instructions.  Unless mleziva says otherwise, I believe the information provided most likely answered the question.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Use email signature images to promote corporate certifications and industry awards.
Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now